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As a small token of thanks for buying this book I would like to offer a FREE
 bonus gift to all my readers. I am offering a FREE
 online VBA macros course called How to Record Macros in Excel
 .

In this FREE
 course you will learn:


	How to record a macro to eliminate manual repetitive Excel tasks

	How to execute a macro by:




	Using the Macro Dialog Box




	Using the Visual Basic Editor

	Clicking a button

	Clicking a shape



Once you have completed the course you will be able to:


	Automate Excel tasks easily

	Save valuable time

	Advance your Excel skill
 s



You can register for this FREE
 online VBA course by clicking on the below link and entering your details now.


Register for the free VBA course



INTRODUCTION

I wrote this book with the sole goal of making you more productive and efficient in Excel. In this book you will find all the essential tools, features, formulas and shortcuts to make your life easier and more productive in Excel. Using some or all of these tools I mention in the book will save you more time, create less workload, increase productivity and reduce stress levels in your work as well as allowing you to work smarter. I have only chosen the very best tools and features available in Excel which have made my life easier and some of these are unknown to a vast majority of people. I will now be sharing these secrets with you to help you with all your Excel needs and will enable you to move from an Excel beginner to an expert in no time.

How is this Book Structured?

This book is organised in three main sections. These are:


Section 1
 - This section contains all the tools, features and shortcuts aimed for complete beginners. These shortcuts do not take long to learn and even a novice can learn these very quickly. Even though they are quick and easy to learn they are still very powerful. Everybody who uses Excel, whether they are a beginner or an advanced user would benefit from learning all of these features to improve productivity.


Section 2
 - In this section, you will learn some very powerful tools to help you manipulate your data with very little effort. The tools and features in this section requires a bit more time to learn than in the first section. In section 2, you will also learn some hidden gems that not many people know about but can significantly save you valuable time. If you want to take your Excel skills to the next level, then the tools and features in this section will enable you to do just that.


Section 3
 - In this section you will learn some of the more advanced features of Excel. The tools and features in this section takes the longest to learn. You will also need some prior 
 knowledge of Excel in order to understand how these features work and get the best out of them. However, once you have mastered these then consider yourself to be in the top percentage of Excel users who have advanced knowledge.

Who is this Book Aimed At?

This book is aimed at people who:


	Have beginners knowledge of Excel and would like to become more efficient in it

	Are intermediate Excel users and would like to move to the next level

	Would like to save time and effort in their spreadsheets and boost productivity

	Want to learn some of the hidden features of Excel that are not easily accessible in the ribbon

	Would like to manipulate and dissect their datasets more efficiently

	Are more experienced in Excel but would like to get more out of it



If you have never used Excel before then I highly recommend that you purchase my beginners Excel book called Excel Bible for Beginners: The Essential Step by Step Guide to Learn Excel for Beginners
 which will walk you through the steps of how to use Excel for the very first time and you will learn all the main tools and features of Excel.

Version Used

I have written this book using examples from Excel 2013 and Excel 365. You can use all the features and tools in this book using Excel 2010 onwards. Note that in Section 3 on two-way lookups, I use the XLOOKUP function. At the time of writing, this function is only available in Excel 365.

Comments

I am always interested in receiving feedback from you, either for this book or other books I have written. If you have any specific Excel topics you would like me to write a book about 
 then please let me know. The best way to contact me is though my website:


www.excelmasterconsultant.com



SECTION 1

In this section you will learn about all the tools, shortcuts and features that are aimed for complete beginners. These are the easiest and quickest to learn in the book but will still enable you to save vast amounts of time and increase your productivity when working with Excel. You will learn the following tools, features and shortcuts:


1) 
 How to hide specific text in a worksheet


2) 
 How to insert line breaks in text


3) 
 How to select the entire worksheet with just one click


4) 
 How to get more options for the Status Bar with just a single click


5) 
 How to stop zeros in front of numbers from disappearing when entered in a cell


6) 
 How to quickly insert multiple rows using the Ctrl, Shift + keys


7) 
 How to quickly shift between lots of open Excel files and windows


8) 
 How to quickly sum values using the Alt + keys


9) 
 How to keep your headers visible by using Freeze Panes


10) 
 How to quickly undo mistakes


11) 
 How to paste copied values with more flexibility using Paste Special


12) 
 How to select datasets more efficiently using Ctrl + Arrow keys


13) 
 How to toggle between different cell references and repeat your last action using the F4 key





Hide Specific Data in a Worksheet

If you have sensitive data in a worksheet you can easily hide the worksheet by right clicking the worksheet tab and selecting Hide from the menu. However, what if you only want to hide specific data in certain cells but would like to keep data displayed in the other cells in the same worksheet? The easiest way to do this is by using the Format Cells
 Dialog Box
 .
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In this example, I want to hide the sales in column C but keep the information in columns A and B.

Here are the steps to do this:


1) 
 Select column C by clicking the column C header. Right click your mouse and then select Format Cells
 from the menu
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2) 
 In the Format Cells
 Dialog Box
 select Custom
 in the left hand pane and then in the Type
 field enter ;;;
 and then click the OK
 button

[image: ]



3) 
 The data in column C is now invisible!
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Note:
 Another method to do this is to select the cells you want to hide and change the font colour to white by going to Home > Font  in the ribbon and selecting the white font from the Font Color command button. 


Insert Line Breaks to Make Text Easier to Read

Worksheets often have long lines of text in a cell that needs to be broken down into different lines to make it easier to read. To start a new line of text place the mouse curser where you want the line break and then press Alt + Enter
 . Let’s look at an example.
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In cell A1 there is an address which is all contained in one line. I want to start a new line after each comma so the address is easier to read.

Here are the steps to insert new line breaks:


1) 
 Select the cell which contains the text. In this example it will be cell A1


2) 
 In the Formula Bar
 , select the location where you want to insert the line break. In my example I will place the curser after the commas


3) 
 Press Alt + Enter
 on your keyboard to insert the line break. Repeat these steps to insert more line breaks in the text

[image: ]



Select the Entire Worksheet with One Click

There may be occasions where you want to select the entire worksheet, maybe because you want to copy the entire contents and paste it to another worksheet or workbook. How can you do this without selecting all the cells in the worksheet with your mouse? Well, only a few people know that selecting an entire worksheet can be done in seconds with a click of a button! Here is how to do it.
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Simply just click on the top left corner button above row 1 and to the left of column A as highlighted in the red square above and the whole worksheet is selected in a split second!


Get more Information in the Status Bar with One Click

When you select a range of numbers in a worksheet, you may notice there is an average, count and sum of the numbers you selected in the Status bar. The Status Bar is located below the worksheet tabs and is coloured green. The average, count and sum is the default setting for the Status Bar. However, what if you want to display more information in the Status Bar? You can easily change the Status Bar settings with just a couple of clicks of the mouse.
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You can open the Customize Status Bar Dialog Box
 with just a single click of the mouse. Just move your mouse pointer anywhere in the Status bar and right click the mouse.
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The Customize Status Bar Dialog Box
 appears with a list of settings. You can turn 
 on any settings which are not ticked by just clicking them. A tick will appear next to the setting and will then appear in the Status Bar. You can also deselect any settings by just clicking the settings that are ticked. This will remove the ticks.
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In this example, I have selected Maximum
 in the Customize Status Bar Dialog Box
 and this now appears in the Status Bar.


Stop Values that Start with a Zero from Disappearing

When you enter values in a cell that start with a zero, Excel will remove them by default. You may need to show the zero in the cell because it could be a product number, invoice number or a customer reference number. Let’s look at an example.
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In the example above you can see screwdrivers has a product code of 0098768 in cell B2.
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When I click out of the cell the two zeros at the beginning of the product number has disappeared.
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To overcome this issue all you need to do is enter a single quotation mark (‘)
 at the beginning of the product number in the Formula Bar.


Insert Multiple Rows Quickly using Ctrl, Shift +

Inserting a new row is easy enough. Just select the row header, right click the mouse and choose Insert from the menu. However, what about if you want to insert multiple rows? Inserting one row at a time is time consuming and tedious. There is an easier option by using the Ctrl, Shift +
 keys.

Here is how to insert multiple rows in one go:


1) 
 Select the number of rows you want to insert. In this example, I want to insert 4 new rows so I select 4 rows (rows 3 to 6)
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2) 
 Press Ctrl, Shift +
 on your keyboard. Four new rows have been inserted in one go
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Quickly Shift Between Excel Files

Sometimes you may have lots of different Excel files open at once. Shifting between all the different Excel files can be confusing and time consuming to get to the one you need. Luckily there are a couple of shortcuts you can use to shift between each Excel file.


1) 
 Firstly, you can use the Ctrl + Tab
 shortcut keys. Keep the Ctrl
 button pressed down and press the Tab
 button to switch between the different Excel files.


2) 
 Secondly, you can press the Alt + Tab
 shortcut keys. This is different to the first method as it allows you to shift between different open windows. You may have several Excel files open, Outlook, PowerPoint, Internet browser and so on. You can shift between the different windows by keeping the Alt
 button pressed and pressing the Tab
 button to switch between the different windows.
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Autosum using Alt +

When you want to add numbers together you can use the SUM
 function. For example, below I want to add the numbers in the range D2:D5 so I use the formula =SUM(D2:D5) in cell D7.
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Another way to perform the same task is to use the AutoSum
 which is located under Home > Editing in the ribbon. Just click any cell underneath the values you want to sum and then click on the AutoSum
 command button and then hit Enter
 on your keyboard.

There is also another, quicker way, which many people are not aware of which is to use the Alt +
 keys.
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Click on any cell underneath the values you want t0 sum. In this example, I select cell D7 and then just press the Alt +
 keys and then the Enter
 key on your keyboard.
 The figures in the range D2:D5 has instantly been summed!


Keep Rows and Columns in View using Freeze Panes

Often in worksheets you may have data which contains thousands of rows or columns. You may want to look at specific rows or columns so you scroll down or to the left or right. When you do this the headers will disappear so you don’t know what the data in the cells are referring to. An easy way to solve this problem is to use Freeze Panes
 . With Freeze Panes you can freeze the top row, first column or any number of rows or columns. The Freeze Panes command button in located under View > Window in the ribbon.

Now let’s have a look at some examples of how to keep the headers and columns visible.
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In this example, I have a dataset which shows how much sales each Sales person has made each month. I want to freeze the headers which is in row 1 so all the months are still visible when I scroll down. To do this follow these steps:


1) 
 Select the row directly underneath the row you want to freeze. In this example, I select row 2
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2) 
 Click the Freeze Panes
 command button with is located under View > Window in the ribbon and select either Freeze Panes
 or Freeze Top Row
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3) 
 Now when you scroll down, the headers will still be visible
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You can follow the same steps to freeze the first column but this time you select column B and when you click on the Freeze Panes
 command button you select Freeze First Column
 .
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To unfreeze a row or column, simply select Unfreeze Panes
 when you click on the Freeze Panes
 command button.


Correct Mistakes Quickly

It is very easy to make mistakes in Excel. After all, we are only human and mistakes happen in whatever we do. There is a very simple and quick shortcut you can perform to undo a mistake in Excel. If you press the shortcut keys Ctrl + Z
 then Excel will go back one step. If you press it again then it will go one step back again. In Excel 2007, 2010, 2013, 2016, 2019, and 365, the number of undo levels is 100.

Instead of pressing the shortcut keys Ctrl + Z
 you can instead press the Undo
 command button which is located in the Quick Access Toolbar. You will learn more about the Quick Access Toolbar in Section 2 later in the book. For now, just be aware that it is located on the top left above the Home tab of the ribbon.
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As well as undoing a mistake you can also redo an action. The shortcut keys to perform this is Ctrl + Y
 . You can also press the Redo
 command button which is located in the Quick Access Toolbar as shown below.
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The above is great but it only lets you undo or redo an action one at a time. What many people are not aware of is that you can undo or redo multiple actions at once. Here are the steps to undo multiple actions at once:


1) 
 Press the down arrow which is located on the right of the Undo
 command button in the Quick Access Toolbar


2) 
 This lists all the actions you have performed. Move your curser down the list until you have highlighted all the actions you want to undo. Notice at the bottom it tells you how many actions will be undone
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You can perform the same thing with the Redo
 command button.


Paste Cells with more Flexibility using Paste Special

Copy and paste is one of the most frequently used tools in Excel. However, when we copy and paste a cell or a range of cells we often paste the formatting or a formula we don’t want to carry over. This can be frustrating and take time to fix manually. Fortunately, there is a Paste Special
 command button which gives you more flexibility than the default paste button when you paste copied cells. The Paste Special
 command button is located under Home > Clipboard in the ribbon.
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Below is a brief description of what each of the buttons do:


	
Paste
 - This will paste the cell contents and the formatting from the copied cell.




	
Formulas
 - This will paste the formula from the copied cell. No formatting will be pasted.




	
Formulas & Number Formatting
 - This will paste the formula and the number formatting from the copied cell.




	
Keep Source Formatting
 - This will paste the cell contents and all the formatting from the copied cell.




	
No Borders
 - This will paste the cell contents from the copied cell but without any borders.




	
Keep Source Column Width
 - This will paste the cell contents, all the formatting and apply the column width from the copied cell.




	
Transpose
 - This pastes the selection in a transposed way. For example, if you copy a vertical range of cells then it will paste it horizontally and vice versa.




	
Values
 - This will paste the cell contents only. No formatting will be pasted. If you are copying a formula then it will just paste the result of the formula and not the formula itself.




	
Values & Number Formatting
 - This will paste the cell and the number formatting. If you are copying a formula then it will just paste the result of the formula and not the formula itself.




	
Values & Source Formatting
 - This will paste the cell and the source formatting. For example, if the cell or cells have a border and a fill colour then it will paste the border and the fill colour.  If you are copying a formula then it will just paste the result of the formula and not the formula itself.






Select Data More Efficiently using Ctrl + Shift

Do you ever find it tedious and time consuming selecting datasets using just your mouse? This is especially so when the dataset contains hundreds and thousands of rows or columns. Luckily, I will show you a more efficient way to select datasets using just the Ctrl + Shift
 and arrow keys
 .

Select Data Down a Column
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To select the data down a column simply click the first cell you want to select and then hold down Ctrl + Shift
 and the down arrow
 keys. In the above example, I selected cell A1 and then pressed Ctrl + Shift
 and the down arrow
 keys.

Select Data Up a Column
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To select the data up a column simply click the first cell you want to select and then hold down Ctrl + Shift
 and the up arrow
 keys. In the above example, I selected cell A14 and then pressed Ctrl + Shift
 and the up arrow
 keys.

Select Data Across to the Right
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To select the data across to the right simply click the first cell you want to select and then hold down Ctrl + Shift
 and the right arrow
 keys. In the above example, I selected cell A6 and then pressed Ctrl + Shift
 and the right arrow
 keys.

Select Data Across to the Left
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To select the data across to the left simply click the first cell you want to select and then hold down Ctrl + Shift
 and the left arrow
 keys. In the above example, I selected cell M6 and then pressed Ctrl + Shift
 and the left arrow
 keys
 .

Select Data from the Active Cell to the Bottom Right
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You can select all the data from the active cell to the bottom right of the dataset by pressing the Ctrl + Shift
 and End
 keys. In the above example, I selected cell D1 and pressed Ctrl + Shift
 and End
 keys to select the data from D1 to M14.

Select all the Dataset
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To select all the dataset press Ctrl + Shift
 and * (Asterisk).
 No matter where you click in the dataset it will select the whole contiguous data of a cell. It will stop where there is a blank cell.


Increase your Productivity using the F4 Key

The F4 key on your keyboard is a very useful button and has two great features. The first is that it will allow you to toggle between absolute, relative and mixed cell references. The second, which not many people are aware of but can increase your productivity, is that it repeats your last action. Let’s look at the two in a bit more detail.

Toggle Between Absolute, Relative and Mixed Cell References

An absolute cell reference is when you keep the row and column locked when you are copying formulas down. When you lock a row and column, you place a dollar sign ($) before the row and column like this =$A$1. A relative cell reference is the default setting for a formula. This is when the row and column is not locked so the dollar sign ($) is not placed before the row and the column like this =A1. A mixed cell reference is when you want to lock either a row or a column. The dollar sign ($) is placed before the row if you want to lock the row like this =A$1 or before the column if you want to lock the column like this =$A1.

I have written books all about formulas and functions in my Excel Formulas and Functions series
 which explains this in more detail. If you would like more information about these books then click on the links below:


1) 
 Excel Formulas and Functions: The Complete Excel Guide for Beginners



2) 
 Excel Formulas and Functions: The Step by Step Excel Guide on how to Create Powerful Formulas



3) 
 Excel Formulas and Functions: The Step by Step Excel Book for Beginners on how to Master Lookup Formulas using the XLOOKUP Function


Now I will show you how to toggle between the different cell references by pressing the F4 key
 .
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In the above example, the formula in cell B1 is referencing cell A1. The formula is =A1 which means it is a relative cell reference as both the row and column are not locked.

[image: ]


Now when I press the F4 key once the formula has changed to an absolute cell reference as it has a dollar sign ($) before the row and the column.
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When I press the F4 key again it changes into a mixed cell reference. The dollar sign ($) is before the row so the row is now locked but the column is relative.
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When I press the F4 key again, the column is locked as the dollar sign ($) is before the column but the row is relative.
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When I press the F4 key again the formula is a relative cell reference again.

This is so much quicker and easier than having to manually enter the dollar sign ($) in the formula yourself and will lead to less mistakes.

Using the F4 Key to Repeat your Last Action

Another great feature of the F4 key is that it repeats your last action. This saves you valuable time as you don’t have to keep on searching and pressing command buttons in the ribbon with multiple clicks of the mouse. Let’s look at a simple example.
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Here, there is a border in the range A1:A6. I want to quickly apply the border in the range D1:D6.
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All you need to do is select the range D1:D6 and then press the F4 key and the borders are applied. No need to go to Home > Font and select the borders from the Borders command button in the ribbon.


SECTION 2

In section 2 you will learn about the more advanced Excel tools and features which will enable you become more productive. You will also learn some of the hidden features that are available in Excel which other people may not be aware of. In this section you will learn the following:


1) 
 How to name a cell or a range of cells to make your formulas easier to read


2) 
 How to have easy access to your favourite command buttons using the Quick Access Toolbar


3) 
 How to use the Camera tool


4) 
 How to use the Advanced Filter to create unique lists and remove duplicate values


5) 
 How to create more flexibility in your datasets by converting them to Excel tables


6) 
 How to split text from a single cell using Text to Columns


7) 
 How to convert dates to the correct format


8) 
 How to make Excel speak back to you using Text to Speech


9) 
 How to highlight values using Conditional Formatting


10) 
 How to auto populate data using Flash Fill


11) 
 How to change case in text


12) 
 How to transpose data




Make Formulas Easier to Read by Naming Ranges

You can give a cell or a range of cells a name. You can then use the named range in your formulas rather than the cell references. So why would you use named ranges? Here are some of the benefits of why you should use them:


	
Named ranges are easier to understand in formulas than cell references
 - For example, =SUM(Sales) is easier to read and understand than =SUM(A1:A10). You know straight away that you are summing the sales figures.




	
You don’t need to keep on selecting the cells when creating new formulas
 - You can just type a couple of letters of the named range and then Excel will show the named range in the list. Once the named range is shown, you can just select it by clicking the Tab button on your keyboard.




	
Named ranges are dynamic
 - For example, if you have named a cell D1 “Bonus” and the bonus is 8% you can use the named range “Bonus” in the formula. Now say, the bonus has changed from 8% to 10% you can just change the named range value in cell D1 to 10% and the formulas will automatically update. If you just hard code the bonus percentage in the formula, you will have to manually change the percentage in the formula if it changes as well as any of the other formulas that contain the bonus percentage.



Now you know why it is good practice to use named ranges, let’s look at an example of how to create one.
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In this example, I want to apply a 10% bonus in column D based on the sales for each Sales person. Note, the 10% value in cell G2. I want to name this cell “Bonus”. To do this follow these steps:


1) 
 Select the cell or range of cells you want to name. In this example I want to name just a single cell which is cell G2 so I select this cell


2) 
 In the Name Box
 which is located to the left of the Formula Bar, type the name of the cell or range. In this example, I type Bonus
 and then press Enter
 . Cell G2 is now called “Bonus”
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3) 
 Now I want to enter the formula in cell D2. I want to calculate 10% of the sales in cell C2 so instead of entering the formula =C2*G2 I write =C2*Bonus
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4) 
 I can then copy the formula down to cell D8 using the Fill Handle which is located at the bottom right of the active cell
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5) 
 Notice all the formulas in column D contain the named range Bonus
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There are some rules to naming a cell or a range of cells which you need to adhere to. These are:


	The first character of the named range must be a letter, an underscore (_) or a backslash (\).




	You cannot use cell references as a named range such as A1.




	If you want to use more than one word as a named range you can’t use a space between the words. You can instead use an underscore character (_), a period (.) or uppercase letters to separate words. For example, you can’t use a named range such as “Date Range” but you can use “Date_Range”, “Date.Range” or “DateRange”.




	You can’t have a named range longer than 255 characters. I do not see why anybody would have a named range longer than this anyway.



You can also use the Name Manager
 to create named ranges. This is located under Formulas > Defined Names > Name Manager in the ribbon.
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To create a named range using the Name Manager
 , select the cell or range of cells you want to name. Click the Name Manager
 command button and then the Name Manager Dialog Box
 will appear as shown above. Click on the New
 button.
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The New Name Dialog Box
 will appear. In the Name
 field type the name you would like. In the above example, I typed Bonus.
 Once this is done click on the OK
 button and the cell has been named “Bonus”.


Customise your Ribbon using the Quick Access Toolbar

The Excel ribbon contains all the tools and functions to help you with your worksheets needs. However, there will be some buttons that you use more often than others and which you use on a daily basis. Having to go to the ribbon and select the relevant tab and then navigate to the correct group whenever you want to click on your favourite command buttons each time is tedious. What you need is a place where you have easy access to your favourite buttons where you can select it with a single click of the mouse. Luckily, Excel has a Quick Access Toolbar (QAT)
 where you can add your most frequently used buttons to it.
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The QAT is located above the ribbon on the top left. By default, the QAT contains the Save, Undo and the Redo command buttons. These are the most commonly used command buttons Excel users use so Microsoft has already included these for you. In the above screenshot you can see I have included more command buttons to the QAT.

I will now show you how to add your favourite command buttons to the QAT. Here are the steps to do this:


1) 
 Click on the down arrow to the right of the QAT and select More Commands
 from the menu
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2) 
 In the Excel Options Dialog Box
 , under the Choose commands from
 drop down box, select the option where the command button you want to add is located. I want to add the Cut command button so I can select either Popular Commands
 or the Home tab
 as the Cut command button is located in these two options
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3) 
 Select the command button you want to add from the left hand box. In this example, I select Cut. Next, click the Add
 button which is located between the left and right boxes and then click the OK
 button to add it to the QAT
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4) 
 You can see the Cut command button has now been added to the QAT
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If you want to remove a command button from the QAT then follow step 1 again. However, this time in the Excel Options Dialog Box
 select the command button you want to 
 remove from the right hand box and click the Remove
 button and then the OK
 button.
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Make Images Dynamic using the Camera Tool

There is a little known but very useful Excel tool called Camera
 . The reason why many people are not aware of this tool is because it is hidden away! You can’t access it through the ribbon. You have to add it to the Quick Access Toolbar (QAT). What the Camera tool does is take a snapshot of an area of the worksheet as a drawing object and updates whenever your worksheet updates. I will show you an example of how to use it but first, you need to add the Camera to the QAT.

Adding the Camera to the QAT

In the previous chapter called Customise your Ribbon using the Quick Access Toolbar
 , I showed you how to add command buttons to the QAT. You need to follow the same steps to add the Camera button. If you have not read the previous chapter then I recommend that you read that first before you continue reading this chapter.
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Open up the Excel Options Dialog Box
 as explained in 
Customise your Ribbon using the Quick Access
 Toolbar
 .
 Choose All Commands
 from the Choose commands from
 drop down box and then in the left hand box scroll down until you see the Camera
 command button. Click on the Add
 button and then OK
 to add the button to the QAT.
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The Camera button looks like a camera as highlighted in the above screenshot.

How to use the Camera

Now that the Camera tool is added to the QAT, I will show you an example of how to use it and explain what it does.
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In the above dataset, there is a list of fruits and their prices in the range A1:B7. I want to take a snapshot of this using the Camera. Here are the steps to do it:


1) 
 Highlight the dataset, in this example I highlight the range A1:B7. Next click on the Camera
 command button in the QAT. The borders will turn into dashes
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2) 
 Click anywhere in the worksheet and the picture of the dataset will appear. You can drag the picture anywhere you like on your worksheet and use the resize handles to make it larger or smaller like with any picture you insert in a worksheet
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Now this is the best bit! Whenever you change any value in the dataset, the picture will also change automatically.
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In this example, I have changed the price of bananas from $1.50 to $1 in cell B2. Notice the picture has also changed.

You might be thinking why you would use the Camera tool in your worksheets? Below are some good reasons why you would use it.


Create Dashboards
 - If you have a large workbook which contains lots of information in Pivot Tables, charts and data tables you can create a summary sheet and take snapshots of the most interesting or the most important pieces of information and group these together on one page. If the user wants to drill down on the data then they can double click on the picture so they can view the original data.


Create Linked Images that Update Based on User Selection
 - If you have a drop down list of items and you want an image to update based on what the user has selected then you can use the Camera tool to create a linked image.


Make your Spreadsheet More Presentable
 - You can apply special layouts to the pictures just like with normal pictures. Say for example, you have taken a snapshot of a 
 chart using the Camera tool, you can apply some very useful tricks. Maybe you want to rotate it or format it using the different built in Excel formats in the Picture Tools tab. Maybe you want to apply different brightness or contrast or put a shadow or glow to the picture. There are many ways you can apply special formatting to your picture to make it look better and more presentable. You can’t apply these special formatting to a normal Excel chart.


Help When Working with Large Data Sets
 - If you are working with a large workbook with many different worksheets and each worksheet is linked to another with formulas, then using the Camera tool can help you. For example, if the user changes values in Sheet2 and it affects the values in Sheet4 then you can take a snapshot of the data in Sheet4 and see how it changes when you change the values in Sheet2.


Extract a Unique List using the Advanced Filter

The advanced filter is one of the most underutilised tools in Excel. You may have come across the regular Excel filter which filters a dataset based on numbers, text or other criteria. The advanced filter is the next level up from a regular filter and uses more complex criteria to filter your dataset. In this chapter, I will show you how to extract unique records from a dataset using the advanced filter.
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The data in the range A1 to C14 contains the names of people in an organisation along with their ages. The rows highlighted in orange are duplicate entries and need to be removed.

To remove the duplicate entries so only the unique records remain follow these steps:


1) 
 Select the dataset and then from the ribbon select Data > Sort & Filter > Advanced
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2) 
 In the Advanced Filter Dialog Box
 under Action
 , select Copy to another location
 . This setting allows you to place the unique records to another location of the worksheet. In the List range
 field you need to select the dataset. Make sure the headers are also selected. You can leave the Criteria range
 field empty. In the Copy to
 field you need to specify where you want the list of unique records to be placed on your worksheet. In the example below, I have specified cell F1. Next click on the OK
 button
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3) 
 The unique list is now located in the range F1:H12 with duplicate entries removed

[image: ]



Make your Dataset more Flexible using Excel Tables

Excel tables are one of the best features in Excel. Whenever I have a dataset, I ensure that I convert this into a table. There are a lot of benefits of converting a dataset into a table which I will explain in more detail later in this chapter. First, I will show you how to convert a dataset into a table.

How to Convert a Dataset into an Excel Table
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In this example, I have a dataset which shows how much an item costs excluding Tax and then the total cost when tax is included. To convert this to a table follow these steps:


1) 
 Select anywhere in the dataset then select Insert > Tables > Table from the ribbon
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2) 
 The Create Table Dialog Box
 will appear. Excel will normally display the correct range of the dataset in the field. If it doesn’t then just select the dataset and then press the OK
 button. If your table already has headers then ensure that the My table has headers
 checkbox is checked
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3) 
 Excel has now converted the dataset into a table. You will know that it is converted into a table as Excel has changed the formatting of the dataset
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4) 
 It is normally good practice to name your table. To do this, click anywhere in the table and then click on the Design
 tab in the ribbon. In the Table Name
 field which is located on the left of the ribbon in the Properties
 group, type the name you would like to call the table. In this example I have called it “Data”
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Benefits of using an Excel Table

There are many benefits of Excel tables. The main ones are mentioned below:

1) Table Headers Remain Visible when Scrolling Down
 – You do not have to freeze panes in a table as Excel will recognise that the top row is a header.
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2) Tables Automatically Resize when you add more Data
 – Whenever you add more data to the dataset, the Excel table will resize automatically. The table name will include the new data without you having to rename the dataset again. This is especially useful when a Pivot Table or chart is referencing the table. This means that you do not have to keep on specifying the new data range whenever new rows or columns are added 
 to the dataset.

3) Formulas are Automatically Copied Down when you add more Data
 – If a table contains formulas and you insert new rows of data, the formulas will automatically be copied down. You do not have to copy formulas down manually. In the example below, I inserted a new item in row 7 and the formula in column D has automatically copied down.
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4) Tables Automatically Name Ranges
 – As mentioned earlier in the book, naming ranges is good practice to make your formulas easier to read. I have already talked about how to name ranges but when you create a table, it automatically creates names for each column for you. You can use these names in your formulas. In the example below, the SUM function uses the table name “Data” and sums all the costs using the column name “Cost”.
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5) You can Format Tables Easily
 – You can very easily change the formatting of a table with a few clicks of the mouse. Click anywhere in the table and then select the Design
 tab. Under the Table Styles
 group you can select from a range of designs. If you click on the down arrow located at the bottom right in the Table Styles
 group you will see even more designs. You can also choose if you want banded rows, display a header row or total rows in the Table Style Options
 group.
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6) Filters are Automatically Inserted when you Create a Table
 – This is not a huge benefit but even so, it saves you from having to insert filters manually.

You can now see the huge benefits of using Excel tables and how flexible and dynamic they are. You should use them as often as you can to make your life easier.




Quickly Split Text in a Single Cell using Text to Columns

Sometimes, when you extract data from another system like a database, the data is not formatted the way you would like it to be. There may be some data all contained in one cell but you want it to be split out into separate columns. Instead of using complicated formulas to split text, there is an easier way to do this using the Text to Columns
 tool.

Let’s look at an example of how to use the Text to Columns tool.

[image: ]


In this example, column A contains the first and last names in one cell. I would like to split the first and last names so the first names are in column B and the last names are in column C.

Here are the steps to do this:


1) 
 Select the data you want to split. In this example, I want to split the first and last names in 
 the range A2:A6 so I select this range. Then from the ribbon select Data > Data Tools > Text to Columns
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2) 
 In Step 1 of the Convert Text to Columns
 Wizard
 select Delimited
 . Delimiter is based on splitting text by spaces or commas and Fixed Width is when all the data is in one column but separated by a fixed number of spaces or periods. Click the Next
 button

[image: ]



3) 
 In the second step of the Wizard select which of the delimiters the text is separated by. In my example, the first and last names in column A is separated by a space so I check Space
 . Now click the Next
 button
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4) 
 In the final step of the Wizard under Column data format
 make sure the General
 setting is selected. In the Destination
 field, select the cell where you want the split data to be located in the worksheet. In this example, I want the data to start from cell B2. Next, click the Finish
 button
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5) 
 As if by magic the text has been separated!
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Convert Dates into the Correct Format Quickly

One of the biggest frustrations in Excel is converting dates into the correct format. You may have to extract data from a database which contains dates but they are in the American format of mm/dd/yyyy but you need the dates in the UK format of dd/mm/yyyy or vice versa. If there are only a few dates then you can change them manually but what if there are hundreds or even thousands of dates you need to amend? If you are an Excel guru then you may be able to come up with a formula to change the formatting. However, this becomes even more complicated if some of the dates are not actual dates that Excel recognises but look like dates. In this chapter, I will show you a little known way to change the date format using the Text to Columns tool which will change the format in seconds!

As already mentioned, changing the date format requires the Text to Columns tool so please see the previous chapter on Text to Columns
 to learn more about what this tool does before you proceed further in this chapter. Now let’s look at an example.
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In column A, there is a list of dates, however, they are in the US format of mm/dd/yyyy. To make this even more complicated, there are some dates which look like dates but are not recognised as dates in Excel which are in rows 9 to 14 and 17 to 20. Dates are normally right aligned but you can see these dates are left aligned.

To convert the dates into the dd/mm/yyyy format, including the dates which are not even real Excel dates, follow these steps:


1) 
 Select the dataset and then from the ribbon select Data > Data Tools > Text to Columns
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2) 
 In step 1 of the Convert Text to Columns Wizard
 select Delimited
 and then the Next
 button
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3) 
 In step 2 of the Wizard under Delimiters
 , ensure that nothing is checked and then click the Next
 button
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4) 
 In step 3 of the wizard, under Column data format
 select Date
 and from the drop down menu select MDY
 and then click the Finish
 button
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5) 
 All the dates are in dd/mm/yyyy format including the dates that Excel did not recognise as dates
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Make Excel Speak back to you using Text to Speech

Text to Speech is a little known but very useful tool to know and learn. As the name suggests, it converts text or numbers into speech and is read out loud by Excel. It is great for when you are proof reading your worksheets. People often use this feature so they can enter text or numbers into their worksheet without having to constantly look up at their screen to check what they have entered is correct. Not many people know about this feature because it is not available from the ribbon. You have to add it to the Quick Access Tool Bar (QAT). I have already discussed how to add command buttons to the QAT in the Customise your Ribbon using the Quick Access Toolbar
 so if you want a recap, please read that chapter again before you proceed.
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To add Text to Speech to the QAT, open the Excel Options Dialog Box
 as explained in the Customise your Ribbon using the Quick Access Toolbar
 chapter. Under Choose commands from
 select All Commands
 and then in the left hand box scroll down until you see Speak Cells
 and then add it to the QAT by clicking the Add
 button and then the OK
 button.
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The Text to Speech is now added to the QAT as highlighted above.

Now when you select a cell or a range of cells that contain text or numbers and press the Speak Cells command button, Excel will read these out aloud in turn. Excel will do its best to pronounce the word, however if a cell contains random text which is not a word then Excel will read out the letters.

You may have noticed there are other Speak Cells buttons which you can add to the QAT. I will briefly describe what each one does.


Speak Cells – Stop Speaking Cells
 – When you click this button then Excel will stop reading the cells out loud


Speak Cells by Columns
 – Excel will read the cells in the left most column and then move across to the next column on the right


Speak Cells by Rows
 – Excel will read the cells in the top row from left to right and then move to the next row below


Speak Cells on Enter
 – Excel will only read the cell once you press the Enter button on your keyboard

You can add one or more of the above Speak Cells buttons to the QAT but only one of the Speak Cells by Columns or Speak Cells by Rows can be active.


Make Data Come Alive using Conditional Formatting

Conditional formatting is used to highlight points of interest in your data. It is often used to highlight cells that are over or below a target value. You can also use it to highlight duplicate values easily. I will show you how to do both in this chapter. The Conditional Formatting command button can be found under Home > Styles > Conditional Formatting in the ribbon.

Highlight Cells below a Target Value
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Here I have a list of Sales people with their sales. They need to achieve a sales amount of $8,000 as indicated in cell B10. I want to highlight the Sales people who have not achieved this target. To do this follow these steps:


1) 
 Highlight the cell range you want to conditional format. In this example I highlight the range B2:B8. Under Home > Styles click the Conditional
 Formatting
 command 
 button. From the menu select Highlight Cells Rules
 and then from the next menu select Less Than
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2) 
 In the Less Than Dialog Box
 you can either enter the target value manually or use the cell address if the target value is in a cell. In this example, the target value is in cell B10 so I select this address in the first field. You can also select the formatting from the drop down box in the second field. Once done, select the OK
 button
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3) 
 The Sales people who have sales under $8,000 are now highlighted
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You can perform many different variations of this. For example, you can highlight cells that are greater than the target value, between two values, equal to a value, highlight the top 10 or bottom 10 values and so on.

Highlight Duplicate Values
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Here we have a list of garden items available to buy from a garden shop. There are some duplicate items in the list which I want to highlight. To highlight the duplicates follow these instructions:


1) 
 Highlight the dataset. In this example I highlight the range A1:B10. Under Home > Styles click the Conditional
 Formatting
 command button. From the menu select Highlight Cells Rules
 and then from the next menu select Duplicate Values
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2) 
 In the Duplicate Values Dialog Box
 , ensure Duplicate
 is selected from the first drop down box. This will ensure that only duplicate values are highlighted. If you only want to highlight unique values then select the Unique option. You can also change the formatting using the drop down box in the second field. Once done, select the OK
 button
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3) 
 The duplicate values are now highlighted
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Auto Populate your Data using Flash Fill

One of the best new features of Excel is the Flash Fill
 . This was introduced in Excel 2013. Flash Fill automatically fills in data when it senses a pattern. The Flash Fill command button is located under Home > Editing > Fill from the ribbon.

Let’s look at an example of how Flash Fill works.
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In this example, there is a list of last names in column A and first names in column B. I want to enter the first and last names in column C.
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Firstly, I enter the first name and last name in cell C1 for Michael Jenkins and then go to Home > Editing > Fill > Flash Fil
 l
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Flash Fill has automatically filled the first and last names in column C. Flash Fill recognised that I wanted the first and last name format when I typed in Michael Jenkins and then filled the corresponding cells in column C in the same format. Before Flash Fill was introduced, you would have to do some complicated workarounds or complex formulas.


Change Text to Upper, Lower and Proper Case Quickly

There may be occasions when you need to change the case of text. Fortunately, there are three Excel functions which will allow you to do just that. The UPPER
 function changes all the text to upper case. The LOWER
 function changes all the text to lower case and the PROPER
 function capitalises the first character of each word to upper case and leaves the rest lower case.

The UPPER, LOWER and PROPER functions all have just one argument which is the text
 argument. In this argument you just enter the text you want to change. Let’s take a look at each function.

UPPER Function
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In cell B2, I entered the formula =UPPER(A2)
 . The text argument is the name in cell A2. Notice that the text is all upper case.

LOWER Function
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In cell C2, I entered the formula =LOWER(A2)
 . The text argument is the name in cell A2. Notice that the text is all lower case.

PROPER Function
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In cell D2, I entered the formula =PROPER(A2)
 . The text argument is the name in cell A2. Notice that the first character in the first and last names are upper case and the rest are lower case.
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I then selected the range B2:D2 and copied the formulas down to row 5 using the Fill Handle highlighted in red above.


Transpose your Data Quickly

Transposing is when you switch data from rows to columns or columns to rows. You may have to transpose data if the dataset is not in the required format to create charts for example. To do this manually would take a long time. Fortunately, there are two ways to transpose data quickly. The first is using the Paste Special Transpose
 command button and the second is using the Excel TRANSPOSE
 function. I will show you how to transpose data using both methods.

Paste Special Transpose Command Button

This is the easiest and quickest way to transpose data.
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Here I have a dataset which lists the names of people in an organisation along with their ages. The data is going down in columns. I would like the data to be across in rows. Here are the steps to do this:


1) 
 Select the dataset. In this example, I would select the range A1:B7 and then copy the data by pressing Ctrl + C
 on your keyboard


2) 
 Select the cell where you would like the transposed data to be. In this example I select cell D1. Next click on Home > Clipboard > Paste > Transpose from the ribbon
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3) 
 The data is now transposed in rows in the range D1:J2
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The TRANSPOSE Function

Another method of transposing data is by using the Excel TRANSPOSE function. This is a more difficult way of transposing data but I want to show you an alternative method. Like with many things in Excel, there is often more than one way to do the same thing.

The TRANSPOSE function is an array function which means you must press Ctrl + Shift + Enter
 after you have entered the formula. It has one argument which is array
 . In this argument you enter the dataset you want to transpose. Now let’s look at an example.
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I will use the same dataset and again I want to transpose the data to the range D1:J2. Here are the steps to do this:

1) Select the data range where the transposed data will be located. In this example, I select the range D1:J2. The selection must be equal size to the dataset but the other way round. For example, the data in the range A1:B7 has two columns and seven rows so I select two rows and seven columns
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2) Next type in the formula in the active cell using the TRANSPOSE
 function. Here I have entered the formula =TRANSPOSE(A1:B7
 in cell D1
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3) This is very important. You must now press Ctrl + Shift + Enter
 on your keyboard for the formula to work. Once done, notice that there are curly brackets ({ }) before and after the formula. This indicates the formula is an array formula. The data has now been transposed
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SECTION 3

In this section you will learn about some of the more advanced features of Excel which will increase your productivity and make you even more efficient. The tools, formulas and features in this section take the longest to learn out of the three sections. By investing your time and effort in learning these however, you will be able to manipulate, dissect and analyse large datasets with ease. In this section you will learn the following:


1) 
 How to make your worksheets very hidden


2) 
 How to analyse large datasets using Pivot Tables


3) 
 How to dissect data using slicers


4) 
 How to join text together


5) 
 How to create two-way lookups


6) 
 How to use the What-If Analysis tool called Goal Seek


Make your Worksheets Very Hidden

You may already be aware that you can hide worksheets in Excel. To hide a worksheet you just simply right click the tab on the worksheet you want to hide and select Hide from the menu. Hiding worksheets is good if you have a worksheet which contains all your calculations or VLOOKUP tables which you don’t want other people to see. You can go one step further than this however and make your worksheets very hidden. This means that even if somebody tries to unhide the worksheet from the unhide menu, the worksheet will not be visible to unhide.

To make your worksheets very hidden you need to access the Visual Basic Editor (VBE). The VBE is where you write macros to automate your spreadsheets. Don’t worry, you will not need to know how to write code to make your worksheets very hidden!

To open the VBE press Alt + F11 or go to Developer > Visual Basic on your ribbon.
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In the top left corner of the VBE is the Project Explorer
 . Here it lists all the worksheets 
 which are contained in the Excel workbook. On the bottom left is the Properties Window
 . This allows you to change various appearances and settings. It is here where you can make your worksheets very hidden.

I would like to make Sheet1 very hidden, so I select Sheet1 in the Project Explorer and I then select xlSheetVeryHidden
 from the drop down box in the Visible
 setting in the Properties Window.
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Sheet1 is now hidden.
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When I try to unhide Sheet1 by right clicking a tab, the Unhide option from the menu is greyed out which means I can’t unhide it.

Making your worksheets very hidden is a good option if you have sensitive data, such as profit figures for your business and you need to send the Excel file to a customer and you don’t want them to see these figures.

In this chapter, I have given you a small glimpse of Visual Basic of Applications (VBA) and the VBE. If you would like to learn more about VBA then you can register for my beginners VBA course which will teach you how to record macros to automate your worksheets. This is a good introduction to programming and will give you a solid foundation of VBA. If you would like to enrol please click the link below.


Register for the free VBA course





Manipulate and Analyse Data Quickly using Pivot Tables

Pivot Tables are arguably the most useful tool in Excel. It is very powerful and it allows you to dissect large amounts of data with just a few clicks of the mouse. A Pivot Table is essentially a data summary tool which is created from a data source. You can summarise data in seconds by simply clicking and dragging fields from one area of the report to another. It can transform hundreds and thousands of rows and columns into meaningful information. You can display subtotals on any level of data you want. Arguably the biggest advantage of using Pivot Tables is in its interactivity. You can rearrange information without any effort. In fact, the reason why they are called Pivot Tables is because you can ‘pivot’ the data in any way you choose. The Pivot Table command button is located under Insert > Tables > Pivot Table.

Let’s look at how to create one.
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I will create a Pivot Table using the above dataset. The data contains shipping information on what dates shipping containers left the origin country and which destination country they arrived at. The data also shows the cbm volume that is in each container. I would like to create a Pivot Table which displays how much cbm was moved in total from India in a 20ft container.

Here is how to do it.

Inserting a Pivot Table
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You first need to insert a blank Pivot Table in the worksheet. From the ribbon go to Insert > Tables > Pivot Table and in the Create PivotTable Dialog Box
 specify the data range under Select a table or range
 . In my example, I select the data range in A1:E17. Under Choose where you want the PivotTable report to be placed
 you can either have the Pivot Table in a new worksheet or in the existing worksheet where the data is located. In my example, I selected New Worksheet
 . Click the OK
 button to create the Pivot Table in the new worksheet.

Pivot Table Fields Pane
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A blank Pivot Table is now created and the Pivot Table Fields
 pane is now showing. This is where you create your Pivot Table and where you can amend it for different scenarios. The top section of the Pivot Table Fields pane contains the Pivot Fields. These are the column headings of the dataset. There are four components of a Pivot Table which are contained in the lower section of the Pivot Table Fields pane. The Pivot Table Fields is a task pane which is associated with the Pivot Table and by default is located on the right side of the window. The four components of a Pivot Table are:


1)
 Filters


2)
 Rows


3)
 Columns


4)
 Values


Filters
 - Filters allow you to display just the data you want to see and the rest of the data will be hidden. When you move a field to the Filters area you can then choose which items in the field you want to see or not see by checking or unchecking the boxes. They work in the same way as a filter in a table.


Rows
 - Rows show each item in the field in separate rows. One field item occupies one row. They go down the left side of the Pivot Table.


Columns
 - Columns shows each item in the field across separate columns.


Values
 - Values shows the summary information. Excel offers many ways to summarise your information which include SUM, COUNT, AVERAGE, MAX, MIN and so on. You are required to enter at least one field in the Values area. You can have the same field in the Values area twice.

To move the Pivot Fields you simply click and drag them in any of the four components to create your summary table.

Building the Pivot Table
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As mentioned earlier, I would like to have a summary table which shows how much cbm volume was moved from India in a 20ft container. I clicked and dragged the Container Size
 field into the Filters
 area. I then used the filter which is next to Container Size (highlighted in red above) and checked 20ft. I clicked and dragged the Origin Country
 field to the Rows
 areas. I then clicked on the filter next to the Origin Country field and checked India. Finally, I clicked and dragged the Volume (cbm)
 field in the Values
 area. As you can see, there was 34cbm moved from India in a 20ft container.
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The great thing about Pivot Tables is that you can easily change them to display different information. For example, I now want to display how much cbm volume arrived in China in a 20ft container. I simply clicked and dragged the Origin Country
 field out of the Rows
 area and clicked and dragged the Destination Country
 field there instead. I then filtered the Destination Country to show just China.
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You can easily format Pivot Tables to look more pleasing to the eye. This can be done by clicking anywhere in the Pivot Table and selecting Pivot Table Tools > Design > PivotTable Styles from the ribbon and selecting one of the many designs available to you.

This chapter gives you the fundamentals of creating a simple Pivot Table. Books have been written on the subject of Pivot Tables alone. I have also written a book about Pivot Tables which gives you much more information about them and how you can become an expert in no time. Click below for more information about the book:


Excel Bible for Beginners: The Step by Step Guide to Create Pivot Tables to Perform Excel Data Analysis and Data Crunching



Dissect Data Quickly using Slicers

Slicers are visual filters which allow you to dissect the data in various ways easily. They are a great way to show different information in your Pivot Tables. Slicers were introduced in Excel 2010 so is not available in earlier versions of Excel. Let’s take a look at how to create and use them using the Pivot Table I created in the previous chapter. If you haven’t read the chapter on Pivot Tables
 then I would recommend you read that first so you know what Pivot Tables are and how to create one.
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The above Pivot Table shows the different container sizes moved from origin to destination country and the amount of cbm volume moved in each container. I want to create a couple of slicer’s to dissect the information by container size and origin country. Here are the steps to do this
 :


1) 
 Click anywhere in the Pivot Table and then select Analyze > Filter > Insert Slicer from the ribbon
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2) 
 The Insert Slicers Dialog Box
 will appear. I want to insert slicers for container size and origin country so I check the boxes next to Container Size
 and Origin Country
 and then press the OK
 button
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3) 
 The slicers have now been inserted in the worksheet. You can click and drag them anywhere you want. You can also resize them using the resize handles
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4) 
 Now you can filter the Pivot Table by selecting any of the items in the slicers. In the below example, I want to show the volume moved from Poland in a 20ft container so I selected 20ft from the Container Size slicer and Poland in the Origin Country slicer
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5) 
 To clear the filters just click on the Clear Filter
 icon located on the top right of the slicer
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Join Text in Multiple Cells

You may have data in separate cells which you want to join together in one cell. A simple way to join text is to use the Ampersand (&)
 key. Let’s look at an example.
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Here, there is a dataset which contains the first name in column A and the last name in column B. I would like to have the full name in column C. Here is how to do it.
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In cell C2 I created the formula =A2&" "&B2
 . To create this formula I first typed in the 
 equals sign (=) and then selected cell A2. I then entered the first Ampersand (&). I would now like to have a space between the first and last name and to insert a space in Excel you have to enter a quotation mark followed by a space and then another quotation mark like this (“ “). I then want to join the space with the last name so I use another Ampersand (&) and finally I select cell B2 to enter the last name.
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You can then copy the formula down using the Fill Handle.

Instead of using the Ampersand (&) you can use the Excel CONCATENATE
 function. The CONCATENATE function has one required argument which is text1
 and the rest are optional arguments such as text2, text3
 , and so on. In these arguments you just enter the text you want to join. Let’s look at an example.
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In cell C2, I entered the formula =CONCATENATE(A2," ",B2)
 . I used three arguments, text1, text2 and text3. The text1 argument is the first name in cell A1. The text2 argument is the space between the first and last name, so I entered (" "). The text3 argument is the last name in cell B2. Again you can then copy the formula down.

These are a couple of simple examples so you can understand the basics of how to join text. This can become very complicated however when you are joining lots of text together. The best way to learn is to practice joining two or three texts together like in the above examples and when you have mastered this you can then start to make your formulas more complicated by joining more texts together.


Perform Two-Way Lookups

Lookups are one of the most powerful ways to perform data analysis. There are many Excel functions which perform lookups such as VLOOKUP, HLOOKUP and LOOKUP but these only perform single lookups. You can perform two-way lookups using the XLOOKUP
 function which looks at a lookup value in a row and column to return a value. Before XLOOKUP, you could perform this same feat by combining the INDEX+MATCH functions together but this was more complicated to do. Note that XLOOKUP is only currently available in Office 365 at the time of writing.

Before we look at an example of how to perform a two-way lookup using XLOOKUP, it is important to understand what its syntax is and an explanation of it arguments.

The syntax for XLOOKUP is:

=XLOOKUP (lookup_value, lookup_array, return_array, [if_not_found], [match_mode], [search_mode])

As you can see there are six arguments. Here is a description of what each argument means:


lookup_value
 - The value you are looking for in the column or row of the data set


lookup_array
 - The column or row of the data set to search the lookup value


return_array
 - The value you want to return from the column or row of the data set


[if_not_found]
 - This is an optional argument. The value to return if the lookup value is not found. If you do not specify this argument then Excel will return a #N/A error


[match_mode]
 - This is an optional argument. With this argument you can specify the type of match you want by selecting one of the following options:


	
0 - Exact match




The lookup value should exactly match the value in the lookup array. This is the default option


	
-1 - Exact match or next smaller item




This looks for an exact match but if the exact match is not found then it looks for the next smallest value


	
1
 - Exact match or next larger item




This looks for an exact match but if the exact match is not found then it looks for the next largest value


	
2 - Wildcard character match




This is to perform partial matching by using wildcard characters such as an asterisk (*), question mark (?) or a tilde (~)


[search_mode]
 - This is an optional argument. If this argument is selected, you can specify how XLOOKUP performs its search of the lookup array. You can select one of four options:


	
1
 - Search first-to-last




XLOOKUP will search for the lookup value in the lookup array from top to bottom. This is the default option


	
-1 - Search last-to-first




XLOOKUP will search for the lookup value in the lookup array from bottom to top. This is useful if you want to find the last value


	
2 - Binary search (sorted ascending order)




This performs a binary search. The data needs to be sorted in ascending order first otherwise XLOOKUP can return an error or a wrong result


	
-2 - Binary search (sorted descending order)




This performs a binary search. The data needs to be sorted in descending order first otherwise XLOOKUP can return an error or a wrong result

Now let’s dive straight in and look at an example of how to perform a two-way lookup.
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In the above dataset, I have a list of Sales people with their sales each month. I want to find the sales for Mick Taylor in July and enter it in cell B18.
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The formula in cell B18 is:


=XLOOKUP(B16,A2:A14,XLOOKUP(B17,B1:M1,B2:M14))
 .

I will break this formula down by its arguments to explain how this two-way lookup formula works:


1
 st
 XLOOKUP



lookup_value
 - In the first XLOOKUP, I want to search for the name “Mick Taylor”, so the lookup value is cell B16


lookup_array
 - I want to search the name “Mick Taylor” in the range A2:A14 as this is where the list of sales people are


return_array
 - In this argument I insert another XLOOKUP function so I can do a column search


2
 nd
 XLOOKUP



lookup_value
 - In the second XLOOKUP, I want to search for the month “Jul”, so the lookup value is cell B17


lookup_array
 - I want to look up the month “Jul” in the range B1:M1 as this is where the list of months are


return_array
 - The return array is the array of sales in the range B2:M14

I do not need the optional arguments, if_not_found, match_mode and search_mode so I close the brackets after the return_array argument.

So how does this formula work? This formula first searches the name of the sales person in the range A2:A14 and locates the row index number for Mick Taylor. This is in row 8 of the range A2:A14. It then does a search for the month and locates the column index number for Jul in the range B1:M1. Jul is in column 7 of the range B1:M1. It then does a cross section between row 8 and column 7 and returns $508.

I have written a whole book on the subject of XLOOKUP. If you want to learn more about the book and XLOOKUP in more detail then please click the link below:


Excel Formulas and Functions: The Step by Step Excel Book for Beginners on how to Master Lookup Formulas using the XLOOKUP Function



Seek a Desired Output using Goal Seek

The Goal Seek tool in Excel is an advanced What-If Analysis tool which allows the user to determine the desired input value when the output value is already known. To explain this further let’s look at an example.
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In this example, there is a list of students with their grades. I have entered the average grade of all the students in cell B7 using the formula =AVERAGE(B2:B5)
 . Notice Emma doesn’t have a grade yet. I want an average score of 80% for all students including Emma. We need to establish what grade she needs in order to get an average score of 80%. Here are the steps to do this:


1) 
 Click on Data > Data Tools > What-If Analysis > Goal Seek from the ribbon
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2) 
 The Goal Seek Dialog Box
 appears. In the Set cell
 field select the cell which contains the formula you want to resolve. I want to resolve the average grade in cell B7 so I select this cell. In the To value
 field enter the result you want. I want the average grade to be 80% so I enter 0.8. In the By changing cell
 field enter the cell reference that you want to adjust. I want to adjust Emma’s grade so I enter cell B5. Once done click the OK
 button
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3) 
 Once you have clicked the OK button, Goal Seek calculates what score Emma needs to get in order to achieve an average score of 80%. Goal Seek calculates that Emma needs a grade of 90%
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TOP 20 SHORTCUTS

Below I have listed my top 20 shortcuts that have not already been mentioned in the book. These shortcuts will make you work faster and become more efficient in Excel as you will not have to keep on finding these commands in the ribbon.
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MORE BOOKS BY EXCEL MASTER CONSULTANT

If you enjoyed reading this book then please look out for more Excel books written by me. I have Excel books in two series which are Excel Bible for Beginners
 and Excel Formulas and Functions
 .

Excel Bible for Beginners Series

Below are two further books in the Excel Bible for Beginners series
 .

Excel Bible for Beginners: The Essential Step by Step Guide to Learn Excel for Beginners
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If you are an Excel novice and would like to know all the great tools and features Excel has to offer then Excel Bible for Beginners: The Essential Step by Step Guide to Learn Excel for Beginners
 will show you.

What you will learn in this book:


	What is Excel?

	What is Excel used for?

	How to open and save workbooks

	How to use the Quick Access Toolbar

	How to change font styles

	How to wrap and merge text

	How to format numbers

	How to apply borders

	How to apply cell styles

	How to use the Format Painter tool

	How to insert and delete worksheets tabs

	How to insert and delete columns and rows

	How to freeze rows and columns

	How to hide/unhide columns and rows

	How to copy, paste and cut

	How to use the Excel Find and Replace tool

	How to use the Excel Text to Speech function

	How to create charts and format them

	How to create formulas

	How to print



And much more!

You can buy this book from Amazon by clicking the below link:


https://www.amazon.com/Excel-Bible-Beginners-Essential-Guide/dp/B088JS6YVS


Excel Bible for Beginners: The Step by Step Guide to Create Pivot 
 Tables to Perform Excel Data Analysis and Data Crunching
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If you are want to learn how to create pivot tables to easily analyse large data sets then Excel Bible for Beginners: The Step by Step Guide to Create Pivot Tables to Perform Excel Data Analysis and Data Crunching
 will teach you how.


Here are some of the topics you will learn from this Excel book
 :



	What is a pivot table?

	Why you should use pivot tables?

	How you should structure your data source before you create a pivot table?

	How to create a basic pivot table?

	How to format and customise a pivot table?

	How to apply number formatting to a pivot table?

	How to display grand totals and subtotals to a pivot table?

	How to sort, filter and group items in a pivot table?

	How to perform calculations?

	How to use slicers to filter a pivot table?

	How to create pivot charts?



After reading this Excel book you will be able to create pivot tables and use all the available tools and functions to perform Excel data analysis easily. You will be able to create various Excel pivot tables from just one data source which summarises the data in different ways. If you have never used pivot tables before then you will learn how easy it is to analyse large data sets without using formulas. You will be able to use pivot tables in Excel dashboards and create slicers to summarise and dissect information in your pivot tables.

You can buy this book from Amazon by clicking the below link to your web browser:


https://www.amazon.com/Excel-Bible-Beginners-Analysis-Crunching-ebook/dp/B08BJFRM28


Excel Formulas and Function Series

Below are two books in the Excel Formulas and Functions series
 .

Excel Formulas and Functions: The Complete Excel Guide for Beginners
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If you want to learn about the best and most commonly used Excel formulas and functions to use for your worksheets then you need to buy Excel Formulas and Functions: The Complete Excel Guide for Beginners


This book includes:


	Tips on how to create more efficient formulas

	How the order of operator precedence in Excel formulas work

	How to check formulas in your worksheets

	How to use the Excel Insert Function Formula Builder to make formulas easier to write

	How relative, absolute and mixed cell references are used to construct formulas

	How to create sum and counting formulas using Excel functions such as SUMIF, SUMIFS, COUNTIF, COUNTIFS, COUNTBLANK

	How to create logical formulas using the IF, OR, AND functions

	How to create lookup formulas using Excel functions such as VLOOKUP, HLOOKUP and combining the INDEX and MATCH functions together to create powerful one way and 
 two-way lookups

	How to create text formulas by using Excel functions such as LEFT, RIGHT, MID, and CONCATENATE to manipulate text in your worksheets

	Great Excel hints and tips to help you become more efficient and save time



And much more!

You can buy the book from Amazon by clicking on the link below.


https://www.amazon.com/Excel-Formulas-Functions-Complete-Beginners/dp/1699170932


Excel Formulas and Functions: The Step by Step Excel Guide on how to Create Powerful Formulas
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If you want to learn how to create powerful formulas such as array formulas that perform the impossible then you can buy Excel Formulas and Functions: The Step by 
 Step Excel Guide on how to Create Powerful Formulas


In this book you will learn:


	How to create more advanced Excel formulas using powerful Excel functions such as SUMPRODUCT

	How to create array formulas

	The advantages and disadvantages of array formulas

	What arrays and array constants are

	What the order of operator precedence is and how Excel orders the calculation in formulas

	How to create formulas that do the impossible!



And much more!

Each example of how to create a formula starts off with a real-life business case scenario and will explain what Excel functions will be used in the formula to solve the business case scenario problem. It will also give you step by step instructions of how the formulas work by breaking each section of the formula down in simple easy to follow steps.

You can buy the book from Amazon by clicking the link below.


https://www.amazon.com/Excel-Formulas-Functions-Create-Powerful-ebook/dp/B085ZQKXSV


Excel Formulas and Functions: The Step by Step Excel Book for Beginners on how to Master Lookup Formulas using the XLOOKUP Function
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Learn how to create powerful lookup formulas using the new Excel XLOOKUP function. Excel Formulas and Functions: The Step by Step Excel Book for Beginners on how to Master Lookup Formulas using the XLOOKUP Function
 is the most comprehensive book yet on XLOOKUP. Many workplaces require you to work with large data sets and to manipulate and extract information from the data set. XLOOKUP is the easiest and best way to do this and this book will teach you how with clear examples and lots of screenshots. You can also download free practice worksheets so you can follow along and practice what you have learnt.

In this book you will learn:


	What is XLOOKUP?

	What the XLOOKUP syntax is and an explanation of all its arguments

	What the limitations of VLOOKUP are and how XLOOKUP addresses these

	What are relative and absolute cell references

	How to perform vertical lookups using XLOOKUP

	How to perform horizontal lookups using XLOOKUP

	What the different error types are in Excel

	How to use XLOOKUP to replace errors with more meaningful values

	How to perform an approximate match using XLOOKUP

	How to use wildcard characters to perform partial matches with XLOOKUP

	How to extract the last value in a column or array using XLOOKUP

	Learn what the new ‘Spill’ term is and why it occurs

	How to return multiple values across cells using just one XLOOKUP formula to save time

	How to perform two-way lookups using XLOOKUP which replaces the more complex INDEX+MATCH functions



You can buy the book from Amazon by clicking the below link:


https://www.amazon.com/Excel-Formulas-Functions-Beginners-Function-ebook/dp/B08F73L8V5



ABOUT THE AUTHOR
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I’m Harjit Suman and I love all things Excel. I wrote this book as I want to teach you all about Excel and its vast arrange of tools and features to enable you to become as efficient as possible with your spreadsheets. I really enjoyed learning Excel over the years and picked up vast amounts of knowledge in this awesome spreadsheet program. I now want to pass on my knowledge to you and my goal is to make this an enjoyable learning experience for you too.

My Background

The first time I used Excel was in my first analytical role as a Business Analyst back in 2008. The problem was, I had no great experience in Excel other than simple data entry. Some of my first projects in data analysis took so long to do. In fact, most of it was manually done as I 
 knew of no other way.

I knew this couldn’t continue so I invested in a beginners Excel book to expand my knowledge. I wanted to automate my spreadsheets as much as I could to save me time. After reading my first book I started to understand the power of Excel. I bought more and more Excel books and practiced what I read in the evenings and weekends, well, whenever I had free time. I then applied what I learnt in my full-time work as a Business Analyst. Soon, over time I went from an Excel beginner to an advanced user and I managed to automate my spreadsheets as much as I could.

However, I wanted to take my Excel skills to another level so I learnt Visual Basic for Applications (VBA) where I could write my own macros. I bought VBA books and practiced what I learnt in my spare time. Now I am able to write my own macros to build tools and applications not just for myself but for other businesses too.

Now it’s your Turn

Over the years I have learnt a lot about Excel and I now want to pass on my knowledge to you through this book. I have also created a website, www.excelmasterconsultant.com
 . In here you can find reviews of the many Excel books I have read which have taken my Excel skills to the next level, and they will for you too. You will also find great tutorials and blogs I have written as well as Excel courses and add-ins you can buy. I also run an Excel consultancy service if you need any help with your spreadsheets.

I hope you enjoy this book. I would love to hear from you with anything Excel related so please get in touch by contacting me through my website.

In the meantime, happy Excel learning.

Harjit Suman

Excel Master Consultant
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ADDITIONAL RESOURCES

For more information about Excel you can visit my website www.excelmasterconsultant.com
 .

In my website you will find:


	Excel tutorials and blogs to expand your Excel knowledge




	Books you can buy that I read while I was learning Excel which has helped me to advance my Excel skills and which I recommend to you




	Excel applications you can buy which will make you more efficient and save you time




	Online Excel and VBA courses you can buy




	More information about my Excel consultancy services that I offer




	An online shop where you can buy books, applications and courses



Please take a visit and drop me a message. I would love to hear from you.


LEAVE A REVIEW

What did you think of this book?

First of all, thank you for purchasing this book. I know you could have picked any number of Excel books to read, but you picked this book and for that I am extremely grateful.

I hope that it has improved your productivity and efficiency in Excel. If so, it would be really nice if you could share this book with your friends and family by posting to Facebook
 and Twitter
 . I would be grateful if you can share your experience of reading this book to your friends and family and what you got out from reading the book.

If you enjoyed this book, I’d like to hear from you and hope that you could take some time to post a review on Amazon
 . Your feedback and support will help me to greatly improve my writing craft for future projects and make this book even better.


You can leave a book review on Amazon here


I want you, the reader, to know that your review is very important to me and so, if you’d like to leave a review
 , all you have to do is click here
 and away you go. I wish you all the best in your future success and happy Excel learning!
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sales person | Jan Feb March | April May Jun Jul Aug sep oct Nov Dec

Jake $5,766 $7,479 $2,405 $690 $1,038 $8,933 $2,942 $6,650 $8,947 $8,516 $8,331 $5,737
Imran $1,815 $3,575 $7,190 $1,633 $4,622 $1,465 $3,354 $4,191 $863 $1,661 $4,000 $6,878
Jessica $8,293 $3,843 $2,951 $4,929 $1,272 $6,521 $8,228 $8,904 $5,067 $8,875 $7,279 $7,645
Seeta $2,506 $7,284 $8,822 $3,904 $1,601 $8,924 $3,168 $6,843 $8,231 $1,547 $2,184 $6,421
Jay. $7,017 $2,101 $5,055 $3,109 $6,995 $5,788 $8,266 $8,543 $849 $5,831 $7,585 $6,447
Bob $5,.274 $1,354 $6,676 $7,965 $3,359 $5,601 $8,685 $8,880 $3,023 $5,401 $2,027 $2,440
Lisa $2,668 $2,958 $6,777 $1,690 $651 $2,173 $5,727 $2,923 $6,007 $3,783 $5132 $6,330
penelope 570 | sam | s3om | s7emr | 299 | ssom1 | s3,50 | sa087 | ssa07 | $3,319 | sio72 | se7sy
Paul $4,393 $8,775 $1,288 38,543 $5,927 $1,107 $8,070 $1,150 $7,469 $4,274 $3,745 $1177
Igbal $1,373 $1,180 $3,293 $4,135 $7,525 $8,281 $4,108 $3,587 $6,237 $2,077 $1,081 $2,713
Simon $2,584 $5,543 $2,969 $6,790 $2,462 $3,069 $6,633 $1,469 $2,086 $5,991 $7,029 $4,939
Hardeep $5671 | %6507 | $817a | S6,0m | sa657 | 4,030 | s1872 | sage1 | ss77s | s3an1 | 5,530 | sas02
Jane $4,595 $8,628 $2,053 $5,200 $8,838 $907 $1,402 $2,460 $1,296 $5,140 $5,660 $6,880
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sales Person|__Jan Feb March [ April May Jun Jul Aug sep oct Nov Dec

Jake $5,766 $7,479 $2,405 $690 $1,038 $8,933 $2,942 $6,650 $8,947 $8,516 $8,331 $5,737
Imran $1,815 $3,575 $7,190 $1,633 $4,622 $1,465 $3,354 $4,191 $863 $1,661 $4,000 $6,878
Jessica $8,293 $3,843 $2,951 $4,929 $1,272 $6,521 $8,228 $8,904 $5,067 $8,875 $7,279 $7,645
Seeta $2,506 $7,284 $8,822 $3,904 $1,601 $8,924 $3,168 $6,843 $8,231 $1,547 $2,184 $6,421
Jay $7,017 $2,101 $5,055 $3,109 $6,995 $5,788 $8,266 $8,543 $849 $5,831 $7,585 $6,447
Bob $5,.274 $1,354 $6,676 $7,965 $3,359 $5,601 $8,685 $8,880 $3,023 $5,401 $2,027 $2,440
Lisa $2,668 $2,958 $6,777 $1,690 $651 $2,173 $5,727 $2,923 $6,007 $3,783 $5132 $6,330
penelope 4570 | s | s3om | S7ema | S2,99 | ssom1 | $3,500 | s3,087 | s3.407 | s3,319 | suo72 | sa7sy
Paul $4,393 $8,775 $1,288 $8,543 $5,927 $1,107 $8,070 $1,150 $7,469 $4,274 $3,745 $1,177
Igbal $1,373 $1,180 $3,293 $4,135 $7,525 $8,281 $4,108 $3,587 $6,237 $2,077 $1,081 $2,713
Simon $2,584 $5,543 $2,969 $6,790 $2,462 $3,069 $6,633 $1,469 $2,086 $5,991 $7,029 $4,939
Hardeep $5,671 | %6597 | %8174 | $6071 | 4657 | 54,030 | s1872 | sase1 | sa77s | s33n1 | 5,50 | sas02
Jane $4,595 $8,628 $2,053 $5,200 $8,838 $907 $1,402 $2,460 $1,296 $5,140 $5,660 $6,880
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sales person| _Jan Feb March | April May Jun Jul Aug sep oct Nov Dec

Jake $5,766 $7,479 $2,405 $690 $1,038 $8,933 $2,942 $6,650 $8,947 $8,516 $8,331 $5,737
Imran $1,815 $3,575 $7,190 $1,633 $4,622 $1,465 $3,354 $4,191 $863 $1,661 $4,000 $6,878
Jessica $8,293 $3,843 $2,951 $4,929 $1,272 $6,521 $8,228 $8,904 $5,067 $8,875 $7,279 $7,645
Seeta $2,506 $7,284 $8,822 $3,904 $1,601 $8,924 $3,168 $6,843 $8,231 $1,547 $2,184 $6,421
Jay $7,017 $2,101 $5,055 $3,109 $6,995 $5,788 $8,266 $8,543 $849 $5,831 $7,585 $6,447
Bob $5,274 $1,354 $6,676 $7,965 $3,359 $5,601 $8,685 $8,880 $3,023 $5,401 $2,027 $2,440
Lisa $2,668 $2,958 $6,777 $1,690 $651 $2,173 $5,727 $2,923 $6,007 $3,783 $5132 $6,330
penelope 54570 | 4372 | s3om | S7eaa | S299 | ssom1 | s3,50 | s30m7 | ssa07 | $3,319 | suo72 | se7sy
paul 54393 | $8775 | S1om8 | s8,543 | $5,927 | s1,107 | ssoz0 | su1s0 | szae9 | saom | sagas | suam
igbal $1,373 $1,180 $3,293 $4,135 $7,525 $8,281 $4,108 $3,587 $6,237 $2,077 $1,081 $2,713
simon $2,584 $5,543 $2,969 $6,790 $2,462 $3,069 $6,633 $1,469 $2,086 $5,991 $7,029 $4,939
Hardeep $5,671 $6,597 $8,174 $6,071 $4,657 $4,030 $1,872 $2,861 $8,778 $3,321 $5,530 $2,502
Jane $4,595 $8,628 $2,053 $5,200 $8,838 $907 $1,402 $2,460 $1,296 $5,140 $5,660 $6,880
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sales Person|__Jan Feb March [ April May Jun Jul Aug sep oct Nov Dec

Jake $5,766 $7,479 $2,405 $690 $1,038 $8,933 $2,942 $6,650 $8,947 $8,516 $8,331 $5,737
Imran $1,815 $3,575 $7,190 $1,633 $4,622 $1,465 $3,354 $4,191 $863 $1,661 $4,000 $6,878
Jessica $8,293 $3,843 $2,951 $4,929 $1,272 $6,521 $8,228 $8,904 $5,067 $8,875 $7,279 $7,645
Seeta $2,506 $7,284 $8,822 $3,904 $1,601 $8,924 $3,168 $6,843 $8,231 $1,547 $2,184 $6,421
Jay $7,017 $2,101 $5,055 $3,109 $6,995 $5,788 $8,266 $8,543 $849 $5,831 $7,585 $6,447
Bob $5,274 $1,354 $6,676 $7,965 $3,359 $5,601 $8,685 $8,880 $3,023 $5,401 $2,027 $2,440
Lisa $2,668 $2,958 $6,777 $1,690 $651 $2,173 $5,727 $2,923 $6,007 $3,783 $5132 $6,330
penelope 4570 | s | s3om | s7emr | S299 | ssom1 | s3,500 | s3,087 | s3,407 | $3,319 | sio72 | s7s7
Paul $4,393 $8,775 $1,288 $8,543 $5,927 $1,107 $8,070 $1,150 $7,469 $4,274 $3,745 $1,177
Igbal $1,373 $1,180 $3,293 $4,135 $7,525 $8,281 $4,108 $3,587 $6,237 $2,077 $1,081 $2,713
Simon $2,584 $5,543 $2,969 $6,790 $2,462 $3,069 $6,633 $1,469 $2,086 $5,991 $7,029 $4,939
Hardeep $5,671 | %6597 | $8174 | S60m1 | 4657 | 4,030 | s1e72 | sa@e1 | ss77e | s3301 | 5,530 | sas02
Jane $4,595 $8,628 $2,053 $5,200 $8,838 $907 $1,402 $2,460 $1,296 $5,140 $5,660 $6,880
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sales person| _Jan Feb March | April May Jun Jul Aug sep oct Nov Dec

Jake $5,766 $7,479 $2,405 $690 $1,038 $8,933 $2,942 $6,650 $8,947 $8,516 $8,331 $5,737
Imran $1,815 $3,575 $7,190 $1,633 $4,622 $1,465 $3,354 $4,191 $863 $1,661 $4,000 $6,878
Jessica $8,293 $3,843 $2,951 $4,929 $1,272 $6,521 $8,228 $8,904 $5,067 $8,875 $7,279 $7,645
Seeta $2,506 $7,284 $8,822 $3,904 $1,601 $8,924 $3,168 $6,843 $8,231 $1,547 $2,184 $6,421
Jay. $7,017 $2,101 $5,055 $3,109 $6,995 $5,788 $8,266 $8,543 $849 $5,831 $7,585 $6,447
Bob. $5,.274 $1,354 $6,676 $7,965 $3,359 $5,601 $8,685 $8,880 $3,023 $5,401 $2,027 $2,440
Lisa $2,668 $2,958 $6,777 $1,690 $651 $2,173 $5,727 $2,923 $6,007 $3,783 $5132 $6,330
Penelope $4,570 $4,372 $3,981 $7,842 $2,99% $8,981 $3,520 $3,087 $3,407 $3,319 $1,272 $8,787
Paul $4,393 $8,775 $1,288 $8,543 $5,927 $1,107 $8,070 $1,150 $7,469 $4,274 $3,745 $1,177
Igbal $1,373 $1,180 $3,293 $4,135 $7,525 $8,281 $4,108 $3,587 $6,237 $2,077 $1,081 $2,713
simon $2,584 | $5503 | $2,969 | %6790 | s2.462 | $3,009 | $6,633 | S1a69 | 2,086 | $5991 | 57,09 | $4,939
Hardeep $5,671 | %6597 | %8174 | $6071 | 4657 | 4,030 | s1872 | sage1 | ss77e | s38n1 | 5,50 | sas02
Jane $4,595 $8,628 $2,053 $5,200 $8,838 $907 $1,402 $2,460 $1,296 $5,140 $5,660 $6,880
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salesperson| san Feb March | April May Jun Jul Aug sep oct Nov Dec
Jake $5,766 $7,479 $2,405 $690 $1,038 $8,933 $2,942 $6,650 $8,947 $8,516 $8,331 $5,737
Imran $1,815 $3,575 $7,190 $1,633 $4,622 $1,465 $3,354 $4,191 $863 $1,661 $4,000 $6,878
Jessica $8,293 $3,843 $2,951 $4,929 $1,272 $6,521 $8,228 $8,904 $5,067 $8,875 $7,279 $7,645
Seeta $2,506 $7,284 $8,822 $3,904 $1,601 $8,924 $3,168 $6,843 $8,231 $1,547 $2,184 $6,421
Jay. $7,017 $2,101 $5,055 $3,109 $6,995 $5,788 $8,266 $8,543 $849 $5,831 $7,585 $6,447
Bob. $5,.274 $1,354 $6,676 $7,965 $3,359 $5,601 $8,685 $8,880 $3,023 $5,401 $2,027 $2,440
Lisa $2,668 $2,958 $6,777 $1,690 $651 $2,173 $5,727 $2,923 $6,007 $3,783 $5132 $6,330
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