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Read Me First

Welcome to Take Control of Preview, version 1.3, published in May 2023 by
alt concepts. This book was written by Josh Centers and Adam Engst.
Versions 1.0 through 1.2 were edited by Scholle McFarland with help from
Tonya Engst; version 1.3 was edited by Joe Kissell.

This book explains how to use Apple’s Preview app to view and edit images
and PDFs. The book goes beyond the basics to explore numerous features
hidden deep within Preview.

If you want to share this ebook with a friend, we ask that you do so as you
would with a physical book: “lend” it for a quick look, but ask your friend
to buy a copy for careful reading or reference. Discounted classroom and
Mac user group copies are available.

Copyright © 2023, Josh Centers and TidBITS Publishing Inc. All rights
reserved.

Updates and More
You can access extras related to this ebook on the web (use the link in
Ebook Extras, near the end; it’s available only to purchasers). On the
ebook’s Take Control Extras page, you can:

Download any available new version of the ebook for free, or buy any
subsequent edition at a discount.

Access the book in both PDF and EPUB formats. (Learn about reading
on mobile devices on our Device Advice page.)

https://www.takecontrolbooks.com/class-copies/
https://www.takecontrolbooks.com/device-advice/


Read the ebook’s blog. You may find new tips or information, as well
as a link to an author interview.

If you bought this ebook from the Take Control website, it has been added
to your account, where you can download it in other formats and access any
future updates.

Settings vs. Preferences
In macOS Ventura, Apple replaced System Preferences with System
Settings, and in most apps, the Preferences menu item and window became
a Settings menu item and window. In this book, we sometimes use a
shorthand like “go to Preview > Settings/Preferences” to reflect both
possibilities; when the details are significantly different, we spell them out
separately as “Ventura or later” and “Monterey or earlier.”

What’s New in Version 1.3
We’ve replaced nearly every screenshot in the book to bring it up to date
with macOS 13.4 Ventura. Additionally, there are a few changes and new
features:

Visual Lookup can identify plants, animals, landmarks, works of art,
and other things. See Identify Photos with Visual Lookup.

macOS Ventura dropped support for opening and editing PostScript
and Encapsulated PostScript (EPS) files. However, we never discussed
these capabilities in the book. You can still export files in PostScript
format; see Exporting to Other File Formats.

There is now a Form Filling toolbar specifically for filling out PDF
forms. It’s merely a smaller subset of the tools available on the Markup
toolbar. See Tour and Customize the Main Toolbar.



macOS Monterey added the Live Text feature, which lets you select
text and copy text in images. See Selecting Text in Pictures for a brief
explanation of how it works and instructions for how to turn it off.

New PDF export options were added.

Apple has added a Redact tool to permanently delete text from PDFs.
See Redacting Text.

Preview now has many more options for restricting permissions for a
PDF in addition to encryption. See Restricting PDFs.

What Was New in Version 1.2
This update featured fixes and updates for small changes. The one notable
new feature in Preview was being able to create a signature with an iPhone
or iPad, which we cover in Signing PDFs.



Introduction

So much criticism has been heaped on the likes of News and Photos that it
can be easy to forget the software that Apple gets right—apps that are both
simple and powerful. There may be no better example of this than Preview,
which has been built into macOS from the beginning.

To call attention to all the things Preview can do, we published the “Power
of Preview” series of articles in TidBITS in early 2016. The articles proved
wildly popular, and we received numerous requests for a book about
Preview. “That’ll be easy,” we thought. Little did we know.

On the surface, Preview is a simple image and PDF viewer that launches
automatically when you open a photo or a PDF document. Open, read, close
—that’s the Preview experience most people have most of the time. But
Preview offers so much more. Use Preview to do all this—no additional
apps required:

Take screenshots and import photos directly from a camera

Quickly cull unwanted images from a large collection

Play slideshows of party photos

Crop, resize, and edit images for use on your website

Convert images to many different formats

Scan paper documents with a scanner

Annotate PDFs with highlights, notes, and shapes



Fill out and sign PDF-based forms digitally, rather than going to the
trouble of printing and signing manually

Rearrange and delete PDF pages, and merge PDFs

We were under the impression that we had covered all of Preview’s features
in our articles, and that we would merely have to polish the prose a bit and
tweak some screenshots to turn the articles into a book. For each chapter,
though, as we started testing and retesting what we’d written, we discovered
that Preview was even deeper and more capable than we’d previously
realized. Couple that with a lot more screenshots, step-by-step instructions,
and real-world usage suggestions, and our few articles turned into a full-
fledged book.

Our goal here is to show you everything that Preview can do and give you
ideas for using it to work with images and PDFs. Follow along, and we’ll
help you become far more capable with Preview and with your Mac in
general.

The first version of this book focused on Preview in macOS 10.11 El
Capitan, and we’ve now examined everything up to macOS 13 Ventura. If
you have an older version of macOS, much of this book will work just fine
for you, though the older your operating system, the more differences you
may see.



Preview Quick Start

When it comes to working with images and PDFs, Preview has many more
features than most people realize. It can’t do everything—it’s not a magical
mash-up of Adobe Photoshop and Acrobat Pro—but for the majority of
graphical and PDF needs, Preview may be all you need. Use this Quick
Start to jump to the appropriate part of the book; there’s no need to read the
book in order.

Pull files into Preview:

You can open files in all the normal ways, but you can also bring
images into Preview by Importing from the Clipboard, Importing from
a Screenshot, Importing from an iPhone or iPad, Importing from a
Camera, and Importing from a Scanner.

The main way to make new PDFs in Preview is by Printing to PDF,
although there are Other Ways to Make PDFs.

View images and PDFs:

As befits its primary function as an image and PDF viewer, Preview
offers numerous controls for how you can View and Manage Images as
well as Read PDFs.

Crop, resize, and rotate images:

For many people, editing images comes down to Cropping Images and
Resizing Images.

When cropping, you’ll want to use the tools explained in Selecting
Content in Images.



If your image is in the wrong orientation, learn how to flip it in
Rotating Images.

Annotate documents and images:

With PDFs, Preview provides tools for Highlighting Text and Adding
Notes to a PDF. You can also learn about Adding Shapes and Text to a
PDF.

If you need to fill out a PDF-based form, read Working with Forms and
Signing PDFs.

For image annotations, read Inserting and Manipulating Basic Shapes
and Adding Text to Images.

Use advanced editing techniques:

With images, you can make a lot of edits by Copying, Pasting, and
Deleting Image Content.

Need to border an image or erase something? You’ll be surprised at
what you can achieve by Inserting and Manipulating Basic Shapes.

Don’t forget that you can radically change the look of images by
Adjusting Colors.

With PDFs, there’s a lot you can do by Rearranging, Deleting, and
Adding Pages, not to mention Rotating Pages, Cropping Pages, and
Changing PDF Color.

Convert and export images and PDFs:

If you have a JPEG and need a PNG, Exporting to Other File Formats
explains how to accomplish that task.



For an overview of which image file format makes the most sense for
any given situation, read Choosing a File Format.

Shrink the size of an overly large PDF with the Reduce File Size
Quartz filter; see the PDF section of Choosing a File Format.

If security is important, read Restricting PDFs to learn how to protect
your content from spying eyes.

Stop looking for features that aren’t there:

Preview offers lots of PDF-related features, but there are others you might
expect to see, but which are not present. Find a list of these features in What
Preview Can’t Do with PDFs.



(Re)Acquaint Yourself with
Preview

You’ve probably used Preview many thousands of times over the years, but
we want to kick off the book with a few setup and configuration reminders
so everyone is on the same virtual page.

Preview is designed to work with both graphical images (in common
formats like JPEG, PNG, GIF, and TIFF) and PDF documents, the Adobe-
created Portable Document Format that’s ubiquitous on the internet for
electronic versions of paper documents.

On the face of things, images and PDFs are fairly similar, and you can do
many of the same things with them in Preview. However, there are
situations where the same tools in Preview work somewhat differently
depending on whether you’re manipulating an image or a PDF. The result is
that Preview is something of a chimera in the Mac world—most apps with
similar features focus either on images or PDFs, not both. For the most part,
we’ll discuss the graphic- and PDF-related features separately.

This chapter starts with a look at a few configuration details, and continues
with a look at the interface in Tour and Customize the Main Toolbar and
Tour the Markup Toolbar. We also touch on Sharing from Within Preview, a
set of more modern features that you may not yet be using. We close with
What Preview Can’t Do with PDFs, so you don’t waste time hunting for
features that don’t exist.

Make Sure Preview Opens Everything



Although Preview is the default app for most image types and for PDFs, it’s
possible that another app has taken over for Preview. For instance, you
might have configured GraphicConverter or Pixelmator to open JPEGs. The
most common remapping is with PDFs, since Adobe Reader can be
somewhat pushy about making itself the default PDF viewer.

If double-clicking a PDF or a particular image file format in the Finder
opens an app other than Preview, here’s how to put Preview back in control:

1. Select a file of the desired type in the Finder.

2. Choose File > Get Info (or press ⌘-I) to open the Info window.

3. Under “Open with,” choose Preview from the pop-up menu
(highlighted in red in Figure 1). If necessary, click the disclosure
triangle to the left of “Open with” to expand that section.



Figure 1: Make Preview the default viewer for a particular file type in the
Finder’s Info window.

4. Click Change All to make Preview the default viewer for all files of
that type.

Note: If you close the Info window without clicking Change All, macOS
changes only how the selected file will open. It does not set that app as the
default for all files of the same type.

Configure Preview Settings
Preview offers numerous ways to view images and PDFs, but most people
prefer the same views most of the time. You should set your favorites in
Preview’s settings window (choose Preview > Settings/Preferences), where
the options are broken up into three panes: General, Images, and PDF.



General Settings

There’s just a single setting on the General pane (Figure 2). It lets you
customize the color of the empty space around documents and images. Click
the color swatch and use the color picker to make it any color you want.

Figure 2: The General settings pane has just a single setting.

Image Settings

There are two settings on the Images pane (Figure 3).

Figure 3: Preview’s Images settings let you control how files open and
what the 100% scale equals.

The first affects how Preview opens files. Preview can open all files in one
window, open groups of files in the same window, or open each file in its
own window:

Open all files in one window: This option opens all images in the
same Preview window, whether or not you open them as a group. In
other words, if you have a few images open in Preview in one window,
and you double-click a screenshot in the Finder, it opens in the same



window as the others. (That might be OK, or it may strike you as
weird.)

Open groups of files in the same window: This option is generally
the best choice. It brings together all the files you open at once in a
single window, letting you navigate through them in the sidebar
(Figure 4)—for details, see Navigating Images via the Sidebar.

Figure 4: Stick with the default opening option, which opens multiple
selected files in the same window.

Note: Unfortunately, Preview sometimes opens multiple selected images in
more than one window, rather than treating the selected set as a group.
You can manually open additional images in the same window by dragging
them from the Finder into the desired window’s sidebar; see Opening
Images and Documents.

Open each file in its own window: If you select the third option, when
you select multiple images and open them in Preview, each one opens
in a separate window. This can make navigating a bunch of images
difficult.

Tip: Option-click a window’s close button to close every window open in that
app.



Tip: In our testing, after opening and closing many images, Preview (or
macOS, we’re not sure) sometimes became confused and started throwing
out spurious errors complaining about permissions problems. Quit and
relaunch Preview to make these go away.

The second setting in the Images section of Preview’s settings is “Define
100% scale as.” This affects how Preview displays images when you choose
View > Actual Size. Here’s how to decide which radio button to select:

If your images are for the screen: If you’re working primarily with
images for display on a screen, such as on webpages, it’s probably
most sensible to choose “1 image pixel equals 1 screen point.” That
way, if you open a 1920-by-1280 image that’s 300 pixels per inch
(ppi), Preview displays it at its actual size in pixels. A 1920-by-1280
image that’s only 72 ppi opens at exactly the same size. That’s what
you’d expect, since resolution isn’t relevant to publishing on screen.

If your images are meant for print: In this case, selecting “Size on
screen equals size on printout” may be more helpful, since then,
assuming the same pixel dimensions, a higher-resolution image appears
smaller and a lower-resolution image appears larger, just as would
happen on a printout.

Does that seem backward? Imagine that you have two 1200-by-900
pixel images, one of which is 300 ppi and the other is 100 ppi. The first
one is thus 4-by-3 inches in actual size (1200 and 900 pixels each
divided by 300 pixels per inch), and the second one is 12-by-9 inches
(1200 and 900 divided by 100). In this example, Preview displays the
300 ppi image at a significantly smaller size than the 100 ppi image
when both are at actual size.

The problem with Preview honoring the resolution-dependent physical
dimensions is that other graphics programs, like GraphicConverter,



focus only on pixel dimensions. So if you work in other graphics apps
too, Preview may confuse you by displaying the same image
differently. The moral of the story is that you shouldn’t get too
wrapped up in how large an image looks in Preview. If your image is
destined for the screen, focus on the pixel dimensions.

PDF Settings

You’ll find more options under PDF settings (Figure 5).

Figure 5: The settings in Preview’s PDF settings control how PDFs appear.

Here’s what these settings do:

Define 100% scale as: How you set this option depends a bit on what
Mac you’re using and what you want choosing View > Actual Size to
do.

If you’re working on a Mac with a large screen, like a Retina iMac,
selecting “Size on screen equals size on printout” may be best, since a
PDF of a standard US Letter sheet of paper (8.5-by-11 inches) will
likely open at a large size that’s conducive to reading, with the View
menu automatically set to Actual Size.



On a Mac with a smaller screen, like a MacBook Air, there’s no way a
PDF of a normal paper size can open at actual size and fit on screen.
Preview automatically chooses the View menu’s Zoom to Fit option.
However, if you’ve selected “1 point equals 1 screen pixel,” choosing
View > Actual Size won’t zoom the PDF much, whereas if you’ve set
the preference to “Size on screen equals size on printout,” View >
Actual Size displays the PDF much larger than can fit on screen.

In short, for a Mac with a large screen, use “Size on screen equals size
on printout” and for a Mac with a small screen, try “1 point equals 1
screen pixel.” If Preview doesn’t act the way you expect when you
choose View > Actual Size, try the other option—there’s no harm in
flipping it back and forth until you like what you see.

On opening documents: By default, this checkbox tells Preview to
open documents to the last-viewed page. This makes it easy to return to
your place when reading a PDF-based book. If you do a lot of PDF
creation and testing, deselect this option so PDFs always open to the
first page.

Opening for the first time: Use this option to set how Preview
displays pages. The options here are Continuous Scroll, Single Page,
and Two Pages, as described in Tweaking the PDF View. Choose the
one that best fits your working style. Continuous Scroll is probably the
best choice for laptop screens; Single Page or Two Pages may be better
if you have a big screen.

Use logical page numbers: This setting tries to help with documents
that have early pages denoted with Roman numerals instead of Arabic
numbers. Usually, it’s best to keep it enabled, but if you have trouble
hitting the correct page when using the Go to Page command, turn it
off. Users have complained that this feature doesn’t always work
reliably, regardless of how you set it.



Add name to annotations: By default, Preview marks annotations
with the name you specify here. This is useful if you’re collaborating
on a PDF with other people, so you can see who marked up what. You
can enter your name here, but it will probably already be filled in for
you, from your user account profile.

Tour and Customize the Main Toolbar
Throughout the rest of this book, we’ll cover a number of features available
from Preview’s menus, but many of them are more easily accessed via the
app’s toolbar.

Note: Many of Preview’s menu commands have memorable keyboard
shortcuts (like ⌘-Control-A for Tools > Annotate > Arrow). You can find all
these listed in the menus, and we mention the most useful of them
throughout the book. Since you’re likely to issue the same commands
repeatedly in Preview (changing the sidebar view, inserting a shape,
annotating a PDF), it’s worth spending a little time to memorize the
keyboard shortcuts for those actions.

Regardless of whether you’re viewing an image or a document, you should
see the toolbar at the top of the Preview window (Figure 6). If it’s not
showing, reveal it by choosing View > Toolbar > Show Toolbar or pressing
⌘-Option-T.

Figure 6: Preview’s main toolbar includes some standard buttons, but you
can add more.

The default items on the main toolbar are:

View : This button displays a menu that lets you choose what
appears in the sidebar. For more on these options, see Navigating
Images via the Sidebar and Navigating PDFs via the Sidebar.



Inspector : Click this button to show or hide the Inspector window;
see Examining Image Metadata, Examining PDF Metadataand Identify
Photos with Visual Lookup

Zoom : These two buttons enable you to zoom in and out. See
Zooming Images and Tweaking the PDF View.

Share : A menu masquerading as a button, Share displays options for
sending the current image or PDF to another app. See Sharing from
Within Preview.

Highlight : Active only when viewing a PDF, the Highlight button
and menu enable you to turn on highlight annotations and choose a
color or style. See Highlighting Text.

Rotate : Although you’re most likely to use it with images, this
button works with PDFs too. See Rotating Images and Rotating Pages.

Markup : This button displays the Markup toolbar, which we cover
next in Tour the Markup Toolbar.

Form Filling : Click this to reveal a toolbar with tools specific to
filling forms in PDFs. All of these tools are also available on the
Markup toolbar, so this toolbar isn’t terribly interesting.

Search: The Search field enables you to find text in a PDF; see
Searching Within a PDF. However, you can also use it to search for
particular images by filename when you have multiple ones open in a
single window.



Tip: If you open a lot of images in a window and are having trouble sorting
through the long list of thumbnails in the sidebar, a search can help. The
search results replace the contents of the sidebar and always show the
names of matching images, either with a tiny thumbnail if the sidebar was in
the Thumbnail view or without the thumbnail if it was using Table of
Contents view.

Like any good Mac app, Preview lets you customize which controls appear
on the toolbar. Plenty of controls are available, all of which duplicate menu
commands. To get started, choose View > Customize Toolbar to see the
customization dialog (Figure 7).

Figure 7: Don’t be shy about customizing Preview’s main toolbar to meet
your needs.

With the dialog open, if you don’t use any of the default buttons often, drag
them off the toolbar. You can add a variety of buttons to the default set.

For more control over zoom levels (see Zooming Images and Tweaking the
PDF View), you can choose from:



Zoom: The second of these button sets includes an Actual Size 
button between the Zoom In and Zoom Out buttons. You can also add
all these buttons separately.

Zoom to Fit  and Actual Size : These buttons are helpful for
seeing the difference between the actual size of an image or PDF and
what fits in the window.

Scale : This field enables you to zoom to a specified numeric
percentage.

Next up are some controls for Navigating Your PDFs:

Previous and Next : These buttons provide page-by-page PDF
navigation. (In most cases, navigating with the keyboard is easier; see
Navigating PDFs via the Sidebar.)

Page History : When you’re moving around within a PDF by
clicking internal links or by clicking thumbnails or ToC entries in the
sidebar, you can use these page history buttons to go back and forward,
just like in a web browser.

Page : As with Scale, this is a field, not a button. You can enter a
number in this field to jump to a specified page.

The last group of items is something of a grab-bag:

Slideshow : Click this button to start a slideshow of open images or
PDF pages—learn more in Playing an Image Slideshow and Viewing
in Full-Screen Mode.

Inspector : Click this button to show or hide the Inspector window;
see Examining Image Metadata, Examining PDF Metadata, and
Identify Photos with Visual Lookup.



Magnify : This button displays a loupe for examining small details
or text.

Selection : An escapee from the Markup toolbar, the Selection
button lets you make rectangular selections for copying or cropping.
See Selecting Content in Images.

Print : This button opens the Print dialog, as you’d suspect. That
could be useful if you print a lot or you want to apply a permissions
password to your document in order to limit what can be done with it
—see Printing to PDF.

Tour the Markup Toolbar
Most of Preview’s annotation tools are available in the Tools > Annotate
submenu, but it’s often easier to find them on the Markup toolbar (Figure
8), which you can display by clicking the Markup button on the main
toolbar or by choosing View > Show Markup Toolbar (⌘-Shift-A).

Figure 8: Preview’s Markup toolbar hides a powerful selection of editing
tools (tools for PDF shown; those for images vary slightly).

Unlike the main toolbar, you can’t customize the Markup toolbar. It
provides a variety of selection and editing tools that fall into a few
categories.

The first few tools help you select text and areas of graphics:

Text Selection : (PDF only) Click this icon to select text in a PDF for
copying to another document. See Copying Text and Images.

Rectangular Selection : When viewing a PDF, this tool lets you
make a rectangular selection you can copy as an image. However,



when you’re viewing an image, the icon becomes a menu that lets you
choose from different types of selections, such as Elliptical Selection or
Lasso Selection. (Learn more about the image-based uses of these tools
in Selecting Content in Images

Instant Alpha : (Image only; not shown above) Known as the
“magic wand” in other graphics apps, the Instant Alpha tool lets you
select areas of similar color. See Instant Alpha Tool.

Most of the rest of the items on the Markup toolbar help you Edit Images
and Annotate PDFs in a variety of ways:

Redact : (PDF only) With this tool enabled, any text you select is
permanently deleted from the PDF. See Redacting Text.

Sketch : The Sketch tool lets you draw freeform shapes. If you have
a Force Touch trackpad, you may also see a Draw  tool. See Creating
Your Own Shapes with Sketch and Draw.

Shapes : Although Preview helps smooth out your freeform
drawings, the Shapes menu makes it easier to draw rectangles, circles,
speech bubbles, and more.

Text : Click this icon to insert a text object that you can type in.

Sign : With the controls in this menu you can create an electronic
version of your signature and then insert it into PDFs or images.

Adjust Color : (Image only) Clicking this icon shows and hides the
Adjust Color window, which provides extensive control over the colors
in an image (see Adjusting Colors).

Image Dimensions : (Image only) This is a shortcut for Resizing
Images.



Note : (PDF only) This icon inserts a Post-it–style note where you
can type comments about a PDF.

Shape Style : Despite its name, this menu lets you choose among
different line widths and types for the shapes you create.

Border Color : As you’d expect, this menu gives you control over
the color of the lines of your shapes.

Fill Color : Use this menu to control the color of the inside of your
shapes.

Text Style : This popover lets you set text font, size, color, style, and
justification.

Image Description : You can add a written image description to
make images decipherable by the visually impaired using screen
readers.

Sharing from Within Preview
Whether you want to send a PDF to a colleague or message a photo to a
friend, it may be easiest to use Preview’s Share menu.

With an image or PDF open, click the Share  button to see any sharing
extensions that have been enabled in System Settings > Privacy & Security
> Extensions > Sharing (Ventura or later) or System Preferences >
Extensions > Share Menu (Monterey or earlier). Exactly what you’ll see
depends on the type of file you’re viewing and the way your system is set
up (Figure 9).



Figure 9: The Share menu lets you easily share files with other people and
apps.

Choose the service or app you want to use to share your file; what you’ll see
next depends on what you chose.

What Preview Can’t Do with PDFs
Preview is a great tool for working with PDF files (which is part of why we
wrote this book about it)—and it’s free, but depending on what you need to
do, it isn’t always the tool of choice. If you need more capabilities, check
out Nitro PDF Pro or Acrobat Pro.

What follows is a list of things that you might want Preview to do that it
can’t:

Editing of text or deleting images: With many apps, you can edit
(add, modify, and delete) the text of PDFs that have a text layer. And,
you can select and move or delete images within the PDF. Neither of
those are possible within Preview, although you may be able to

https://www.gonitro.com/pdf-pro/macos
https://www.adobe.com/acrobat.html


simulate certain edits by overlaying text or graphics on the PDF and
then Printing to PDF again.

Editing marks: Although we detail both the built-in features and some
creative workarounds for marking up a PDF document in Preview (see
Annotate PDFs), Preview doesn’t offer formal editor’s marks that
mimic the handwritten marks that editors traditionally use to indicate
insertions, deletions, lowercasing, and so on. Nitro PDF Pro offers a
nice library of editing marks.

Automatic page numbering: If a document already had page numbers
before it was made into a PDF, they’ll still be there in Preview. And, if
you want to number pages by hand in Preview, you could put a text
block on each page individually—you’ll have to type a page number
on each page. But, what you can’t do is add automatic page numbers,
where you’d insert a single auto-number element on one page and it
would then appear on all pages with the correct number. PDFpen and
Acrobat Pro can do this.

Table of contents creation: If you’re building a multi-page PDF, you
might want to add a table of contents to different sections of the PDF.
Preview can’t do that, whereas other apps can.

Interactive PDF form creation: Though you can fill out interactive
PDF forms using Preview, making them requires Nitro PDF Pro or
Acrobat Pro. Also, if you run across a complex form that Preview can’t
handle, use Adobe’s free Acrobat Reader. For more details, see
Working with Forms.

PDF to Microsoft Office formats conversion: Even Acrobat Pro isn’t
great for more than small edits, but they get around that limitation by
letting you export to other formats, such as Microsoft Word and
PowerPoint. Preview can open Office (and iWork) documents and can

https://get.adobe.com/reader/


export them to PDF, but it can’t do the reverse, exporting a PDF to an
editable document format.

Support for PDF/A and PDF/X: PDF comes in many different,
strictly defined ISO standards. For instance, there’s PDF/A (ISO
19005), which is intended for archival documents, and PDF/X (ISO
15930), which is designed for graphics exchange. If you work with
government documents or graphic design and your work demands
these features, Preview isn’t enough. It supports some PDF/X features,
but it doesn’t support PDF/A features at all. It can open these files, but
it might strip out things it can’t handle, like digital signatures (Not the
kind you sign with a pen, as described in Signing PDFs, but
cryptographic signatures.)

For the ultimate in compatibility with different PDF variants, stick with
Acrobat Reader or Acrobat Pro.

https://en.wikipedia.org/wiki/PDF/A
https://en.wikipedia.org/wiki/PDF/X


Open and Import

It’s important to be aware of all the ways you can move data into Preview,
because even though some are painfully obvious, others are more hidden.
And, the less obvious methods can be huge time savers.

In this chapter, we start with a look at the many ways you can open files and
documents, like PDFs and PNGs, that you already have stored in your
Finder. We then look at:

Importing from the clipboard: Anything you can copy, you can turn
into a new document in Preview. The results are sometimes just what
you’d expect, but other times rather intriguing. See Importing from the
Clipboard.

Importing from a screenshot: macOS’s screenshot tool lets you send
a newly taken screenshot right to Preview, where you can edit and
save. See Importing from a Screenshot.

Importing from an iPhone or iPad: The Continuity Camera feature
in macOS lets you bring a photo or scan into Preview directly from an
iOS device. See Importing from an iPhone or iPad.

Importing from a camera: Connect any digital camera to your Mac,
and you can preview your snaps in Preview, plus save them to the
Finder. See Importing from a Camera.

Importing from a scanner: Continuing on the theme of importing
from a hardware device, note that Preview can scan graphics and turn
papers into PDFs. See Importing from a Scanner.



Taking screenshots: Preview offers a nice workflow for capturing
portions of your screen in various ways and then modifying the image
in Preview before saving it. There’s even an option that provides a 10-
second delay. See Taking Screenshots.

Opening Images and Documents
Let’s begin by looking at how you open images and documents in Preview,
starting with the obvious ways and moving on to things you may not know.

If Preview is your default app for images and PDFs, those files will open in
Preview when you double-click them in the Finder or when you select files
in the Finder and choose File > Open. Similarly, you can go into Preview
and choose File > Open; if no documents are open, clicking Preview in the
Dock also shows the Open dialog. Or, drag a file to the Preview icon, either
in the Finder or in the Dock. You can even Control-click or right-click a file
in the Finder and choose Open from the contextual menu.

Tip: You can re-open recently opened files in Preview by choosing File >
Open Recent or by Control-clicking Preview’s Dock icon.

You probably know all of those methods, but slightly more subtle is the trick
of opening files through Quick Look: If you think you’ve found the right
file but aren’t sure, you can select the image or PDF file in the Finder and
then press the Space bar, or ⌘-Y, to peek at it in Quick Look. If it’s the
right one, press ⌘-O or click the Open with Preview button in the upper-
right corner.

Moving beyond macOS’s built-in ways of opening files, there are two
Preview-specific techniques that can be useful at times when you’re
working with images. (When used with PDFs, this trick merges the dropped
PDF into the open PDF.)



In Preview, with at least one image open, make sure the sidebar is showing
and is set to display thumbnails—for help with that, see Navigating Images
via the Sidebar. Then, from the Finder, drag an image into the sidebar
(Figure 10).

Figure 10: Drag images into the Thumbnails view of the sidebar to open
them in that window.

The other way of accomplishing this task is by choosing View > Contact
Sheet and dragging one or more images into the main window alongside all
the other thumbnails. Again, you need at least one image open to show the
contact sheet.



Opening iWork and Microsoft Office Documents

Technically speaking, Preview can open word processing documents written
in Apple’s Pages and Microsoft Word, spreadsheets made in Apple’s Numbers
and Microsoft Excel, and presentations created by Apple’s Keynote and
Microsoft PowerPoint. Just drag the document to Preview’s icon in the Dock.

However, this capability is neither particularly useful nor interesting. It’s not
all that useful because Preview can only display documents from iWork and
Office—it doesn’t offer any editing or annotation capabilities at all. At best,
you can zoom in and out, and copy text and (sometimes) graphics.

This capability isn’t all that interesting because every Mac sold for the past
decade has shipped with bundled copies of Pages, Numbers, and Keynote,
and those apps can open both their own documents and Office documents
with better visual fidelity. They also allow you to make changes.

Even if you have an older Mac, there are better choices. For those who never
bought either iWork or Microsoft Office, Apple’s TextEdit app can open and
edit Microsoft Word files. Finally, if you have an iCloud account (and who
doesn’t?), you can always upload a file to the appropriate web app on the
iCloud website to view and edit it there.

Importing from the Clipboard
Since Preview is primarily seen as an image viewer, you’ve probably never
looked closely at its File menu. Do that and you’ll notice that instead of a
plain old New command, it has one titled New from Clipboard. That
command does just what its name implies: it creates a new untitled
document containing the contents of the clipboard. It’s also often dimmed,
because it can work only when the clipboard contains image or PDF data.

To try this, copy an image from anywhere on the Mac (try Control-clicking
an image on a webpage in Safari and choosing Copy Image). Then switch to
Preview and choose File > New from Clipboard. You’ll get an Untitled
document containing the image.

https://www.icloud.com/


Similarly, if you have a PDF open in Preview, choosing Edit > Copy copies
the current page, and choosing File > New from Clipboard creates a new
PDF document containing just that page. Selecting multiple pages in the
Thumbnails sidebar or Contact Sheet view before copying is a fast way to
create a new PDF with just the selected pages.

You can put this capability to use in an interesting way to extract icons and
other images from apps, something that we often find ourselves needing to
do when illustrating TidBITS articles. To get an icon, select a file or folder
and choose File > Get Info. Then, in the Info window, click the item’s icon,
choose Edit > Copy (or press ⌘-C), switch to Preview, and choose File >
New from Clipboard. Preview creates a new document containing all sizes
and resolutions of that icon (Figure 11).

Figure 11: Preview can extract app, document, and folder icons from the
clipboard.

Note: Since apps in macOS are actually special folders called packages, you
can use Preview to look at every image used in the app, including the icon,
by simply dropping the app onto Preview’s icon in the Dock or Finder. Beware
that some apps have hundreds of images inside!

Using Preview’s New from Clipboard command is far from the only way to
create a new document with an image or PDF page, but it’s handy on
occasion.



Importing from a Screenshot
Mojave introduced a new interface for taking screenshots, invoked by
pressing ⌘-Shift-5 and then choosing a screenshot type from the control
bar that appears. It’s both largely self-explanatory and out of scope for this
book, but there is one way it integrates with Preview—you can open a
screenshot directly in Preview without saving it as a file first.

To set macOS to do this, invoke the screenshot control bar by pressing ⌘-
Shift-5, clicking one of the three screenshot buttons, and then, from the
Options pop-up menu, choose Preview from the Save To possibilities
(Figure 12).

Figure 12: Choose Preview from the Options pop-up menu to send
screenshots to Preview instead of saving them as files.

Note: Once you set the screenshot destination to Preview in this manner, it
applies to screenshots taken using the traditional ⌘-Shift-3 (full screen) and
⌘-Shift-4 (a window, menu, or arbitrary selection) commands as well.

Importing from an iPhone or iPad



Another feature introduced in Mojave is Continuity Camera, which makes it
easy to take a photo or scan a document with your iPhone or iPad, sending
the result directly to an app on your Mac. It’s a big time-saver, since you
don’t have to transfer the image or scan from your iOS device to your Mac.

Note: For Continuity Camera to work, your Mac must be running Mojave or
later, your iOS device must be running iOS 12 or later, they both need to
have Wi-Fi and Bluetooth enabled, and both must be signed into iCloud using
the same Apple ID, which must be using two-factor authentication. For
details, see Apple’s support article.

Tip: See Josh’s video demonstrating how to use Continuity Camera.

Follow these steps to take a photo directly into Preview:

1. In Preview, choose File > Import from iPhone or iPad > Take Photo. (If
you have multiple iOS devices, both appear in the sub-menu; choose
the one you’re using. We’ll assume you’re using an iPhone.)

2. A dialog appears, telling you to take a photo with your iPhone. You can
click Cancel if you invoked it accidentally, or it will disappear on its
own once you take the photo.

3. Switch to your iPhone, and note that it has brought up a simplified
version of the Camera app. You can switch between the front- and rear-
facing cameras, turn the flash on or off, and zoom.

4. Frame your subject in the viewfinder, and tap the shutter button.

5. Tap Use Photo to open the photo in Preview. Or, if the photo isn’t to
your liking, tap Retake to try again (Figure 13).

https://support.apple.com/en-us/HT209037
https://www.youtube.com/watch?v=NkOEzRdESSA


Figure 13: Line up your shot (left). You’re given the choice of using the
image or trying again (right).

6. Save the document.

Scanning works similarly. Follow these slightly more involved steps:

1. In Preview, choose File > Import from iPhone or iPad > Scan
Documents.

2. A dialog appears, telling you to scan a document with your iPhone.
Again, you can click Cancel if you invoked it accidentally, or it will
disappear on its own once you save your scan.

3. Switch to your iPhone, and note that it has brought up a simplified
version of the Camera app. This one uses only the rear-facing camera,
and it lets you control the flash, tap the Filters icon to choose the type



of scan (color, grayscale, black-and-white, or photo), and switch
between Auto and Manual scanning.

4. If you’re using Auto, hold the iPhone still over your document for a
few seconds, and the scanner will snap a picture automatically when it
detects the document edges. If you’re in Manual mode, tap the shutter
button and drag the circles to set the scan area, if necessary.

5. Tap Keep Scan. Or, if the scan isn’t right, tap Retake to try again
(Figure 14).

Figure 14: Capture the overall image (left) or select a specific area to scan
(middle). Then, you’re ready to scan more or tap Save to send the
document to Preview (right).

6. Continue scanning pages. When you’re done, tap the Save button that
appears in the lower-right corner to open the scanned page(s) in
Preview as an Untitled PDF.

7. Save the document.

Importing from a Camera



Here’s something you probably didn’t know: Preview can import images
from digital cameras. You can connect a camera to your Mac via USB or
use its media card in a card reader attached to your Mac.

By default, Preview displays the photos in a list, with EXIF information like
the date and time the picture was taken, file size, resolution, GPS
coordinates, aperture size, whether the flash was fired, and more. Even if
you don’t want to use Preview to import your photos, it’s a handy way to
view all that data.

To see what’s available to import from your camera, connect it or its media
card to your Mac, open Preview, and choose File > Import from
CameraName.

A window appears displaying thumbnails of the photos on that camera,
largely mirroring the look and capabilities of Apple’s standalone Image
Capture utility (Figure 15).

Figure 15: Preview can be used to not only import photos from a camera,
but also to view embedded EXIF information.

In the lower-left corner of the window, you see buttons to rotate photos 
(any photos you rotate here will be imported in that orientation), delete
photos , and view photos as a list  or grid . Adjust the size of the
thumbnails using the slider in the lower-right corner.

When you’re ready to import the photos, you have two options. Click
Import All to get everything or select a few photos and click Import



(double-clicking the selected photos is the same as clicking Import). Decide
where to save the images and click Choose Destination. Preview saves the
images and opens them in a new window as well.

Importing from a Scanner
If you have a compatible scanner attached to your Mac or available via Wi-
Fi, you can use Preview to import images and documents from it.

First, make sure your scanner appears in System Settings > Printers &
Scanners (Ventura or later; Figure 16) or System Preferences > Printers &
Scanners > Scan (Monterey or earlier). If it doesn’t, add it by clicking Add
Printer, Scanner, or Fax (Ventura or later) or clicking the plus  button
(Monterey or earlier).

Figure 16: Before you try to import from a scanner, make sure your
scanner appears in System Settings > Printers & Scanners.

Note: Perhaps not surprisingly, Preview’s scanning interface is nearly
identical to Image Capture’s. It’s also similar to the window that appears
when you click Open Scanner on the Printers & Scanners setting/preference
pane.



With the scanner attached, turned on, and a piece of paper ready to scan in
it, follow these steps:

1. In Preview, choose File > Import from ScannerName.

Preview opens its scanning window and performs an overview scan
that gives you a preview of what will be captured (Figure 17).

Figure 17: Preview’s scanning window shows a preview and lets you set a
wide variety of options in the details pane.

2. If the details pane isn’t showing already, click Show Details to display
a wide variety of controls for resolution, size, rotation, format, and
image correction (more on those shortly).

3. Select the area(s) to scan. By default, Preview draws a rectangular
selection box with handles you can drag. Adjust these so that the box
encloses what you want to scan. See the sidebar Selecting What You
Want to Scan, just after these steps, for more help.

Tip: Drag anywhere inside the dotted lines to move the selection box.



4. In the details pane, adjust the settings as desired (we explain them a
page or so below), and click Scan. Preview scans the document and
opens it as a new file named Untitled. Examine it to make sure you set
all the options properly. If not, close it without saving and try again
with different settings.

Note: If you selected more than one item, Preview creates a file for each
selection box.

5. If the scan looks the way you want, choose File > Save and then name
and save your document.



Selecting What You Want to Scan

The hardest part of scanning is selecting the content you want. There are
essentially two scenarios:

A single sheet of normal paper: Deselect the Use Custom Size option
and choose the appropriate paper size and orientation. If Preview’s
default selection box doesn’t fit the paper exactly, adjust it manually by
dragging a selection box handle (it will turn red).

One or more items smaller than a normal piece of paper: Select
Use Custom Size. If you’re feeling lucky, choose Detect Enclosing Box
(for one item) or Detect Separate Items (for multiple items) to see
whether Preview can detect the originals on its own. If it can’t, press ⌘-
A and then Delete to remove all the boxes. Then drag out new selection
boxes for each of the items you want scanned, and adjust them
manually if necessary (Figure 18).

Figure 18: Dragging out and adjusting each selection box manually is the
better part of valor if Detect Separate Items fails.

If your paper was askew, you can compensate by dragging the rightmost
handle in the middle of a box (you get a silhouette of a person in a circle—
see the figure above) around the circle to adjust the angle.

Now, let’s talk about all those scanning options on the details pane:



Scan Mode: On the scanner Adam uses, this pop-up menu lets him
choose between Document Feeder and Flatbed. If your scanner has
only one input method, this menu won’t appear.

Kind: Choose among Text, Black & White, and Color. Despite the
names, Text means monochrome (every pixel is either black or white),
Black & White means grayscale (black, white, and way more than 50
shades of gray in between), and Color means full color.

Note: If you’re scanning something that’s just text, either Text or Black &
White would be appropriate; if there are any graphics, either Black & White
or Color could be appropriate. When choosing, think about how the
scanned image or document will be used. If it will be printed, should it use
color ink or will it really only be grayscale? And if it’s meant to be
transferred electronically, does it end up overly large if scanned in color
versus one of the other options?

Resolution: Choices in this menu range from 50 dpi to 4800 dpi (and
may vary by scanner). 50 dpi is too low for almost anything, and
anything over 600 dpi will result in an unnecessarily large file unless
you’re scanning an original that’s both very small and very high
resolution, like a photographic slide. If you choose a resolution that
your scanner doesn’t support, Preview will display an error.

Tip: We recommend choosing 300 dpi for most things; if you’re scanning
photos for archival reasons, go to 600 dpi to ensure that you’re capturing
every detail. Even if you end up wanting to crop the image or reduce its
resolution to speed up loading time on a webpage, it’s better to start with
more pixels than fewer.

Use Custom Size (Selected): Select this checkbox if you are scanning
a photo or small paper ephemera, like ticket stubs—in short anything
that’s not a normal paper size. When selected, the following options
appear:



Size: Enter the dimensions of your original here, and choose the
appropriate units. It’s generally easier to resize the selection by
dragging the selection box’s handles.

Rotation Angle: Enter an angle here or adjust the angle manually
using the technique explained in Selecting What You Want to
Scan.

Auto Selection: If you are scanning multiple small items, Detect
Separate Items may work; for a single item, Detect Enclosing Box
is more appropriate. Or just choose Off and select your item(s)
manually.

Use Custom Size (Deselected): Leave this checkbox deselected if
you’re scanning a piece of paper in a common size, like US Letter or
A4. When this checkbox is deselected, the following options appear:

Size: Choose a paper size from this pop-up menu. The choices
may vary with the capabilities of your scanner.

Orientation : Click the button corresponding to the
orientation you want for your final scan. So if the image appears
upside-down in the preview area, click the third button with the
picture of the person on their head. The preview won’t change, but
the final scan reflects your selection.

Format: The choices in this menu are JPEG, HEIC, TIFF, PNG, JPEG
2000, GIF, BMP, and PDF. (The list varies based on what you selected
in the Kind menu, since there’s no point in scanning Text to GIF
format, for instance.) Which you choose depends on what you’re
scanning and what you want to do with the end results.



Note: As a rule of thumb, choose JPEG for photos, TIFF for archival
photos, PNG for solid-colored graphics or if you need transparency, and
PDF for print documents. (And with PDF, you get the option of combining
multiple selections into a single multi-page document.) For more details
about these formats, see Convert and Export.

Image Correction: None is probably fine for most things, but switch
to Manual if you want to adjust various options, which vary based on
what you’ve chosen in the Kind menu:

Text: The Threshold slider lets you adjust how sensitive the
scanner is to black pixels, and the Dither checkbox uses black
pixels to simulate grayscale. The defaults are usually good.

Black & White: When scanning in Black & White, you can adjust
just brightness and the contrast with a pair of sliders. Tweak them
until the preview looks the way you want.

Color: For scanning in Color, you can adjust brightness, tint,
temperature, and saturation with sliders.

Note: For images, we recommend sticking with None and Adjusting Colors
later. For PDFs, you might want to play with the settings to improve the look
of the preview before scanning, since it’s much harder to do that later on
with PDFs.

Depending on your scanner, you may have additional options in the details
pane. These options appeared for us when using the scanning feature of an
Epson multi-function printer:

Unsharp Mask: Choose from None, Low, Medium, or High. Unsharp
Mask makes images look sharper, at least in theory. It made no
difference in our tests in either the preview or final scan.



Descreening: When scanning from a newspaper or magazine, the
options here can compensate for the halftone printing process used. If
you see wavy moiré patterns when you scan, try choosing General,
Newspaper, Magazine, or Fine Prints from the Descreening menu.
You’ll need to experiment to see which option produces the best results
from your original. The preview doesn’t reflect what you choose in this
menu; you’ll have to do a scan to see the results.

Backlight Correction: If you’re scanning a photo and it’s too dark, try
changing Backlight Correction from None to Low, Medium, or High
and see if that improves the result. Again, you must scan to see the
results.

Dust Removal: Depending on your scanner, you may see a pop-up
menu for Dust Removal, with options for None, Low, Medium, and
High. It tries to remove dust spots from the image automatically; test
each option to see if it improves the final scan.

Color Restoration: This checkbox might be useful when scanning old
color photos that have faded, but you’ll have to experiment with full
scans (the preview window doesn’t reflect changes) or just ignore and
assume you’ll be Adjusting Colors later.

Note: In previous versions of Preview, there was an Edit > Insert > Page
from Scanner command that let you scan a page and insert it into an
existing PDF. That’s gone now, but you can simulate it by copying a page
from another PDF or merging PDFs. See Rearranging, Deleting, and Adding
Pages.

Taking Screenshots
Those of us who write about technology have memorized Apple’s keyboard
shortcuts for taking screenshots, but normal people who need to take a



screenshot only a few times a year might prefer to turn to Preview instead.

Note: About those keyboard shortcuts: ⌘-Shift-3 takes a screenshot of the
entire screen(s), ⌘-Shift-4 lets you drag out a selection first or restrict the
shot to a window or menu, and ⌘-Shift-5 brings up the screenshot control
bar.

To take a screenshot in Preview, choose File > Take Screenshot and pick a
command from the submenu:

From Selection: After choosing this command, your pointer becomes
a crosshair. Drag the crosshair over the screen area you want to
capture. This is useful for capturing only part of a window, or if you
want to capture multiple windows while including a bit of background.

From Window: Choose this command, and your pointer changes to
look like a camera . Move the pointer over a window and the
window turns color to indicate that it’s selected.

Click to take a screenshot of that window. This is useful when you just
want to capture a single window and not the entire screen.

Tip: By default, window screenshots get a large transparent shadow; to
capture a screenshot without it, Option-click the selected window instead
of just clicking.

From Entire Screen: When you choose this command, a 10-second
countdown begins. Once it finishes, Preview takes a screenshot of your
entire screen. If you have multiple screens, Preview creates screenshots
for each one. The timer is useful when you need to set up the screen in
such a way that wouldn’t be possible with an instantaneous screenshot.
Although it won’t appear in the final screenshot regardless, you can
move the countdown timer bar around to get it out of your way.



Capturing the Pointer

The big win of using Preview’s From Entire Screen command is that it always
includes the mouse pointer. Before Mojave, there was no way to capture the
pointer with Apple’s normal screenshot shortcuts. Capturing the pointer is
now possible, and if you set that option on the screenshot control bar, the
traditional shortcuts also honor that setting, making it possible to capture
screenshots that require the mouse button to be down (such as when you’re
showing something being dragged.) Tweaky, we know, but we tech writers
run into this stuff all the time. Still, we occasionally run into situations that
don’t work with the macOS screenshot capabilities, and for those, we return
once again to Preview and its From Entire Screen command.

Tip: To cancel before Preview takes the screenshot using any of these
methods, press Esc.

Preview opens each new screenshot as a PNG file in an untitled window,
where you can make any modifications you like before saving it. Simple,
but effective.



View and Manage Images

For many people, Preview’s primary function is as a viewer for both images
and PDFs. Although much of what we cover in this chapter also applies to
PDFs, our focus here is on the many ways you can view images in Preview.

We begin by making sure you can use the sidebar and its various views to
full advantage, especially the Contact Sheet view, which is helpful for
working with a large collection of images. We also cover Zooming Images
and Viewing in Full-Screen Mode, plus Playing an Image Slideshow.

If you find yourself wanting to learn more about an image—what its pixel
dimensions are, when it was created, and more—we discuss how to do that
in Examining Image Metadata.

But that’s not all that Preview can do—you can also work with the files
underlying the images you’re viewing. For instance, if you need to cull
near-duplicates from a folder containing a large number of graphics, you
don’t even need to leave Preview; see Managing Images.

Navigating Images via the Sidebar
When it comes to navigating among multiple images, Preview’s sidebar is
your friend. Preview tries to be smart about displaying this tool, so if you
open multiple images, the sidebar automatically appears, as you can see in
Figure 19.



Figure 19: Preview’s sidebar automatically displays on the left side of the
window when you open multiple images in the same window.

You can hide the sidebar by choosing View > Hide Sidebar (⌘-Option-1).
Note that this command is a one-way toggle; if Preview’s sidebar is
showing, choosing Hide Sidebar makes it disappear and puts a checkmark
next to the menu command. Choosing it again does nothing. To bring the
sidebar back, you must instead choose another of the sidebar-related
commands like View > Thumbnails.

Note: All the sidebar views are accessible both from the main View menu
and from the pop-up that appears when you click the View  button on
Preview’s toolbar.

For viewing collections of images in the sidebar, you have two main
options:

Thumbnails: This view, shown in the figure above, shows graphical
previews of your images.

Table of Contents: Choose this view to display a text list of image
filenames (Figure 20).



Figure 20: The sidebar can show either image thumbnails or, in Table of
Contents mode (shown here), the filenames of the images.

Tip: You can drag the sidebar’s divider to the right to see the thumbnails
larger or see more of the sidebar text; dragging the divider to the left makes
more room for the current image.

Regardless of which view you choose, clicking an item in the sidebar
displays the associated image in Preview’s main pane. You can also navigate
through the sidebar’s entries with the ↑ and ↓ keys. You can also move
between images by pressing Space and Shift-Space.

Beware a Table of Contents Bug

We ran across one unexpected behavior (okay, let’s call it a bug) that might
confuse you when you’re using the sidebar. Let’s say you open three images
in Preview and set the sidebar to Table of Contents view. Then you switch
back to Thumbnails view and add another five images by dragging them into
the sidebar from the Finder. If you subsequently switch to Table of Contents
view again, only the original three filenames appear, rather than all eight.

It appears that Preview creates the table of contents when you first choose
that menu item and doesn’t update it even if the contents of the sidebar
change later.



Viewing a Contact Sheet
When you have many images you’d like to compare, you can view their
thumbnails in a single-window grid, just like the photographer’s contact
sheet of old (Figure 21). Choose View > Contact Sheet or press ⌘-Option-
6.

Figure 21: Contact Sheet view displays all the open images in a single
window.

Contact Sheet view is actually the sidebar’s Thumbnails view expanded to
take over Preview’s entire window—if Preview is in Contact Sheet view
and you choose View > Hide Sidebar, Preview focuses on a single image
just as it would if you had the sidebar open and chose View > Hide Sidebar.

Double-click a thumbnail to expand it to fill the entire window. The only
way to return to Contact Sheet view after expanding an image is by
choosing View > Contact Sheet again (or pressing ⌘-Option-6), so if you
use this view often, it’s worth memorizing the keyboard shortcut.

Depending on how many thumbnails you’re viewing, you may want to
adjust their size. With hundreds of images open, you might want the



thumbnails to be smaller, or if you have only a few, larger thumbnails might
be easier to work with.

To change the thumbnail size, choose View > Zoom In to make them larger
or View > Zoom Out to make them smaller. Don’t rely on the menu
commands, though, since there are more efficient ways to zoom in and out.
⌘-= (remember it as ⌘-Plus, but you don’t need the Shift key) and ⌘–
(⌘-Minus) zoom in and out, respectively, as does pinching in and out on a
trackpad.

The keyboard and trackpad shortcuts are absolutely worth using here,
especially since the are nine levels of magnification, so you might want to
press ⌘-= repeatedly to zoom the thumbnails to their maximum size.

Just as in the sidebar when in Thumbnails view, there are oodles of other
things you can do with images in Contact Sheet view, and we discuss those
in Managing Images, later.

Zooming Images
We just talked about zooming in Contact Sheet view, so now let’s focus on
zooming individual images. When you have an image selected, you can
choose View > Zoom In and View > Zoom Out to do exactly what you’d
expect. The ⌘-= and ⌘– keyboard shortcuts work too (we think of them as
⌘-Plus and ⌘-Minus).

Whereas Contact Sheet view offers only 11 zoom levels, 20 zoom levels are
available when you’re viewing images directly, letting you get down to the
point where you can see individual pixels. When you’re zoomed in enough
so the image is larger than the window, horizontal and vertical scroll bars
appear on the bottom and right edges of the window to let you move around
within the zoomed image (Figure 22).



Figure 22: When you’re zoomed in far enough, scroll bars appear to help
you pan around the image.

Note: Alas, Preview doesn’t offer a hand tool for dragging the zoomed image
around within the window, but if you drag out a rectangular selection that
extends beyond the edge of the window, Preview scrolls the window
appropriately.

The View menu offers additional choices for image zooming: Zoom to Fit
(⌘-9), which fills the window with the document or image, and Actual Size
(⌘-0), which does just what it says, regardless of whether the file fits in the
window or not.

Tip: If you have multiple images open, you can select them all in the sidebar
in Thumbnails view, at which point the View menu’s Zoom commands work
on the selected images. So if the images are all of different sizes, you can
choose View > Zoom Selected Images to Fit to make them all expand to the
window size.

For more control over the zoomed area that appears in the window, you can
make a selection (choose Tools > Rectangular Selection and drag out a
rectangle) and then choose View > Zoom to Selection (⌘-*, which may be
better thought of as ⌘-Shift-8). That’s a great way to focus on a particular
area without having to zoom and then scroll to find the portion of the image
you want to work on.



Note: Zoom to Selection will fail if the selected area is smaller than the 20th
zoom level. We noticed this while trying to zoom into a 24-by-24 pixel button
within a screenshot of an entire 27-inch screen.

Focus on Details with the Magnifier

If you’re zooming in to see the details in a photo, consider using the
magnifier tool (Figure 23), which you display by choosing Tools > Show
Magnifier. It’s easier to engage by pressing the Backtick key, just above the
Tab key on Apple keyboards. It turns your pointer into a magnifying glass
inside Preview, providing a loupe to expand a portion of an image. Turn it off
by pressing Backtick again, or Esc.

Figure 23: Use the Magnifier tool to look at the details in an image
without zooming.

Since the Magnifier tool takes over the pointer, you can’t do anything else
that requires making a selection while it’s active.

Viewing in Full-Screen Mode
If you’re zooming your images to fit in the largest possible window, why
not just use full-screen mode? Either click the green zoom  button in the



upper-left corner of the window or choose View > Enter Full Screen.
Preview zooms the image to the largest possible size, with black on the
sides or bottom as necessary (Figure 24).

Figure 24: In full-screen mode, display the menu bar and toolbar by
moving your pointer to the top of the screen.

Tip: Option-click the green zoom  button to expand the window to its
largest appropriate size without going into full-screen mode. This is handy
when you want to be able to resize the window or move it partially off-screen
temporarily.

In full-screen mode, Preview acts a little differently. Here’s what you need
to know:

Accessing the menu bar and toolbar: In full-screen mode, Preview’s
menu bar and toolbar vanish. To reveal them temporarily and access
their commands, move the pointer to the top of the screen.

Accessing the Dock: Move your pointer to the bottom of the screen to
reveal the Dock (or to the side of the screen, if that’s where you’ve
positioned your Dock).

Keeping the toolbar visible: Choose View > Always Show Toolbar.
This can be helpful, for instance, if you plan to edit in full-screen



mode.

Leaving full-screen mode: Click the green zoom  button, choose
View > Exit Full Screen, or press Esc. We always press Esc.

Contact Sheet view: Although it might not seem obvious, View >
Contact Sheet (⌘-Option-6) is available in full-screen mode; it’s a
good way to get an overview of the open images.

Using the sidebar: In full-screen mode, the Hide Sidebar command in
the View menu changes to Always Show Sidebar (it retains the ⌘-
Option-1 keyboard shortcut). Choose it to show or hide the sidebar,
which is handy for navigating among a large number of open images.

When the sidebar is showing in full-screen mode, View > Thumbnails
and View > Table of Contents work, along with their ⌘-Option-2 and
⌘-Option-3 shortcuts.

Navigating between images with the keyboard: The ↓ and → keys
and the Space bar move to the next image. The ↑ and ← keys, along
with Shift-Space move to the previous image. In other words, you can’t
use Up and Down to navigate vertically in the grid of photos unless
you’re in Contact Sheet view.

Playing an Image Slideshow
If you’d like to get a better look at a group of images or share them with
someone else on screen, use Preview to play a slideshow. To do this, open a
bunch of images in the same window and then choose View > Slideshow
(⌘-Shift-F). You can play a slideshow whether or not you’re in full-screen
mode, although it’s not available when you’re in Contact Sheet view.



Preview displays the current image fullscreen and advances to the next
image every 5 seconds. A slideshow toolbar appears near the bottom of the
screen, with controls to move to the next or previous image, play or pause
the slideshow, and exit the slideshow (Figure 25). You can also use the
arrow keys to move between slides; pressing Esc exits.

Figure 25: Use the slideshow toolbar to move to the previous and next
slides, play and pause, and stop the slideshow.

Tip: The slides play in the order they appear in the sidebar’s Thumbnails
view and contact sheet, and you can drag them around to adjust the order.
See Managing Images.

The slideshow toolbar automatically hides itself after a few seconds so it’s
not obscuring your beautiful pictures. To get it back, just wiggle the mouse.

Note: If you start a slideshow while in full-screen mode, pressing Esc not
only ends the slideshow but exits full-screen mode. To stop the slideshow
and remain in full-screen mode, click the close  button on the slideshow
toolbar.

Examining Image Metadata
That’s about it for what you can do in Preview with viewing images, but
what about the metadata surrounding those files? That’s where the Inspector
comes in handy. Choose Tools > Show Inspector (⌘-I) to reveal the
Inspector window. It has four panes for images: General Info, More Info,
Keywords, and Annotations (Figure 26).



Figure 26: The General Info pane (left) may be the most helpful in
everyday use, but More Info (right) has by far the most information.

Let’s look at each of these in turn:

General Info: The first pane in the Inspector, General Info, gives you
useful information like image size, image DPI, and when the file was
created. We use this to look at the image size numbers a lot.

More Info: This pane has (depending on the image) up to five views
for General, Exif, IPTC, JFIF, and TIFF data. As you can see in Figure
26, above, there are oodles of details here; you’ll know if you need
them.

Tip: You can select entire lines in any of the More Info views and copy
them for pasting elsewhere, should you want to give that info to someone
else. ⌘-A even works for selecting all the lines.



Keywords: Here you can add keywords to an image so that it can be
found more easily in Spotlight. Keywords may already be present if
you’ve applied them in an app like Photos. Click the plus  button to
add keywords or the minus  button to remove them. Honestly, it’s a
lot easier to work with keywords in Photos.

Annotations: Use this pane to view and jump to any annotations
you’ve made—both text and any shapes you’ve added. Unfortunately,
the Annotations pane is entirely useless with images because as soon as
you close an image, all its annotations are “flattened” and become just
pixels, so they disappear from this pane. It’s mainly for use with PDFs
(see Annotate PDFs).

Identify Photos with Visual Lookup
If you ever see a sparkle in the Inspector  button, that means Visual
Lookup is available for that photo. Visual Lookup can identify animals , art
, plants , landmarks , and other things:

1. Click the Inspector  button.

2. If it’s an animal, artwork, or plant, the respective icon appears near the
center of the image. Landmarks appear in the lower-right corner.

3. Click the icon to show an info card with information about the
identified subject (Figure 28).



Figure 27: Visual Lookup can identify many common (and uncommon)
plants.

Managing Images
We’ve talked about Preview as an image viewer so far, but that’s a bit like
calling the Finder a file viewer. Preview can do much more with images
than merely display them. When you select one or more images in the
sidebar (or in Contact Sheet view, see Viewing a Contact Sheet), there are
quite a few actions you can take.



Selection Tips

Preview abides by the standard Mac selection rules, so all these techniques
work for selecting multiple thumbnails in the sidebar’s Thumbnails view:

Click one thumbnail and Shift-click another to select all the thumbnails
between them.

Click between thumbnails and drag out a rectangle to select all the
thumbnails inside your selection.

⌘-click individual thumbnails to select a discontiguous set. Also, ⌘-click
a selected thumbnail to deselect it.

After clicking anywhere in the sidebar, choose Edit > Select All or press
⌘-A to select all the thumbnails.

The same techniques work in Contact Sheet view, with the exception of the
first one—Shift-clicking in a contact sheet is identical to ⌘-clicking in that it
creates a discontiguous selection.

Rearranging Images

When you open multiple images from the Finder, Preview tries to arrange
them in the sidebar in accordance with the order in which you selected them
or, if you select them all at once, how they were arranged in the Finder. So,
if you select three images named Alice, Bob, and Christine with a Shift-
click selection when the folder they’re in is sorted by name, they’ll open in
that ABC order. But if their folder is sorted by date such that the order is
Bob, Alice, Christine, their Preview thumbnails appear in BAC order to
match. When opening multiple images from a folder in icon view, where the
order is often arbitrary, Preview defaults to alphabetical order for its
thumbnails.)

The order of thumbnails in the sidebar isn’t fixed, however, and you can
select one or more thumbnails and drag them up or down in the list to
change the arrangement. The same applies to Contact Sheet view (Figure
28).



Figure 28: Drag an image to a new location to rearrange it in Contact
Sheet view.

We can think of two main reasons to rearrange thumbnails. First, if you
want to play a slideshow of all the images in a folder, tweaking the order of
the thumbnails gives you control over which images appear when. Second,
if you want to create a PDF with one page per image (see Printing to PDF),
this is a good way to ensure that they appear in the desired order.



Batch Rename Images for Slideshows

If you’re doing a lot of rearranging for a slideshow, be aware that your
efforts are lost as soon as you close the Preview window that contains the
images. If you want to maintain image order over time, rename the images
in numeric order.

It’s probably best to work on a copy of the images, so create a folder in the
Finder and copy the images into it. Then, follow these steps:

1. Still in the Finder, select all the images and choose File > Rename to
display the Rename Finder Items dialog (Figure 29).

Figure 29: You can batch rename your slideshow images right in the
Finder.

2. Choose Format from the top pop-up menu, and Name and Index from
the Name Format pop-up menu.

3. Set the Where pop-up menu to “before name.” Leave the Custom Format
field blank to use the current names of the files, or enter a new name to
assign it to all of them.

4. Enter 1 in the “Start numbers at” field.

5. Finally, notice how the Example area reflects all your changes. When
you’re ready, click Rename.

The Finder renames all the selected files according to your selections; in this
case, the files would be 1 Slideshow Image.pdf, 2 Slideshow Image.pdf,
and so on.

Breezing Through More Tasks

Preview has numerous other features in its File and Edit menus. Some can
be applied to multiple images simultaneously, whereas others ignore the



sidebar selection and work on just the image that’s showing.

Using the File menu, you can:

Close Selected Images (⌘-Shift-W): Use this command to remove
one or more images from the currently open collection. The images
aren’t deleted in the Finder.

Save (⌘-S): The Save command applies only to the current image,
even if you have multiple images with changes selected in the sidebar.

Duplicate (⌘-Shift-S): Duplicate makes a copy of the selected image
in Preview and opens it in a new window. If you’ve selected more than
one image, only the current one is duplicated.

Save As (⌘-Shift-Option-S): Hold down the Option key and
Duplicate becomes Save As, which lets you save a copy of current
image. Again, it works only on the current image when more than one
are selected.

Rename: Choose this command and Preview lets you edit the name of
the currently selected image in the title bar (Figure 30).

Figure 30: You can rename images right within Preview, which can be
helpful for fixing the inscrutable names of images you’ve downloaded from
the web.

Move To: This command can be helpful if you’re sorting a folder of
images. Imagine that you have a folder of photos, some of which are



originals and some of which are edited in some obvious way and need
to be separated. You can go through them in Preview, and when you
come across an edited photo, choose File > Move To to put it in a
separate folder.

Export and Export Selected Images: When used with a single image,
the Export command lets you change the image format (see Convert
and Export). However, when you have multiple images selected, the
command changes to Export Selected Images and just makes a copy of
each selected image in the destination folder; you don’t get a chance to
specify a new image format.

Export as PDF: This command is disappointing, since it works only
on the currently selected image, turning it into a standalone PDF. If you
want to make a multiple-page PDF of all your open images, print to
PDF instead, discussed two bullets down.

Revert To: Like Save, this works only on the currently showing image,
and lets you revert to an earlier version, getting rid of changes you’ve
made. For details on reverting to the last opened version or browsing
all available versions, see Remember Undo!

Print (⌘-P): You can, of course, just print multiple images as separate
pages, but a more interesting thing to do is to choose Print, and then,
from the PDF pop-up menu (Figure 31), choose Save as PDF to get a
PDF containing all open images. You might want to change the
orientation to landscape if you’re printing photos.



Figure 31: In the Print dialog, choose Save as PDF from the PDF pop-up
menu in the lower-left corner (circled).

Two commands in the Edit menu also prove useful:

Copy (⌘-C): If you select one or more images in Preview and choose
Edit > Copy or press ⌘-C, it copies the image(s) to the clipboard. If
you then choose File > New from Clipboard (⌘-N), Preview creates a
new window, or windows, with untitled versions of each copied image.
It’s a fast way to make a duplicate. Weirdly, in the Mojave and Catalina
versions of Preview, it often seems to create two copies—Untitled and
Untitled 2.

Tip: You can also switch to the Finder and choose Edit > Paste (⌘-V) to
make copies of the images in a particular folder. However, as this often
creates a pair of copies now, a better approach is to drag a thumbnail to
the desktop!



Move Selected Image(s) to Trash (⌘-Delete): We saved what may
be the most useful command for last. Let’s say that you have a folder
containing a slew of images, many of which need to be deleted. Thanks
to this command, you can open all of them at once, switch into full-
screen mode to see them better, and then use the arrow keys to flip
through them, pressing ⌘-Delete whenever you find one you want to
trash.

Note: When there’s only one image open in Preview, this command is
dimmed out.



Edit Images

So far, we’ve walked you through the basics of opening and viewing images
in Preview. Now we dig into Preview’s little-known and surprisingly
powerful editing features. As people who write about technology, we have
some skin in the game. We work with screenshots every day and Preview is
our go-to app for cleaning up and tweaking the images that appear in
TidBITS articles and this book. Sure, we could use something like
GraphicConverter, Pixelmator, or even Adobe Photoshop, but those tools
are often overkill for the graphics tasks that many of us need to perform.

In this chapter, we start by looking at how to select content in an image.
After that, we cover:

Copying, Pasting, and Deleting Image Content

Cropping Images, Resizing Images, and Rotating Images

Inserting and Manipulating Basic Shapes and Using the Mask and
Loupe Shapes

Adding Text to Images

Adjusting Colors

We end with a look at the Undo command and how you can even use it
to open an older version of a file; see Remember Undo!

Selecting Content in Images



Once you understand how to use Preview’s tools, you’ll discover that you
can edit images in ways that are far more subtle than you might think. But
first, you must understand how to select image content.

Preview offers five different selection tools, each of which may be more or
less appropriate depending on what you want to accomplish. You’ll use the
Rectangular Selection tool the most, but the Elliptical Selection Tool, Lasso
Selection Tool, and Smart Lasso Tool also can be helpful on occasion.
Finally, the Instant Alpha Tool is extremely useful for making image
backgrounds transparent.

You find these tools on the Markup toolbar (see Tour the Markup Toolbar).
To access the first four selection tools, click the Selection Tools  icon and
choose from the drop-down menu. (You can access this menu only when
you’re working on an image. When a PDF is open, only the Rectangular
Selection  tool is available.) For Instant Alpha, use the Instant Alpha 
icon (Figure 32).

Figure 32: Access four of Preview’s selection tools by clicking the Selection
Tools icon on the Markup toolbar.



Invert Your Selection

Sometimes you want to select everything in an image except a particular
object. To do that, select the object using whatever tool makes sense, and
then choose Edit > Invert Selection.

If you look closely, you’ll see that Preview draws a selection rectangle around
the entire image and the adjustment handles disappear from the original
selection. Any actions you take on the image (see Copying, Pasting, and
Deleting Image Content) now apply to everything except what you initially
selected.

Rectangular Selection Tool

The Rectangular Selection tool should be selected by default when you’re
viewing images. If not, choose Tools > Rectangular Selection or click the
Selection Tools  icon on the Markup toolbar and then choose Rectangular
Selection.

Using the Rectangular Selection tool is simple: drag within the image to
create a selection box that’s the size of what you want to select. You can
move the box by positioning your pointer inside it so the pointer becomes a
hand. Once it does, drag to position the box as you like.

If the box isn’t quite the right size, drag any blue dot at its edges (Figure
33). (We call these dots “adjustment handles.”) As you tweak, Preview
displays the box’s pixel dimensions in a small label—a handy aid when
you’re trying to create an image with a specific measurement or aspect ratio.
(This label won’t appear for a PDF; instead, choose Tools > Show Inspector,
click the Crop  icon, and look in the Selection area. See Cropping Pages)



Figure 33: To adjust the size of your selection, drag any blue dot at the
edge of the box.

But wait—there’s more! The Rectangular Selection tool offers a couple
more tricks:

Press and hold the Shift key while dragging to restrict the selection to a
perfect square. This is particularly handy when you’re making an
avatar icon for websites that require square dimensions, as shown in
Figure 33, above.

Hold down the Option key while making your selection box to expand
it from the center.

Elliptical Selection Tool

The second choice when you click the Selection Tools  icon on the
Markup toolbar is Elliptical Selection . It works just like the Rectangular
Selection tool, except that it selects elliptical rather than rectangular areas.

Tip: Press Shift while dragging with the Elliptical Selection tool to make a
perfect circle, or press Option while dragging to size your selection in both
dimensions from the center.

After dragging out an elliptical selection, you’ll see blue adjustment handles
at its edges as well as additional handles at each corner of a rectangle
surrounding the selection (Figure 34). The dots attached to the selection



ellipse itself adjust one dimension at a time, whereas those on the corners of
the rectangle enclosing the ellipse can adjust two dimensions at once. In
other words, drag a corner to enlarge the entire ellipse or drag a side to
change the ellipse’s shape.

Figure 34: The Elliptical Selection tool is like the Rectangular Selection
tool, except rounder.

Lasso Selection Tool

The third choice when you click the Selection Tools  icon on the Markup
toolbar is the Lasso Selection . Use this tool to select an irregularly shaped
object or portion of a graphic. With this tool, you can hand-draw a selection
around any object (Figure 35).



Figure 35: The Lasso Selection tool is finicky to use, but it offers an
unmatched level of precision when selecting oddly shaped objects.

Note: Bill Atkinson first invented the Lasso Tool for MacPaint, the bitmap-
based painting software that shipped with the original Apple Macintosh. You
can even give it a try in this web-based version.

The hard part of using this tool is that you have to do it in a single click-
and-drag motion. Since the Lasso Selection has to form a closed shape, if
you don’t close it yourself by ending back at the starting point, the selection
closes itself with a straight line. There’s no way to resize it after the fact
without starting over.

Note: Because the Lasso Selection tool requires such precision and is so
unforgiving of mistakes, we can’t recommend wasting much time on it. Try
the Smart Lasso tool instead.

Smart Lasso Tool

The Lasso Selection tool works best when the irregularly shaped object you
want is well separated from other parts of the image, as might be the case
with a logo you want to extract from a scanned flyer. But in a photograph or

https://en.wikipedia.org/wiki/MacPaint
https://cloudpaint.com/imageeditor


complicated illustration you’re unlikely to be so lucky. For such situations,
use the last option when you click the Selection Tools  icon on the
Markup toolbar—the Smart Lasso  tool. It tries to make up for the plain
old Lasso tool’s deficiencies.

When you drag using Smart Lasso, a thick red line appears instead of a thin
white one. Draw around the object you want to select; as you do, Preview
tries to construct the selection intelligently (Figure 36). As with the Lasso
tool, the Smart Lasso has to make a closed shape, so if you don’t close it
yourself, it does so using a straight line.

Figure 36: The Smart Lasso tool draws with a thick red line and does its
best to guess the margins of what you’re trying to select.

The Smart Lasso acts more like a brush than a selection tool, so if you miss
an area, you can double back immediately. Although the Smart Lasso is
more forgiving than the normal Lasso, you’ll likely need to experiment to
get the results you want.

Instant Alpha Tool



Preview’s final selection tool is a one-trick pony that’s designed to remove a
colored area from an image, replacing it with transparency. That’s essential
when you want irregularly shaped images, such as logos or product photos,
to float above a webpage’s background color or to have an image’s fill color
match the page color.

Warning! Instant Alpha works only with image formats that support
transparency, including PNG, TIFF, and GIF. If you try to use it on an
unsupported file format, such as JPEG, Preview asks if you want to convert
the file to PNG. If you agree, Preview replaces the existing file and you
cannot undo or use the Revert To menu. If that’s undesirable, make a copy
first!

Click the Instant Alpha  tool on the Markup toolbar and then drag slightly
on the colored area you want to delete. Preview selects the area you dragged
over as well as any adjacent pixels that have the same color, highlighting
them all in pink. Without releasing the mouse, you can continue to drag the
pointer to adjust the Instant Alpha tool’s sensitivity to include additional
colors (Figure 37).



Figure 37: The Instant Alpha tool highlights in pink the area it will select.

Once you’re happy with what’s selected, lift your finger from the mouse
button or trackpad to finalize your selection. You’ll see “marching ant”
dashes around the selection. Then press Delete to remove the selected color,
replacing it with transparency (represented by the window background
color, gray by default, which you can customize in Configure Preview
Settings).

The Instant Alpha tool selects only areas that are contiguous. To remove an
image’s entire background, you may need to select more than one section
and delete it in turn (see Figure 38).



Figure 38: If the background areas you want to select with Instant Alpha
aren’t contiguous, you’ll must use the tool a few times.

Although this may seem like a hassle, it’s actually a feature, not a bug. If
Instant Alpha selected all the white pixels in Figure 38 (above), above, at
once, it would also pick up the logo’s center and display text. When you
pressed delete, all of those areas would become transparent, which might
look truly strange on a webpage with a colored background.

Using the Instant Alpha tool on images with solid areas of color is
straightforward. If you’re trying to remove a background that’s not a solid
color, however, you’re in for a little more work. You’ll have to use the
Instant Alpha tool multiple times, clicking in a different color each time and
dragging slightly to tweak the selection’s sensitivity. In Figure 39, we’re on
the third pass with Instant Alpha, with more to come.



Figure 39: To remove a more complex background, you’ll need to use the
Instant Alpha tool multiple times.

If Instant Alpha can’t select the background color without also selecting
some of what you want to keep, try zooming in so you can select carefully.
Remember that you can always fall back on Preview’s other selection tools
for the final cleanup.

Tip: When you’re trying to remove the last bits of background for an image
that doesn’t have solid colors or straight edges, try the Elliptical Selection
tool. Make an elliptical selection and then drag it so it covers some part of
the background you want to delete. Press the Delete key, reposition the
selection, and repeat as necessary.

Selecting Text in Pictures

macOS 12 introduced Live Text, which lets you select text in photos just as
you would any other text. When you move the mouse pointer over
recognized text, it switches from the regular selection crosshair to a text-



selection pointer. It’s especially handy for digitizing text from books and
recipe cards.

It’s a simple but game-changing feature. However, sometimes it makes it
difficult to actually selection parts of an image. To turn it off, go to System
Settings > General > Language and Region (Ventura or later) or System
Preferences > Language & Region (Monterey or earlier) and disable Live
Text.

Copying, Pasting, and Deleting Image
Content
Once you’ve isolated the part of the image you want, you have a few
options for working with your selection:

Move the selection: Is your selection the right size but slightly out of
place? If you used the Rectangular Selection tool, Elliptical Selection
tool, or Lasso tool, you can reposition your selection—not the
underlying image itself, but the dashed line that indicates what part you
want—with the pointer or the arrow keys.

Note: Oddly, you cannot use your pointer to drag a selection made with
the Smart Lasso tool, but you can move it using the arrow keys.

Copy the selection for later pasting: Once you’ve selected what you
want, press ⌘-C to copy it. Press ⌘-V to paste it into a different
image, a different document, or just a different position in the same
image. Once you have a copy in Preview, you can move and resize it
(by dragging the blue adjustment handles), although it is always
essentially rectangular in Preview’s eyes, no matter how irregular it
was to start.



Note: You can also choose File > New from Clipboard to create a new file
with the copied selection. See Importing from the Clipboard.

Delete the selection: Once you’ve made your selection, press Delete to
remove that part of the image, leaving a transparent hole indicated by
the background color. This is most helpful when you’re trying to turn
portions of an image transparent. If the image isn’t in PNG format, you
will be prompted to convert the image to PNG since it supports
transparency.

Tip: If seeing the background color for transparent parts of the image isn’t
helpful, choose View > Show Image Background to replace the background
color with a gray-and-white checkerboard pattern.

Cropping Images
When you’re working with images, cropping is a necessary and frequently
used feature. Use cropping to focus the eye on what’s important by
removing distracting objects near the edge of the frame. For example, we
did a lot of cropping for the screenshots in this book to home in on a
particular window or button.

For basic cropping, use the Rectangular Selection tool to select the content
that you want to keep. In Figure 40, for example, there is too much blue
background, so we are tightening the focus to just the two windows and a
small amount of the surroundings.



Figure 40: To crop an image, first select the content you want to keep.

With your selection is in place, choose Tools > Crop or press ⌘-K to delete
everything that’s not selected (Figure 41).

Figure 41: When you invoke the Crop command, Preview deletes
everything that isn’t selected.

The basics of cropping are easy to pick up, but here’s a technique that
simplifies creating precise selections around windows, dialogs, and other
objects:

1. Don’t try to make a perfect selection on the first go around. Instead, if
the object you want to keep is fairly small, drag out a rough selection
around it that includes some of the background, and then press ⌘-K to
make an initial crop. Alternatively, if the desired object already makes



up most of the image, choose Edit > Select All or press ⌘-A to make a
selection rectangle around the entire image.

2. Next, use the blue adjustment handle in the middle of each side of the
selection rectangle to adjust each side. This is more precise than
dragging the corner handles, as those resize the selection in two
dimensions at once, and it can be hard to get both sides exactly right at
the same time.

Tip: If you’re cropping a very small object, like the buttons we use as
inline graphics in this book, zoom in closely before you adjust the
selection. For instructions, refer back to Zooming Images.

3. Once you’ve selected what you want, you’re ready to crop; however if
you made a rectangular selection, consider copying instead. When you
choose File > New from Clipboard, Preview creates a new document
containing the copied data. This is a quick way to create a file
containing your desired content and might be more appropriate in
certain workflows. See Importing from the Clipboard.

Resizing Images
You’ve cropped out the parts of the image you don’t need, but it’s still too
large, either in terms of dimensions or file size? No problem. Preview
makes it easy to shrink the image.

Choose Tools > Adjust Size and a handy dialog appears (Figure 42). Play
with the settings and either click OK to apply your changes or Cancel to
back out.



Figure 42: The Adjust Size dialog gives you all the controls and feedback
you need to make your image the perfect size.

Here’s a quick overview of what each of the controls does:

Fit Into: This pop-up menu gives you a set of predefined sizes. If your
image doesn’t match the aspect ratio of the pre-defined size you
choose, Preview fits the longer side of your image to the appropriate
dimension, adjusting the shorter side proportionally. So a portrait
image will always be fit to the height of the pre-defined size, and
landscape images will be fit to the width. When you adjust the width
and height yourself, this menu sets itself to Custom; you don’t need to
choose that manually. Frankly, this menu is a confusing waste of time;
just set the dimensions yourself in the fields below.

Width and Height: In these fields, you can set the width and height of
the image manually. Use the pop-up menu on the right to set the unit of
measurement to pixels, percent, inches, centimeters, millimeters, or
points. Which unit you choose depends mostly on how you think about



your output. For example, if you’re planning to use the image on a
website, pixels makes the most sense. If the image is destined for print,
a real-world measurement like inches, centimeters, or millimeters may
be more helpful. If the actual size doesn’t matter, choose Percent in this
menu.

Tip: You can always scale images down, but you don’t want to scale
images up. Unlike what you may see on TV shows, scaling an image up
almost never works well, because Preview has to generate pixels out of
thin air, and the resulting image is always blurry.

Resolution: Here you can adjust the resolution of the image, in either
pixels per inch or pixels per centimeter. Resolution is a tricky topic, but
in short, for images destined for the screen, it’s usually irrelevant and
can be ignored. For screen display, all you care about is how many
pixels the image has—whether it’s 72 ppi or 144 ppi should make no
difference in how it looks on screen. Don’t assume that reducing the
resolution will make the file size smaller either; it will if you select
Resample Image because you’re throwing away pixels, but if you don’t
resample the image, the file size stays roughly the same and may even
increase somewhat for JPEGs.

For images you want to print, resolution is important. If you have a 72
ppi image, it needs a lot more pixels to print at a decent size on paper
than if it’s a 300 ppi image. But you can’t change the resolution to get
better results because any change in resolution must either throw pixels
away or add pixels in, neither of which is good for image quality. In
short, unless you know what you’re doing, leave the resolution setting
alone.

Tip: For a good discussion of the ins and outs of resolution, see the
Photoshop Essentials site’s explanation.

https://www.photoshopessentials.com/essentials/image-resolution/


Scale Proportionally: In nearly all cases, leave Scale Proportionally
selected, because otherwise your image will be stretched or squished in
the dimensions that change. The only time it’s worth deselecting Scale
Proportionally is when you need dimensions that are just slightly
different from what you have, when the stretching or squishing won’t
be noticeable.

Resample Image: As noted above, resampling changes the number of
pixels in the image. Thus, you should leave this checkbox selected in
most situations, particularly when the image is destined to be displayed
on a screen and you want to control the pixel dimensions. In fact, if
you deselect Resample Image, you can no longer choose Pixels in the
pop-up menu next to Width and Height, Scale Proportionally is locked
on (since disproportionate scaling would change the number of pixels),
and any changes you make in Width and Height also change
Resolution. All you can do then is change how large the image prints.
Again, Photoshop Essentials has a nice explanation.

Resulting Size: This feedback area is useful to watch, particularly if
you’re trying to reduce the file size of your image. As you adjust the
image’s pixel dimensions, it tells you the resulting percentage size of
the original image, the resulting file size, and the previous file size.
Changing resolution while resampling doesn’t affect size much, and
Preview doesn’t report on such changes.

Tip: You can resize a number of images at once by selecting them in the
sidebar before choosing Tools > Adjust Size.

https://www.photoshopessentials.com/essentials/resizing-vs-resampling/


Resizing the Image Canvas

Unlike many graphics apps, Preview has no way of resizing the canvas on
which the image sits, which you might want to do if you want to combine
multiple images or add borders or have callouts that extend past the edge of
the image. However, there is a workaround:

1. Select the entire image with Edit > Select All.

2. Cut the image out with Edit > Cut. This leaves an empty canvas the size
of the image. (You may be prompted to convert the file to PNG; that’s
fine, and you can save it back to JPEG at the end if you want.)

3. Resize the canvas with Tools > Adjust Size (unlock the proportions if you
want). If you don’t know how large to make it, err on the high side since
you can always crop it back down later.

4. Paste the image back onto the resized canvas with Edit > Paste.

5. Add other images or callouts or whatever else as you want.

6. Crop the resulting image to remove extra space around the edges.

That’s it! It’s not as simple as just resizing the canvas in other apps, but
achieves the desired results.

Rotating Images
Every now and then, you end up with an image that’s upside down or
generally not rotated the way you want. Happily, Preview makes it easy to
make a change: choose either Tools > Rotate Left (⌘-L) or Tools > Rotate
Right (⌘-R). You can also click the Rotate  button on the main toolbar to
rotate the image to the left or Option-click it to rotate the image to the right.

You also might find use for the next two in the Tools menu: Flip Horizontal
and Flip Vertical. These tools rotate the image too, but around a horizontal
or vertical center line. For example, Flip Horizontal can be helpful if you
need a person’s headshot to face a different direction. Flip Vertical is useful
when you need to flip a photo upside-down.



Inserting and Manipulating Basic
Shapes
Whether you want to call out a particular interface element in a screenshot
with a big red arrow or add a speech balloon to a picture of your cat,
Preview lets you add shapes to your images without ever opening a
dedicated image-editing app.

Shapes include a line, a line with an arrow on one or both ends, a rectangle
with sharp or rounded corners, an ellipse, a speech balloon, a star, and a
polygon. There are also two special shapes—a mask and a loupe—that we
explain in Using the Mask and Loupe Shapes.

Working with Shapes

You can access Preview’s basic shapes under Tools > Annotate, and it’s
worth noting the keyboard shortcuts there. However, it’s usually faster to
use the Shapes  icon on the Markup toolbar (Figure 43).

Figure 43: The Markup toolbar offers easy access to all the shape tools via
a popover.

To insert a new shape in your document, click the Shapes  icon on the
Markup toolbar and then either click a shape or drag the one you want into
place.



The shape is surrounded by blue adjustment handles (Figure 44); drag a
handle to adjust the shape’s dimensions in that direction. Press Shift to
maintain the shape’s aspect ratio, for example keeping a circle a circle
instead of stretching it into an oval. Press Option while dragging a handle to
resize the shape from the center—a handy trick when the shape is already
centered over the spot you want to encompass. When you resize lines or
arrows, pressing the Shift key constrains the line to a 45-degree angle.

Figure 44: Use the shape’s blue handles to change its size.

As with selections, holding down the Shift or Option key changes how
Preview resizes the shape:

Press Option while resizing an object by any selection handle, and it
resizes from the center.

Shift-click a resize handle on a selected object to equalize its height
and width. In particular:



Shift-click the midpoint resize handle on the top or bottom of the
shape to make all sides equal to the current height.

Shift-click a midpoint side handle to make all sides equal to the
current width.

Shift-click a corner handle to make equilateral sides that are the
average of the length and width measurements.

You can, of course, move the shape, by placing your pointer on it anywhere
other than on a handle. When your pointer becomes a hand, drag to move
the shape. Or just click once to select the shape and then use the arrow keys
to nudge it more precisely.

When you’re moving shapes, note that Preview shows a yellow guide when
the center of the object you’re moving is aligned—horizontally or vertically
—with the center of another object. Unfortunately, this guide only helps you
align objects by their centers, not other edges.

Tip: You can select all shapes in a PDF (⌘-A) if you select one shape first.

You may at some point find yourself with multiple overlapping objects in an
image. Every object lives on its own layer, and each new object appears on
top of all the previous ones. To change that order, Control-click an object
and choose from the pop-up menu that appears. Bring to Front and Send To
Back put on object on the top or bottom of the pile, respectively, whereas
Bring Forward and Send Backward move the selected object by one level in
the layer pile.

Tip: If you need two or more shapes of the same type, create one and then
copy and paste. Or, simply hold down Option and drag the shape, as if to
move it, to create an exact duplicate.



The line, polygon, and star shapes offer additional possibilities:

Lines: When first inserted, lines are straight, but a green adjustment
handle in the middle of the line lets you make it into a smoothly curved
line.

Polygons: By default, inserting a polygon adds a hexagon to your
document. But if you select it and look closely, you’ll see a green
adjustment handle. Move that handle counter-clockwise to remove
sides, down to three (a triangle), or clockwise to add sides, up to twelve
(a dodecahedron).

Stars: The star shape works similarly to the polygon, except it has two
green handles, one that adds or remove points and another that changes
the length of the points (Figure 45).

Figure 45: The star has eight blue adjustment handles, but if you look
carefully you’ll also notice the two green handles. These green handles let
you adjust the number and length of the points.

Tip: When you’re working with a polygon or star, you don’t need to press the
Shift key to maintain its aspect ratio. In this case, that’s default. Pressing the
Shift key lets you change the horizontal and vertical dimensions
independently.



Tip: It’s possible to rotate a shape, too, but only if you have a trackpad.
Select the shape, put your thumb and forefinger on the trackpad, and twist.
Make sure you select a shape first, because otherwise Preview rotates the
entire image (in 90-degree increments).

Creative Ways to Use Shapes

If you’re wondering when you’d ever use shapes with your images, here are
some ideas to get you started:

When you’re having technical difficulties, take a screenshot (see
Taking Screenshots) and then use the Shapes tools to point out the
problem. Send this to tech support or a helpful friend.

We often use shapes (typically a red oval or rectangle with no fill) to
draw attention to interface elements in screenshots.

Use Preview’s speech bubbles to put words in the mouth of your cat or
infant before sharing the photos with family and friends.

You can also use shapes to mark up PDF documents. See Adding
Shapes and Text to a PDF.

Customizing Shapes

With Preview, you can do more than change a shape’s dimensions. Let’s
look next at changing the style of a shape’s exterior line, which is called the
stroke, as well as the shape’s interior color, which is called the fill. These
options appear on the Markup toolbar (View > Show Markup toolbar).

Here’s what you can change:

Stroke style: Click the Shape Style  icon to adjust the stroke of the
selected shape. Interesting options include a dashed or rough stroke, as



well as a drop shadow. If your shape is a line or an arrow, you can also
choose where to place arrowheads (Figure 46).

Figure 46: To customize the shape’s look, adjust its style.

Stroke color: Click the Border Color  icon and pick a color.

Fill color: Click the Fill Color  icon and select a color (Figure 47).
By default, it’s set to “no fill,” signified by a red line across a white
square.



Figure 47: You can adjust the color of the shape’s fill. Here the stroke is
red and the fill is a very light, somewhat transparent green, achieved by
reducing the Opacity slider in the Colors palette.

Redacting Text in an Image

Preview has no built in way of redacting text in an image, so if you’re taking
a screenshot that includes personal information you’d like to obscure, you
can draw a shape over it. We particularly like using a line or rectangle with
the rough stroke option—with the rectangle, just make sure you’ve set the
stroke color and fill color to be the same. And if you have to redact a number
of bits of information, make one redaction line or rectangle and then Option-
drag it to make copies to cover other bits. For info on redacting text in PDFs,
see Redacting Text.

Tip: You aren’t limited to the colors represented by the squares in Preview’s
color picker. Click Show Colors to bring up the Mac’s standard Colors palette,
where you can select any color you want, and even adjust opacity.

Creating Your Own Shapes with Sketch and
Draw

If you’d rather draw shapes yourself, Preview lets you do that, too. On the
Markup toolbar, click the Sketch  icon. Your pointer turns into a pen. Drag
to draw the desired shape.



What Preview does next depends on what you draw. If Preview thinks you
are trying to draw a square, for instance, it automatically changes your
drawing to be a proper square shape. Likewise with triangles, ovals, lines,
arrows, and other shapes. Usually, if you draw an unidentifiable squiggle,
Preview leaves the squiggle as is, but sometimes it tries to replace it with a
smoothly drawn line.

Thankfully, if you don’t care for Preview’s interpretations, or if Preview
couldn’t see that you meant to draw a speech bubble, you have a chance to
correct it. After drawing a shape, look closely at the upper-left corner of the
window, where a small popover appears with your original and a choice of
possible replacement shapes (Figure 48). Click the shape you want, but be
aware that you get only one shot, since the popover vanishes forever after
you choose, or if you deselect the shape.

Figure 48: Outlining this head of broccoli, Preview’s popover (outlined in
red here) suggested two alternative shapes, but we’ll stick with our
squiggly circle to highlight the broccoli.



The Draw  tool, which appears only if your Mac has a Force Touch
trackpad, works similarly, with two main differences. First, Preview doesn’t
attempt to guess that you’re trying to draw a shape—what you draw is what
you get. Second, if you press more firmly on the trackpad while drawing,
you get a thicker line; let up somewhat and the line gets thinner (Figure 49).
We find it hard to control, but perhaps our fingers aren’t educated enough.

Figure 49: With the Draw tool, the amount of pressure you apply to the
Force Touch trackpad determines how thick the line is.

Note: If you have a rubber-tipped stylus designed for use on any iOS device
screen (not an Apple Pencil), you can use it on a trackpad with Preview’s
Sketch and Draw tools.

Using the Mask and Loupe Shapes
You’ll notice two more options when you click the Shapes  icon on the
Markup toolbar, Mask and Loupe. These offer an alternative way to call
things out in your images:

Mask shape: The Mask shape is a sort of a reverse shape. Click the
Shapes  icon and then click the Mask  icon. A rectangle appears on
your image. Inside of it, the image remains the same, while everything
outside darkens (Figure 50). You can use only a single mask on an
image.



Figure 50: Mask highlights a rectangular area while darkening the
surrounding area.

The blue adjustment handles work as you’d expect to change the
rectangle’s size. To position the rectangle over the portion of the image
you want to highlight, you must, click outside the rectangle to select it,
not inside, and then drag it into place with your pointer outside the
rectangle.

Loupe shape: Use the Loupe shape to magnify small details in your
image—you can insert multiple loupes. Be aware that this tool also
distorts the image, which can be confusing to the viewer. To use it,
click the Shapes  icon and then click the Loupe  icon. A circle, or
loupe, appears on your image. You change the size of the loupe using
the blue adjustment handle and adjust the zoom level with the green
adjustment handle (Figure 51). You can also change the stroke style
and color using those menus on the Markup toolbar.



Figure 51: Loupe is handy for magnifying and calling out small screen
elements, as we are doing here to a screenshot of a toolbar containing an
Apple TV icon.

Adding Text to Images
Shapes are great, but what about when you want to add text to an image?
Preview gives you a rich set of options for doing so, in the form of text
boxes and speech bubbles—or you can just add text to any shape:

Add a text box: The main way to insert text is to choose Tools >
Annotate > Text or click the Text  icon on the Markup toolbar.
Preview inserts a text box, with “Text” as a placeholder that disappears
when you start typing.

Move a text box: Try these techniques to move the text box easily.
First, click anywhere else to deselect the text box, hover over the
deselected text box until you see the hand pointer, and drag the box
with the hand. Alternatively, if the text box is already selected, hover
over the outlined edge to get the hand pointer and then drag.

Style text in a text box: To change the text’s typeface, point size,
color, style, or alignment, select the text box and click the Text Style 



icon on the Markup toolbar. Then use the controls in the popover that
appears (Figure 52).

Figure 52: You can adjust the text style, along with the text box’s border
and fill.

Tip: You can’t style individual words or characters in the text box
separately, but you can create multiple text boxes, each with its own
unique style.

Customize the color and more: Just as with regular shapes, you can
click the Shape Style  icon to change the selected text box border’s
stroke thickness and style. The Border Color  icon lets you add a
border to the text box and give it a color. The Fill Color  icon adds a
background color to the text box, as has been done with the orange box
in Figure 52, above.

Add speech bubbles: Speech bubbles are great for adding funny
comments to photos. Insert one by choosing Tools > Annotate >
Speech Bubble or click the Speech Bubble  icon in the Shapes 
icon’s popover (Figure 53). Speech bubbles work just like regular
shapes, with the addition of two green adjustment handles for
controlling the tip and base of the arrow.



Figure 53: Speech bubbles are fun, but not exactly professional.

Add text to shapes: It’s a cinch to add text to your speech bubble—
just select it and begin typing. The surprise is that you can use this
same technique for any shape other than the Mask and Loupe. In most
cases, the text shows up inside the shape. If you select a line or arrow,
however, the text appears off to one end (Figure 54).

Figure 54: To add text to any shape, select it and start typing. For lines
and arrows, the text displays at the end of the shape.

Adjusting Colors



Preview includes some surprisingly robust image adjustment tools. The
options under Tools > Adjust Color are essentially identical to those that
first appeared in iPhoto many years ago. We’ll go through the Adjust Color
window in parts.

At the top of the Adjust Color window is a histogram with three drag
handles with which you can adjust the image’s black point, midpoint, and
white point (Figure 55). Click the Auto Levels button to make Preview
reset the black and white points automatically, which usually improves the
image a bit. Then play with each of the sliders to get a feel for how they
lighten or darken the image. If you don’t like how things turn out, you can
reset all of your changes with the Reset All button at the bottom of the
window.

Figure 55: The histogram at the top of the Adjust Color window lets you
tweak an image’s black point (left), midpoint (middle), and white point
(right) by adjusting the appropriate drag handle.



In Case the Point Isn’t Black and White

Confused by the histogram? It’s a bar chart with each value on the horizontal
axis representing a brightness value (say 0 equals black, and 100 equals
white) and the height of each bar representing the proportionate distribution
of pixels with that brightness value. Preview’s Levels histogram contains
three separate graphs, one each for red, blue, and green pixels. We think of
them as mountain ranges.

If a picture has a lot of blue in it, the blue mountain range will probably be
large, and will likely be on the right side (since it’s the brightest color). The
red and green mountain ranges may also be large, but will likely be farther
to the left, since they’re being used combinatorially to provide the exact
shade of blue that you see.

When you move the black point handle a bit to the right, changing its value
from 0 to 10, for instance, that sets all pixels with values in that range to 0
and makes the image darker. Conversely, if you move the white point handle
to the left, from 100 down to 90, the pixels in that range are all mapped to
100, making the image lighter. In essence, you’re redefining what counts as
black and white.

The midpoint is defined as a point that’s exactly in the middle of the black
point and white point, or 50. Thus, the shadows in an image fill the values
from 0 to 50 and the highlights from 50 to 100. Dragging the midpoint
handle to the left makes the image lighter, because it defines a darker level
as the midpoint, compressing the shadows into a smaller range and
expanding the range of the highlights. Similarly, dragging the midpoint
handle to the right makes the image darker by defining a lighter level as the
midpoint.

For most people, clicking Auto Levels is all that’s necessary, but remember
that you can tweak the lightness of your image by adjusting the black point,
midpoint, and white point manually too.

The rest of the sliders in the Adjust Color window are labeled. We
recommend experimentation to see how each affects a given image.
Remember, you can undo your adjustments at any time with the Reset All
button.



The first four sliders are for manipulating lighting-related adjustments
(Figure 56):

Exposure: If a photograph is too dark or too light due to being under-
exposed or over-exposed, this slider lets you fix that. It’s mostly
helpful when you need to brighten photos that were dimly lit.

Figure 56: With the Exposure, Contrast, Highlights, and Shadows sliders,
you can change lighting, contrast, and increase detail in light and dark
areas.

Contrast: This slider lets you control the difference between the
lightest and darkest areas in a photo. It’s seldom worth messing with
much, though increasing contrast a little bit can make an image look
crisper and more detailed.

Highlights: This slider reveals detail in the brightest points of a
photograph, which can be useful for making clouds more visible, for
instance.

Shadows: The Shadows slider throws light on the darker parts of a
photo, revealing detail that was previously hard to see. Since you’re
most likely to use it on a dark photo, it probably lightens the entire
photo as well.

The next four sliders give you control over color (Figure 57):

Saturation: Use this slider to adjust how saturated, or intense, the
colors are. Moving the Saturation slider all the way to the left makes
the image grayscale, which can be a useful effect, while sliding it to the



right makes colors practically explode off the screen. If an image
seems a little dull, try increasing saturation just a bit.

Figure 57: Saturation lets you control color intensity, Temperature and
Tint increase or decrease the amount of specific colors, and Sepia provides
a retro look.

Temperature: With this slider, you can make the image cooler (more
blue) or warmer (more yellow). If the photo was taken in unkind,
greenish fluorescent lighting, the Temperature slider might improve the
color a bit.

Tint: While the Temperature slider lets you make an image more blue
or more yellow, the Tint slider does the same with green and red. To
make the Temperature and Tint sliders easier to use, Apple provides a
dropper  tool; select it and then click a part of the image that should
be a neutral gray or white. That sets both sliders automatically. Click
the dropper in a few different spots to see how they differ in color. The
best way to evaluate how well it has worked is to look at skin tones and
make sure they look the way you expect.

Sepia: This slider is a one-trick pony; it reduces the saturation of the
photo using sepia tones instead of grayscale. Crank it all the way up to
give your image an “old-timey” feel.

Lastly, the Sharpness slider sits off by itself, and a Reset All button
completes the contents of the Adjust Color window (Figure 58):

Sharpness: This slider can make your image blurrier or sharper.
Blurrier might be helpful with an almost abstract sunset, but mostly



you’ll want to sharpen photos to bring out more detail. Be careful not
to go too far, though, since excessive sharpness can make the image
look grainy.

Figure 58: The Sharpness slider is extremely useful for bringing out more
detail in images, and if you go too far in your edits, Reset All takes you
back to the original settings.

Reset All: There’s no harm in experimenting wildly with all these
sliders, and you can use ⌘-Z to undo multiple changes. But if you’ve
made many edits that have taken the image down a path you don’t like,
click Reset All to return it to its original look.

To give a visual example of what these controls can do for you, here’s a
photo of Cornell University’s Dragon Day. Unfortunately, because it was an
overcast day, it looks less like a celebration and more like a funeral
procession (Figure 59). Let’s see if we can brighten things up.

Figure 59: Because of cloud cover, this celebration looks a bit drab. Note
how all the sliders in the Adjust Color window are set to their default
positions.



Here’s how we tweaked this photo to make it brighter and clearer (Figure
60):

1. Since the original was so dark and muddy, we boosted the Shadows
slider first, which had the effect of bringing out detail in the dark areas
and lightening the image overall. We could have done this with the
Exposure slider too, but that would have blown out the sky.

Figure 60: By using Preview’s color and lighting controls, we were able to
improve this photo significantly. Note how we’ve moved the Adjust Color
window’s sliders from their default positions.

2. Noticing that there wasn’t much going on at the left side of the
histogram, we moved the black point slider in a bit, which made some
fuzzy gray bits darker and more clearly defined.

3. To bring out the detail in the clouds and the bright spots of the dragon’s
iridescent scales, we bumped the Highlights slider up a bit.

4. Next, in order to boost the color of the dragon, we increased the
Saturation slider a little.

5. Rather than mess with Temperature and Tint manually, we selected the
dropper tool and clicked on a white spot in the sky to warm up the



image a bit with more yellow and red. You can see how the
Temperature and Tint sliders moved right to reflect that change.

6. Finally, since most of the individual objects in the photo are quite
small, we maxed out the Sharpness slider to make them pop. The
human eye prefers sharp edges to smooth tones, so increasing
sharpness often makes an image more pleasing, if less technically
accurate.

The end result is a brighter, clearer photo. Now there’s a celebration!

Tip: You can work in a Time Machine-like view to see your original photo
while you adjust the colors in the current version; for the scoop on this
wacky but helpful technique, read the sidebar While Browsing All Versions,
later in this chapter.

Color Profiles

Preview supports color profiles, which define how different displays or
printers can output color. In View > Soft Proof with Profile, you can choose a
color profile with which to preview the image. If you want to assign a
particular profile, choose Tools > Assign Profile and pick a profile from the
pop-up menu in the dialog that appears.

These features could be useful for graphics professionals who care deeply
about color reproduction or are caught on the road without pro tools. In
most cases, however, we suspect that pros are using different apps with
significantly more powerful color tools.

Remember Undo!
The safest approach when editing an image is to make a copy before
modifying it, but it’s easy to forget to do that. Should you find yourself with
a badly edited image, you have two ways to undo the unwanted changes.



The first is the hoary Edit > Undo (⌘-Z) command, which lets you undo
recent actions. Remember that anything you undo, you can redo with Edit >
Redo (⌘-Shift-Z).

But if you’ve already saved and closed a file, and later reopened it, you
can’t use the Undo command anymore. Thankfully, you can still revert to an
older version, thanks to Preview’s support for the Modern Document Model
(see the TidBITS article The Very Model of a Modern Mountain Lion
Document for a thorough explanation). Choose File > Revert To, where you
see one to three options depending on the state of the document:

Last Saved: This option appears only if you have made changes, saved
them, and then made more. Use it to revert to the last saved version,
but not all the way back to when you opened the image.

Last Opened: Use this option to get rid of all changes made to the file
since you last opened it.

Browse All Versions: Choosing this option displays a Time Machine-
like interface, with the current version of the document on the left and
previous versions on the right (Figure 61).

Figure 61: Even if you’ve saved unwanted changes to a file in Preview,
you can revert to an older version with Browse All Versions.

https://tidbits.com/2012/08/07/the-very-model-of-a-modern-mountain-lion-document/


Use the arrow buttons or the horizontal lines at the right side of the
screen to move between versions. Click Restore to restore the file to
the version showing on the right, or click Done to cancel (you can also
click either image’s red close  button or press ⌘-W; alas, pressing
Esc doesn’t work).

To recover a previous version without overwriting the changes you’ve
made, press Option to transform the Restore button into Restore a
Copy. Clicking it opens a copy of the selected version in Preview as an
untitled document.

Tip: The size of the current document’s window before you choose File >
Revert To > Browse All Versions controls the size of both windows in the
Time Machine-like interface. For larger images, we’ve found that it’s handy
to increase the size of the current document window first so it’s easier to see
and compare details in the two windows (this doesn’t work with images that
are inherently tiny, like a screenshot of a button).



While Browsing All Versions

We’ve discovered that nearly all of Preview’s capabilities remain available
while you’re using the Time Machine-like interface for browsing versions of a
document, though its editing tools work only on the current document on the
left.

For instance, you might want to:

Display the menu bar: Move your pointer to the top of the screen to
display Preview’s menu bar, just like in full-screen mode.

Select either image: To manipulate one of the two images, click it to
select it. If the image is larger than its window, it may zoom
automatically; if that happens, click outside the images to return them to
the same size.

Zoom: Use the ⌘-= and ⌘– keyboard shortcuts (we think of them as
⌘-Plus and ⌘-Minus) to zoom in and out of whichever window is
selected, which is handy for comparing details.

Compare to an original while editing: It can be hard to know
whether edits made using Adjust Color are better or worse, but with
Browse All Versions, you can see the original while editing. Enter the
Time Machine-like interface, navigate back to the original image on the
right side, click the left image to select it, and then choose Tools >
Adjust Color. Tweak the sliders while seeing how the new version
compares with the original.

This Time Machine-like view is most practical when working on large
monitors, but keep it in mind whenever you need to compare old and new
versions of an image.

Use Preview Editing Tools Outside
Preview
You can access the Mac’s Markup annotation tools in the Finder’s Preview
pane, in Quick Look previews, by Control-clicking an image and choosing
Quick Actions > Markup from the pop-up menu (Figure 62), and by
double-clicking a newly taken screenshot’s floating thumbnail.



Figure 62: There are a number of ways to access the macOS Markup tools
in the Finder, including in the Preview pane (boxed) and from contextual
menus (see arrow).

Markup is also available in Photos and some apps, like TextEdit, by
hovering over the upper-right corner of an image and clicking the
downward-pointing arrow and selecting Markup from the pop-up menu that
appears.

Markup tools bear an uncanny resemblance to Preview’s editing tools and in
fact, they behave nearly identically. For a complete rundown, see Sharon
Zardetto’s TidBITS article macOS Hidden Treasures: The Mac’s Hidden
Markup Tools.

https://tidbits.com/2018/11/19/macos-hidden-treasures-the-macs-hidden-markup-tools/


Use an iPhone or iPad to Mark Up Images and PDFs on Your
Mac

macOS offers two ways to use an iPhone or iPad to mark up documents on
your Mac:

Markup: While in Markup, click the iPhone  or iPad  icon to mark up
that file on an iPhone or iPad. The image or PDF appears instantly on
your device, and you can use the onscreen markup tools to edit the file—
changes appear instantly on your Mac in the Quick Look window.

Sidecar: If you have a compatible iPad, you can use the Sidecar feature
to mark up images or PDFs in Preview on your Mac, either with your
finger or an Apple Pencil. In short, open an image or PDF in Preview,
move that window to the iPad, select an editing tool and then modify the
document.

https://support.apple.com/en-us/HT210380#systemrequirements


Convert and Export

Preview can not only display a variety of image formats, but also convert
from one to another. As we explain in Choosing a File Format, each format
has its own advantages and disadvantages—for instance, JPEG is the right
choice for photos because it produces nice photos at reasonable file sizes,
while PNG is superior for simpler, on-screen graphics because it handles
solid colors well.

When Should You Convert an Image’s File Format?

Some image formats incorporate lossy compression, so converting from one
to another can reduce image quality. Why would you convert formats? Here
are a few good reasons:

You need to open an image in a particular app, but that app doesn’t
support the image’s current format.

You need part of the image to be transparent and the current format
doesn’t support it.

The original image is in a format unfriendly to web browsers, like TIFF,
and you need to use it on the web.

The image isn’t in the ideal format, like a largely photographic image in
PNG that’s much larger than it would be in JPEG.

Exporting to Other File Formats
A few commands in Preview’s File menu help you export your files to
different file formats:

Export: With this command, you can save a copy of your file with a
different name, in a different location, and in a different format,



including HEIC, JPEG, JPEG-2000, OpenEXR, PDF, PNG, and TIFF.
What you see in the bottom portion of the Export dialog depends on
what you’ve chosen in the Format pop-up menu—press Option while
you open the Format pop-up menu to see an extended set of choices.
We’ll cover all the export options in Choosing a File Format, Changing
PDF Color, and Restricting PDFs.

Export Selected Images: If you select multiple files in the sidebar
before looking in the File menu, you’ll see that Export changes to
Export Selected Images.

Tip: When exporting selected images, if you click the Options button in the
Save dialog, you can change the export format. In essence, then, Export
Selected Images is useful for batch conversion of images from one format
to another.

Export as PDF: As you’d expect, this command is a quick way to
export a file as a PDF, but the Export as PDF dialog lacks the Quartz
filter options that the regular Export command has (see Changing PDF
Color), as well as all other options available with the File > Print
command.

Print: When you choose File > Print, you can “print” to PDF using the
PDF pop-up menu at the bottom-left corner of the dialog. We talk
about this in detail in Printing to PDF. For now, just know that using
the Print dialog to export a PDF offers some advantages, such as
additional encryption options and better embedding of annotations.

Choosing a File Format
Earlier in this chapter, we talked about how you can choose File > Export in
order to save a copy of your file in a different format. There’s a seemingly
endless number of image formats, and Preview’s Export feature supports a



bunch of them. Most people need to be familiar with only a handful of these
formats. Here are descriptions of the most common formats that Preview
supports and the options that Preview offers for exporting to them.

GIF

Since the dawn of time, or at least since it was first introduced by
CompuServe in 1987, the GIF image format has been widely used for online
graphics. It has since been superseded by PNG in every way but one: GIF
supports flipbook-style animations. Don’t use GIF unless you want to create
an animation or feel like reliving the battle over how it’s pronounced.

If you open an animated GIF in Preview, you can see each individual frame
in the sidebar. Older versions of Preview could make rudimentary animated
GIFs, but the support was removed from in Mojave.

Tip: GIF isn’t offered in the Export dialog’s Format pop-up menu by default;
you have to hold Option as you click the menu to see it.

When exporting as GIF, you may see an Alpha checkbox. This box appears
only if there’s a transparent element in the image. Select the checkbox to
enable transparency in the exported GIF. However, if you want
transparency, PNG is the better format, so we’ll explain the Alpha option in
depth there.

HEIC

Apple introduced the awkwardly named High Efficiency Image File Format
(HEIF) as its core image file format in iOS 11 and macOS 10.13 High
Sierra. HEIF is actually a container format that can store individual images,
image properties, thumbnails, derived images created by editing, image
sequences, metadata and more. Any photo you take with an iPhone or iPad
running iOS 11 or later is an HEIF file by default. However, when you

https://archive.nytimes.com/bits.blogs.nytimes.com/2013/05/23/battle-over-gif-pronunciation-erupts/
https://en.wikipedia.org/wiki/High_Efficiency_Image_File_Format


export or share an image from Photos, it automatically converts it to JPEG,
since HEIF isn’t universally supported.

Now, if Preview’s menu says HEIC, why are we calling it HEIF? That’s
because Apple has chosen the .heic filename extension for its HEIF files
to indicate that the image(s) inside the container file are encoded using
HEVC, or High Efficiency Video Codec, whereas .heif indicates that any
codec could have been used.

Confused? Sorry. The practical upshot of all this is that you’re unlikely to
want to export an image in HEIC format, but if you ever do want to do so,
it’s possible.

JPEG

JPEG is great for photographs, and any image-viewing app can open JPEG
images. When exporting as JPEG, you can reduce the quality to reduce the
file size, which may be useful for any sort of file transmitted electronically,
such as web graphics. Be aware that JPEG compression is lossy, which
means data is thrown away during saves and can’t be recovered. Because of
this, every time you edit and save a JPEG, the picture quality degrades a
little.

Don’t confuse JPEG with the JPEG-2000 format. Despite having a similar
name and coming from the Joint Photographic Experts Group, the two
formats are entirely different. In theory, JPEG-2000 is better, but in reality,
it doesn’t offer many benefits.

Preview’s Export dialog offers one option for JPEGs: Quality, which is a
sliding scale from least to best. It defaults to a setting of about 75%, which
results in a file that’s nearly the same as the original. There’s seldom a win
in increasing the Quality slider; the file size grows significantly and you’re
very unlikely to be able to see any differences.

https://en.wikipedia.org/wiki/JPEG_2000


Reducing the Quality slider, however, can result in a significant drop in file
size without a noticeable decline in image quality. Smaller files result in
faster loading webpages and email attachments, so it’s worth playing with
the Quality slider to find your desired tradeoff between image quality and
file size.

PNG

Conceived as an improved, non-patented replacement for GIF, PNG is
designed for internet image sharing, as opposed to professional-quality
printing (PNG doesn’t support print-based color spaces like CMYK). PNG
uses lossless compression, making it ideal for images that you need to edit
repeatedly, and it excels with computer-generated images that have large,
uniformly colored areas, like screenshots and logos, particularly when you
enlarge them.

In Figure 63, you can see how the JPEG version of a screenshot
enlargement suffers from numerous compression artifacts in comparison
with the PNG version.

Figure 63: JPEG’s flaws become apparent when an image has solid colors.
In these images, you can see JPEG compression artifacts in the solid gray
background, around the icons, and particularly around the letters.



Both PNG and GIF support transparency, which means that you can define
one of the colors in an image as “transparent” rather than an actual color.
When the image is displayed, as on a webpage, the transparent pixels are
rendered in whatever the background color is. That’s tremendously handy
for creating images that appear to float over the background (Figure 64).

Figure 64: Here we’ve mocked up a simple webpage with two versions of
an old TidBITS logo, one without transparency and one with. Transparency
allows the orange background to show through.

You can remove an image’s background by using something like Preview’s
Instant Alpha Tool to select the background color(s), and then pressing
Delete. When you “delete” a portion of an image in Preview, you’re actually
replacing all those pixels with pixels in a particular color that Preview
defines as transparent.

As you save or export the image, pay attention to the Save dialog’s Alpha
checkbox. If you keep it selected, any transparent areas in the image remain
see-through in the saved image. If you deselect Alpha, any transparent areas
are colored white in the saved image.

Tip: The JPEG file format does not support transparency. That means if you
convert a PNG or GIF image to JPEG, whatever color has been defined as
transparent is instead be rendered as another color, which may be
undesirable.



Note: Two variants of PNG support simple animation—MNG and APNG—but
support and usage are minimal at best. GIF remains the choice for
animations.

TIFF

TIFF is a fixture in the print world and is used extensively for archiving
original images. TIFF files have much larger file sizes than JPEGs. They
can be compressed losslessly, though that’s not required. When exporting to
TIFF in Preview, you can choose from no compression, LZW compression,
and Packbits compression.

Tip: In our testing, LZW compression did a decent job on images of all sorts,
but Packbits-compressed files were only slightly smaller than an
uncompressed file. Stick with LZW compression.

Like PNG, TIFF also supports transparency, but what sets it apart is its
support for layers. In graphics programs like Adobe Photoshop and
Pixelmator, layers enable you to work on an image as though you’re
drawing on a stack of transparent sheets of acetate. Objects on layers can be
manipulated independently, and layers can be turned on or off so you can try
various edits without committing to them.

Unfortunately, Preview doesn’t support layers, so while it can open a TIFF
that contains layers, it flattens them into a single layer. The same goes for
edits made in Preview; you can add a shape to a TIFF and move it around
while editing, but as soon as you close the image, the shape is merged with
the image layer.

Tip: Although TIFF files support transparency, if it’s not necessary for your
needs, disable the Alpha checkbox when saving or exporting to turn off
transparency and reduce file size significantly.



PDF

Entire books have been written about Portable Document Format (like PDF
Hacks, PDF Explained, and Developing with PDF, all from O’Reilly
Media). Originally created by Adobe but an open ISO standard since 2008,
PDF is one of the tech world’s most useful file formats. In the simplest
terms, PDF represents the text and graphics of a printed document in digital
form. The most common usage of PDF is in printing and publication, with
examples ranging from government forms to Take Control ebooks. PDF is
also incredibly flexible—macOS’s Quartz rendering engine uses PDF
internally, which is why it’s so easy to export files as PDF in macOS.

Preview’s Export dialog provides two extra options when exporting PDFs:
encryption and Quartz filters. We look at encryption in Restricting PDFs.
The Quartz filters modify the exported PDF in various ways. Two of them
affect the internal structure of the PDF:

Create PDF/A: PDF/ARestricting PDFsa PDF variant intended for
archival purposes. The main benefit is that it embeds the fonts inside
the document, so the recipient doesn’t have to have the PDF’s fonts
installed on their system. It’s also sometimes required for compliance
purposes. If you don’t know what this is, you probably don’t need it.

Create Linearized PDF: A linearized PDF is designed for fast web
viewing, because a browser doesn’t have to first load the entire
document before displaying it. Instead, it can “stream” a linearized
PDF a page at a time. Consider this if you plan to offer your PDF for
online display.

Other Quartz filters tweak the look of an entire PDF, such as to give it a
sepia tone—skip ahead to Changing PDF Color for more. There is also a
Permissions button that we’ll cover in Restricting PDFs, ahead.

https://www.oreilly.com/library/view/pdf-hacks/0596006551/
https://www.oreilly.com/library/view/pdf-explained/9781449321581/
https://www.oreilly.com/library/view/developing-with-pdf/9781449327903/
https://en.wikipedia.org/wiki/PDF/A


And All the Rest

What about the other image formats Preview lets you pick from when you
export a file? For the most part, they’re old, uncommon, or both, at least in
the Mac world. The two exceptions are Photoshop and QuickTime Movie,
which are plenty common, but unlikely to be useful in the context of a
Preview export. Saving a file in Photoshop format does mean that
Photoshop can open it natively, but as far as we can see, there’s no
advantage over PNG in that regard. And we can’t figure out what file format
you can open in Preview that you could later save using QuickTime Movie;
animated GIFs seemed the most likely, but they can’t be saved as
QuickTime movies.

If you’d like to read up on all the rest of your format choices, here’s a full
list, with links for more information:

ICNS

JPEG-2000

KTX

Microsoft BMP

Microsoft Icon

OpenEXR

PBM/PGM/PPM

PVRTC

Photoshop

PostScript

https://en.wikipedia.org/wiki/Apple_Icon_Image_format
https://en.wikipedia.org/wiki/JPEG_2000
https://registry.khronos.org/KTX/specs/1.0/ktxspec.v1.html
https://en.wikipedia.org/wiki/BMP_file_format
https://en.wikipedia.org/wiki/ICO_(file_format)
https://en.wikipedia.org/wiki/OpenEXR
https://en.wikipedia.org/wiki/Netpbm_format
https://en.wikipedia.org/wiki/PVRTC
https://en.wikipedia.org/wiki/Adobe_Photoshop#File_format
https://en.wikipedia.org/wiki/PostScript


TGA

Tip: Preview’s list of supported formats may look long, but there are many
more graphic file formats out there. If you run across one that you can’t
open with Preview, or if you need to save an image in a format that Preview
doesn’t support, turn to Lemke Software’s venerable GraphicConverter,
which can import approximately 200 file formats and export in roughly 80
formats.

Summing It Up

If you’re still unsure about which format should you use for your graphics,
here’s the short answer:

If the image is photographic, JPEG provides the best combination of
quality and reduced file size.

If the image is a computer-generated graphic with large areas of
uniform color, like most screenshots, or if you want the image to
appear to float on the page using transparency, stick with PNG.

TIFF is useful primarily in the print publishing world. For instance, a
publisher may require that screenshots for a book be in TIFF rather
than PNG for color workflow reasons. Also, use TIFF if you need to
edit with layers in an app like Photoshop.

Restricting PDFs
Before you send your bookkeeper a copy of your bank statement as an email
attachment, you might want to encrypt it. That way, if her Gmail account is
hacked, the hackers won’t be able to open it, assuming the password you’ve
chosen is reasonably strong. You’ll have to tell her the password through
some other communications medium than email. There are plenty of other

https://en.wikipedia.org/wiki/Truevision_TGA
https://www.lemkesoft.de/en/products/graphicconverter/


reasons why you might want to encrypt a PDF: perhaps yours contain trade
secrets, customer data, or even a treasure map.

In addition to encrypting PDFs, you can now place additional restrictions on
them to prevent the recipient from printing them, copying anything from
them, and so on.

Tip: One-Time Secret helps you send passwords securely. See the TidBITS
article Share Passwords Securely with One-Time Secret.

To place restrictions on a PDF, choose File > Edit Permissions.

Note: You can also place restrictions while exporting. Choose File > Export
and click Permissions.

You must first create an owner password at the bottom (Figure 65). The
owner password lets you bypass or change restrictions. You can remove all
restrictions, but the owner password will remain.

https://onetimesecret.com/
https://tidbits.com/2016/06/13/share-passwords-securely-with-one-time-secret/


Figure 65: You must first create an owner password before applying any
restrictions.

To encrypt the PDF, select Require Password to Open Document, and create
a different password than the owner password. From then on, when anyone
—including you—tries to open the encrypted PDF in any PDF-savvy app,
they’ll be prompted for the password (Figure 66).



Figure 66: After you encrypt a PDF, it can’t be opened without keying in
its password.

You can deselect additional options to prevent a recipient from taking those
actions:

Printing

Copying text or graphics

Inserting, deleting, or rotating pages

Adding annotations or signatures

Editing existing form fields

All of them are allowed by default.

If a recipient attempts to take any of those actions on the PDF, they’re
prompted to enter the owner password (Figure 67).



Figure 67: You must have the owner password to take certain actions on a
restricted PDF.

You can change permissions at any time by choosing File > Edit
Permissions.

Warning! Do not be overly dependent on these permissions for security, as
they’re incredibly easy to work around. For example, someone could take a
screenshot of a copy-restricted PDF and then use Live Text to copy the text
from the image. See Selecting Text in Pictures.



Read PDFs

In this chapter, we’re going to focus on Preview’s prime directive: viewing
PDF documents. We start by making sure you’re using the best view for
your needs, and then look at the features for Navigating Your PDFs that
make it easier to move around.

Sometimes a PDF is better than a physical document because you can find
specific text within it, and we cover that in Searching Within a PDF. For
those who want to look more closely, we discuss Examining PDF Metadata,
and we close with a discussion of Copying Text and Images.

Note: While Books for iOS can read PDFs, and Books for both iOS and Mac
can store and sync your PDFs, Books for the Mac doesn’t actually let you
read PDFs—instead, it hands them off to Preview! When you open a PDF
stored in Books, Preview launches and opens the file like any other PDF for
reading and annotation.

Tweaking the PDF View
The View menu offers three options for how you view PDFs:

Continuous Scroll: This view lets you move smoothly from the
bottom of one page to the top of the next one as you scroll in the
document.

Single Page: In this view, you see a document page-by-page as you
scroll.



Tip: Notice the keyboard shortcuts displayed on the View menu;
Continuous Scroll is ⌘-1, Single Page is ⌘-2, and Two Pages is ⌘-3.

Two Pages: Work in this view when you want to scroll by two-page
spread (Figure 68).

Figure 68: Two-page view works well on large, widescreen displays.

Which view is best for you depends on your personal preferences, the
document in question, and your screen size. For instance, if you’re working
on a small MacBook screen, you’ll likely want to stick with Continuous
Scroll view, which makes it easy to zoom the page to a comfortable reading
size and then scroll through smoothly with the trackpad. For those with
larger screens, Single Page may work better because it enables page-based
scrolling with a tap of a key (see Navigating Your PDFs). It’s particularly
good if each page of the PDF you’re reading stands alone. If your screen is
large enough, Two Pages lets you see a two-page spread at once; that’s ideal
if you’re viewing a magazine that was designed around two-page spreads.

Happily, you can set your favorite view as the default in the PDF pane of
Preview’s settings—choose a view from the “Opening for first time: Show



as” pop-up menu (for more details, see PDF Settings).

You can also view pages as thumbnails in a grid by choosing View >
Contact Sheet (Figure 69). You might find this useful for getting an
overview of a highly graphical PDF document or when building a PDF from
separate documents. It’s too bad that Preview now uses square thumbnails,
which look particularly weird with PDF pages.

Double-click any thumbnail to focus on it, bringing it up in the last view
you picked. We’ll talk more about these features in Manipulate PDFs, but
notice that in Contact Sheet view, you can drag pages around in a PDF to
rearrange them, or even select one or more pages and press Delete to
remove them. The same is true of Thumbnails view (View > Thumbnails)
and the sidebar.

Figure 69: Contact Sheet view can be useful for getting an overview of a
PDF, or for adding, removing, or rearranging the pages.

Zooming In and Out

The key to a comfortable PDF reading experience is correctly setting the
zoom level, which you can adjust by choosing View > Zoom In and View >
Zoom Out, though we recommend using the keyboard shortcuts instead: ⌘-



= and ⌘– (we think of them as ⌘-Plus and ⌘-Minus, though you don’t
need to press the Shift key).

If you have a trackpad connected to your Mac, pinching in and out adjusts
the zoom level as well.

However, with PDFs, you won’t want to adjust the zoom manually all the
time. That’s why the View menu offers additional choices for document
zooming: Zoom to Fit, which fills the window with the document, and
Actual Size, which does just what it says, regardless of whether the
document fits in the window or not. Zoom to Fit in a large window is
usually the best way to read PDFs.

Tip: If you find yourself changing the zoom level for every PDF, be sure to
set your “Define 100% scale as” option correctly in Preview’s PDF Settings,
since that affects the scale at which PDFs open.

If you encounter a portion of text that’s too small to read, Preview has two
tools for overcoming that; we especially like the magnifier:

Zoom in a rectangle: You can zoom in on a specific part of a page.
Make a marquee selection in a PDF by choosing Tools > Rectangular
Selection, dragging out a rectangle, and then choose View > Zoom to
Selection.

Use the marvelous magnifier: A better option is the Magnifier, under
Tools > Show Magnifier, though it’s easier to engage it by pressing the
Backtick key (`), just above the Tab key. It turns your pointer into a
magnifying glass inside Preview, allowing you to make small text in a
PDF easier to read (Figure 70). While the Magnifier is enabled, you
can still scroll through the document as normal, and the text moves
under the Magnifier. Turn it off quickly by pressing Backtick or Esc.



Figure 70: The Magnifier makes even the smallest text easy to read. Since
it lets you keep magnifying the text as you scroll through a document, and
it’s easy to turn on and off with the keyboard, it’s a better option than View
> Zoom to Selection.

Tip: The Magnifier works best in Continuous Scroll view since then the page
scrolls under it. If you use Single Page or Two Pages view, you end up having
to move the Magnifier around on each page or spread.

Using Full-Screen Mode

Sometimes you want to cut out distractions while reading a PDF. If that’s
the case, choose View > Enter Full Screen (or click the green zoom 
button) to put the window into macOS’s full-screen mode.

By default, full-screen mode shows PDFs with portrait-orientation pages as
two-page spreads and PDFs with landscape-orientation pages as single
pages. Hover at the top of the screen to temporarily reveal the menu bar and
open the View menu to choose among the usual views: Continuous Scroll,
Single Page, and Two Pages.

Tip: Continuous Scroll is the odd view out, since it also zooms the document
to fit the width of the screen, making the text super large.

Within full-screen mode, you can use the same trackpad, mouse, and
keyboard navigation controls discussed in relation to images, in Viewing in
Full-Screen Mode.



Making a PDF Slideshow

Choosing View > Slideshow displays the current page at full-screen size,
and switches to the next page or pages every 5 seconds, creating a
slideshow-like effect from the PDF. In our testing, if the pages of the PDF
were in portrait orientation, the slideshow always showed two-page spreads.
However, if the pages of the PDF were in landscape orientation, they
appeared one at a time in the slideshow.

A toolbar near the bottom of the screen provides controls for moving
between pages, playing or pausing, and closing the slideshow—if you don’t
see the toolbar, wiggle the pointer to reveal it. You can also press the arrow
keys to move between pages manually and press Esc to exit the show (refer
back to Figure 25).

Note: If you start a slideshow while in full-screen mode, pressing Esc ends
the slideshow and exits full-screen mode. To stop the show and remain in
full-screen mode, click the X button on the toolbar.

Navigating Your PDFs
The easiest way to scroll through a PDF is with trackpad or mouse, but there
are oodles of other options involving menu commands, toolbar buttons, and
keyboard shortcuts (as well as the sidebar, which we cover in the next
topic).

Here’s a rundown, which we list in the order that these commands appear on
the Go menu:

Up and Down: These commands scroll your PDF by the size of the
window that contains it, which may be more or less than a single page
if you choose View > Continuous Scroll. So, if your window is
showing multiple pages, scrolling with these commands moves you by



as many pages as are showing. Similarly, if your window can’t show an
entire page, these commands move you by portions of a page at a time.

You can choose these commands from the Go menu, but the special
symbols shown on the menu (↑and ↓) indicate that you can also just
press the keyboard’s Page Up and Page Down keys, if they’re present
on your keyboard. If they’re not, use fn-↑ and fn-↓. We find the
keyboard shortcuts infinitely preferable, because they are so quick and
easy.

Previous Item and Next Item: In contrast to the previous commands,
Previous Item moves up a page and Next Item moves down a page,
regardless of the window size. Again, the keyboard shortcuts shown on
the Go menu—Option-↑ and Option-↓—are easier to use, and even
easier yet are the → and ← keys.

You can put Previous and Next buttons on the toolbar too; see Tour and
Customize the Main Toolbar.

Tip: If your keyboard has Home and End keys, you can press them to skip
to the start or end of your PDF.

Note: In Continuous Scroll view, the ↑ and ↓ keys scroll within the
document, but only by a few lines. If you have the Table of Contents
sidebar open and your current selection in Preview is an item in the
sidebar, the ↑ and ↓ keys navigate within the sidebar, instead of within the
main portion of the document.

Go to a page: Choose Go > Go to Page (⌘-Option-G). In the dialog
that appears, enter the page number, and press Return or click OK
(Figure 71). If you don’t end up where you expect, see the explanation
of Use Logical Page Numbers in PDF Settings.



Figure 71: To view a specific page, choose Go > Go to Page.

Back and Forward: Well-made PDFs, like the Take Control books,
feature links to other parts of the document. That’s where the Back and
Forward commands come in handy. Choose Go > Back (⌘-[) to
bounce back to the link you clicked. Then, Go > Forward (⌘-]) returns
you to that link’s destination. These commands also work if you
navigate using the sidebar.

Tip: You can put Back and Forward buttons on the toolbar; see Tour and
Customize the Main Toolbar.

Navigating PDFs via the Sidebar

The Go menu commands and associated keyboard shortcuts, which we just
covered, do the heavy lifting of PDF navigation in Preview, but the sidebar
is particularly useful as a visual way to move around in multi-page
documents.

Preview isn’t smart enough to show the sidebar automatically for multiple-
page PDFs and to hide it for single-page documents, but it does try to
remember the sidebar’s last state, both generally and for previously viewed
documents, and to restore that state for your next usage.

When viewing multi-page documents in the sidebar, you have two main
options, both available in the View menu:

Thumbnails: Choose Thumbnails to display graphical previews of
images and document pages.



Table of Contents: With Table of Contents, you see a text list of image
filenames or PDF bookmarks (Figure 72). These bookmarks are
different than the “bookmarks” that you can insert in Preview when
Bookmarking a PDF.

Figure 72: The Thumbnails view (left) offers visual previews of each of a
PDF’s pages. You’ll probably find the Table of Contents view (right) helpful
when looking for a particular topic in your PDF.

Regardless, if you click an item in the sidebar you jump to the associated
page. Remember that you can drag the sidebar’s divider to the right to see
the thumbnails larger, or see more of the sidebar text. Dragging the divider
to the left makes more room for the current image or page.

You can navigate within the Table of Contents view in the sidebar with the
keyboard. Press the ↑ and ↓ keys to move between table of contents entries.
Press → to expand (Figure 73) a hierarchical table of contents level
(indicated by a disclosure triangle). Press ← to collapse the outline again



Figure 73: To expand an item in the table of contents, click its disclosure
triangle or select it and then press the → key.

It’s usually best to display the sidebar for multiple-page documents, but it
can be an annoyance when viewing a lot of one-page PDFs. Hide the
sidebar by choosing View > Hide Sidebar. Note that this command is a one-
way toggle; if Preview’s sidebar is showing, choosing Hide Sidebar makes it
disappear and puts a checkmark next to the menu command. Choosing it
again does nothing. To show the sidebar, you must instead choose another
sidebar-related command like View > Thumbnails.

Tip: You can use Preview’s sidebar to jump between annotations, too. See
Annotate PDFs.

Searching Within a PDF
If the teen in your life has ever marched into the room, holding a paperback
from English class while proclaiming, “this book is no good if it doesn’t
have a Search!” then you know that sometimes a PDF is much more
valuable than its equivalent printed form. Searching in a PDF has many
uses, and beyond hunting down just the right quote for an English paper,
one that comes up often for us is finding text in a Take Control ebook. In the
example below, we’re showing how you can quickly find every mention of
using Siri in Take Control of Apple TV.

As you can see in Figure 74, we’ve entered siri in the Search field to find
all instances of the term in the document—it’s easier to enter all-lowercase
siri instead of Siri, and Preview’s search isn’t case-sensitive. As soon



as you stop typing, Preview displays a Search toolbar just above the
document. Preview also summarizes the results in the sidebar and highlights
instances of the term in the document itself.

Figure 74: As you type in the search field, the results appear in Preview’s
sidebar and are highlighted in the document.

Tip: If the toolbar isn’t visible or if you’ve customized it to remove the
Search field, choose Edit > Find > Find (⌘-F) to bring up a Search dialog.

If you like, you can sort your results by clicking the Search Rank or Page
Order button on the Search toolbar:

Search Rank: With Search Rank, Preview sorts the results by the
number of matches in each section (it’s not entirely clear what Preview
considers a “section”). Depending on how accurate your search terms
were, Search Rank might be a good way to get the best results at the
top. On the downside, if you’re familiar with the contents of the
document you’re searching, clicking different search results can make
you feel disoriented as to where you are in the document.

Page Order: With Page Order, Preview sorts the results by page,
starting with results earlier in the document. You can still judge the
search ranking by looking at the number of matches in each section, to



the right of the section title in the sidebar. We like Page Order best
when we’re working in familiar documents.

To browse through your results, you can click the Back and Forward arrow
buttons on the Search toolbar or choose Edit > Find > Find Next, but we
always press ⌘-G, which “goes” to the next found item in most Mac apps,
including Preview. Or, select a search result in the sidebar and then arrow-
down through the sidebar.

Frustratingly, Preview searches for multiple words—for example siri
remote—independently, which usually provides far too many results. To
search for a phrase, surround the words with double quotation marks, as in
“siri remote”. Preview then looks for all instances of those words
together.

To leave search mode, click the Done button on the Search toolbar or the
close  button in the Search field on the main toolbar.

Examining PDF Metadata
So far, we’ve discussed viewing the contents of the PDFs, but there’s more
to PDF documents than meets the eye. Most include a wealth of embedded
information, called metadata, with information like file size, page count,
author, creation date, and more. You likely won’t want to look at this
information regularly, but it can be worth consulting to learn more about a
document and how it was created. Plus, the Mac’s Spotlight search engine
can index some of this information and use it to help your Spotlight
searches more useful.

To see a document’s metadata, choose Tools > Show Inspector (⌘-I) to
open the Inspector window. Here’s what you’ll find:



General Info : The General Info inspector shows basic details,
including file size, resolution, creator information, and when the file
was created (Figure 75).

Figure 75: The General Info inspector shows basic information about the
PDF, like filename, page count, and page size.

Keywords : Here you can add keywords to a document or image so
that those files can be found more easily when you search using your
Mac’s Spotlight feature. Click the plus  button to add a keyword and
click the minus  button to remove the selected keyword (Figure 76).



Figure 76: Add keywords to a PDF in order to make it easier to find in
Spotlight searches.

Encryption : This inspector tells you whether the PDF is encrypted,
and if so, what permissions you have. Yes, Preview can encrypt your
PDFs, which we discuss in Restricting PDFs.

Crop : This inspector shows the dimensions of the area you’ve
selected with the Rectangular Selection tool. You can crop a PDF page
to those dimensions, as discussed in Cropping Pages.

Annotations : Use this inspector to view and jump to your highlights
and notes—see Highlighting Text and Adding Notes to a PDF.

Note: The Inspector window works a bit differently for images. See
Examining Image Metadata.

Copying Text and Images



Sometimes you need to move information from a PDF to another app.
Perhaps you need to copy an address from a PDF and paste it into a
conversation in Messages. Or maybe you’re designing a brochure for a
client and the only place you can find the appropriate logo is in an old PDF.
Whatever the situation, you can copy both text and images from PDFs that
you’re viewing in Preview. Here’s how to do both.

Copying Text from PDFs

When you need to copy text from a PDF, first select it using the Text
Selection  tool, accessible by choosing Tools > Text Selection or from the
Markup toolbar.

Selecting text in Preview works just like text selection in any other app—
just position the pointer and then drag across the text you want—but once
you’ve selected your text and are ready to copy, there are a few things to
keep in mind:

Depending on the PDF, there may or may not be Return character at
the end of every pasted line that prevents the pasted text from wrapping
normally. You can delete the spurious Return characters manually, by
searching for them (copy one and paste it into your app’s Search field)
and replacing with a space, or use an app like BBEdit (choose Text >
Remove Line Breaks).

When you look at pasted text, you may see some spaces where
characters are missing. This mistake happens when the PDF was
created by an app that replaced certain character pairs with a single
character called a ligature. For instance, some apps may automatically
replace the two letters fi with a single fi character (you can even
type that character with Shift-Option-5). And since those two letters
appear in the word office you might instead see of ce in text
copied out of a PDF. We’ve also seen instances where Preview just



fails to copy the spaces between words—this may have to do with how
the PDF was originally created. There’s no way around these problems,
but using a spell-checker on the pasted text should reveal most
mistakes.

When copying from a PDF, Preview also copies the text style,
including typeface, text color, and even background color. If this isn’t
what you want, if the receiving app has an Edit > Paste and Match
Style command, use that command when you paste. Some apps might
call this command Paste Text Only or Paste Without Formatting.

Note: If you regularly copy text from one place to another, third-party
tools can simplify the process of removing line breaks and ditching the
styles. Joe Kissell’s Take Control of Automating Your Mac discusses these
tools in detail.

If you use the Text Selection tool to copy text and images in your PDF,
the results may not always be what you’d expect.

Copying Images from PDFs

If copying an image using the Text Selection Tool doesn’t work the way you
want, try selecting the image using the Rectangular Selection  tool,
accessible via Tools > Rectangular Selection or from the Markup toolbar.

Use the Rectangular Selection tool to drag out a rectangle around the image
you want to copy, then press ⌘-C. All you’re copying is a graphical image
of what you select, just like taking a screenshot with File > Take Screenshot
> From Selection (see Taking Screenshots).

Once you’ve copied the chunk of PDF, you can paste it into nearly any app
that can accept a graphic. Alternatively, choose File > New from Clipboard
to create a new PDF from what you copied.

https://www.takecontrolbooks.com/automating/?pt=INTERNAL


Annotate PDFs

Preview isn’t just a mere PDF reader—it also offers an array of PDF
annotation capabilities that can take your reading and collaboration to the
next level.

Highlighting Text lets you mark interesting passages in a PDF. Adding
Notes to a PDF helps you add context to your highlights and include
independent notes throughout the document. If those annotation methods are
too complex for your needs, Bookmarking a PDF is a simple way to keep
your place. For more graphical annotations, try Adding Shapes and Text to a
PDF.

Finally, we cover Working with Forms, such as those issued by the
government, and Signing PDFs, which makes it easier to slap your John
Hancock on a digital document.

Highlighting Text
If you’re one of those people who highlight important passages in
textbooks, you’re going to love Preview’s highlighting feature. It works
much like using a marker to highlight passages in a book, except that you
can add a note to go with each highlighted passage, rather than having to
write in the margin with another pen. This is tremendously handy when
you’re reviewing a PDF document for someone else, or even to leave
yourself notes.

To highlight a passage, click the Highlight  button on the toolbar. When
selected, the yellow highlighter is enabled by default. Click the arrow next



to the button to choose among different highlight colors, or to use red
underline or strikethrough marking (Figure 77).

Figure 77: Choose a highlight color. Or pick Underline or Strikethrough as
your “highlight.”

Now, drag over your passage to highlight it. The highlight color or style
remains selected, so you can keep highlighting passages without any
additional action.

Once you’ve highlighted a passage, you can modify the highlight in a few
ways:

Change the highlight: Control-click the highlight and click a different
color, or click the underline or strikethrough  icon.

Delete the highlight: Control-click the highlight and choose Remove
Highlight.

Remove part of a highlight: Choose the same highlight color or style
as is used in the highlighted text you want to modify, and select some
of the highlighted text. (In other words, each highlighter works to erase
its own highlights as well.)

Add a note: We explain how to add a note in the next topic.



You can efficiently view all your highlights in the sidebar or the
Annotations inspector. See Quickly Viewing Highlights and Notes, ahead.

Adding Notes to a PDF
When it comes to adding notes, Preview offers two options:

Make a general note: A general note can be positioned anywhere on
the page (Figure 78). It’s easy to move it around or duplicate it.

Figure 78: For this screenshot, we’ve chosen View > Highlights and Notes
to show how notes can be viewed in the sidebar. The blue note is a general
note; the “unsalted” underlining doesn’t get a color; the green note goes
with the highlighted “almond flour”; and the red note goes with the struck-
out “Dutch-processed.”

Attach a note to a highlight: You can attach a note to highlighted text
—this is a handy way to help yourself remember why you highlighted
a passage in the first place.

Adding a General Note

To add a general note, choose Tools > Annotate > Note or click the Note 
icon on the Markup toolbar. (We also like its keyboard shortcut, ⌘-Control-
N.)



A colored box appears; start typing to add your text (Figure 79). When
you’re done, click outside that box, and it shrinks down to become a smaller
box.

Figure 79: Type your note in the box.

You can do several things with your note:

Change its color: Control-click the closed note box, and choose a
different color.

Edit it: To expand the note box and make its text editable, click it. Or,
click it in the Annotations inspector and edit its text in the edit pane
(more about the inspector slightly ahead).

Move it: Drag the note box to the side of the page so it doesn’t obscure
the document’s text (usually a good idea). You can’t drag notes
between pages.

Delete it: Click the edge of the note box (there’s no way to tell it’s
selected anymore) and press Delete, or select the note in the sidebar or
Annotations inspector and press Delete. This is worth doing when
reviewing comments from others that you’ve dealt with and that
nobody needs to see again.

Adding a Highlight Note



We talked about Highlighting Text earlier in this chapter. Once you’ve
highlighted a passage, here’s how to attach a note to it:

1. Control-click the highlighted text and choose Add Note from the panel
that appears.

2. Preview displays a blank rectangle in the same color as your highlight.
Type your note in the rectangle.

3. Click outside the note rectangle when you finish.

The note box appears as a tiny square icon just above and to the right of the
highlighted text.

To edit a highlight-attached note, click its square icon in the main Preview
window. Click to position the insertion point in the text, make your revision,
and click outside the note area when you finish.

To delete a highlight-attached note, either Control-click its highlighted text
and choose Remove Note or just remove the highlighting. You can also
delete highlight-attached notes from the sidebar or Annotations inspector.

Quickly Viewing Highlights and Notes
Preview provides two places for working with a document’s highlights and
notes from a summary view: the sidebar and the Annotations  inspector.

To access highlights and notes in the sidebar, choose View > Highlights and
Notes (⌘-Option-4). This is particularly useful if your highlights and notes
are scattered in a multi-page PDF.

Click any note in the sidebar to scroll to it. If you want to remove an item,
select it in the sidebar and press Delete.



Alas, although you can select and delete highlights and notes in the
Annotations inspector (choose Tools > Show Inspector and click the
rightmost  button), clicking them doesn’t scroll you to that position in the
document. However, you can edit the text of a note in the inspector—not
that that’s particularly useful.

Bookmarking a PDF
Reading a long document isn’t much fun if you can’t save your place. You
don’t have to rely on highlights and notes for that, since you can bookmark
a page in a PDF by choosing Tools > Add Bookmark or pressing ⌘-D. A
little red bookmark icon appears in the upper-right corner of the page
(Figure 80).

Figure 80: A bookmarked page is indicated by a red bookmark (circled).

To view your bookmarks in the sidebar, choose View > Bookmarks (⌘-
Option-5). Click one to jump to that spot in the document. To delete an
unneeded bookmark, select it in the sidebar and press Delete.

Note: Adobe Acrobat Pro and Adobe Reader use the term “bookmark” for
items in what Preview calls the “table of contents.” What Preview calls
“bookmarks” are, as far as we can tell, specific to Preview, so don’t assume
that anyone reading your PDF in one of Adobe’s programs can see and use
them.

Adding Shapes and Text to a PDF



In Inserting and Manipulating Basic Shapes, we explained how to add
shapes, text, loupes, and masks to images in order to annotate them. Those
exact same tools also work in PDFs. Here are some ways these tools are
useful for PDFs.

Note: When you add shapes to an image, save it, and close, Preview
“flattens” the shapes into the image so they can’t be selected and
manipulated independently in subsequent editing sessions. However, that’s
not true of PDF; shapes added to a PDF remain independent entities that you
and others can select and modify or delete later on.

Adding Text

Let’s say you want to fill out a PDF form, but it’s not a proper PDF form
with text fields into which you can type. No problem, click the Text  icon
on the Markup toolbar (or press ⌘-Control-T) to add a text box with “Text”
as placeholder text. Click inside the box and start typing. See Adding Text
to Images.

Redacting Text

Oftentimes, PDFs have sensitive or embarrassing information that you need
to remove, and simply drawing a black box over it is insufficient. That’s
why Apple has added a Redact tool to Preview, which permanently deletes
whatever text you select while the tool is enabled by clicking the Redact 
icon on the Markup toolbar (Figure 79).

Figure 81: The Redact tool permanently deletes sensitive text from PDFs.

Drawing Attention to Details



If you want to call attention to something in a document without
Highlighting Text or Adding Notes to a PDF, you have three tool options:
Shapes, Loupe, and Mask.

We’ve found that no-fill red ovals (or rectangles, of course) are a great
choice when you want to call out certain text or images. Choose Oval 
from the Shapes  icon on the Markup toolbar to insert one (or press ⌘-
Control-O). While the shape is selected, use the Border Color  and Fill
Color  icons on the Markup toolbar to give the oval a red border and a
clear fill. Drag the oval over the desired content, and use the blue
adjustment handles to tighten the oval around the content. For more on
customizing shapes, see Inserting and Manipulating Basic Shapes.

Note: Preview remembers shape settings, so if you always want it to use a
3-point red stroke and no fill, you’re all set. Unfortunately, Preview
remembers only the settings you used last, so if you switch between a red
no-fill oval and a solid black rectangle, you’ll have reset the shape settings
each time.

When you’d like to magnify small details in a PDF, the Loupe  tool can be
handy (Figure 82). Like the others, it’s available from the Shapes  icon
menu on the Markup toolbar (or press ⌘-Control-L).



Figure 82: Both the oval shape (top) and the loupe (bottom) are handy
for calling out elements in a PDF.

Finally, there’s the Mask tool, which works by leaving a rectangular area
alone while darkening the surrounding area. Insert a mask by choosing
Mask  from the Shapes  icon menu on the Markup toolbar. It’s useful for
highlighting an important section of text on a page, but you can have only
one mask per page. See Using the Mask and Loupe Shapes for details on
how to use masks and loupes.

Pointing Things Out

Once you’ve drawn attention to something in a document, you may need
more context to explain what’s important about it. For that, the arrow 
shape is useful—find it in the Shapes  icon menu on the Markup toolbar
(or press ⌘-Control-A).

When an arrow is selected, start typing to insert text off to its side—you
don’t even have to create a text box (Figure 83).



Figure 83: Arrows and text work together to make sense of the things you
circle in a document.

When adjusting arrows, Border Color  changes the color of the arrow and
line, while Fill Color  changes the color of the attached text box. For more
on customizing arrows, see Inserting and Manipulating Basic Shapes.

Working with Forms
Some PDFs—for example, many government documents—include pre-
defined interactive text fields and checkboxes (Figure 84). Although you
can fill in these forms with Preview, it can’t create PDFs that include such
forms. For that you need an app like Nitro PDF Pro or Adobe’s Acrobat Pro.

Figure 84: Some PDFs have interactive form fields for text entry and
checkboxes.

To fill in an interactive form, just click inside a form element with the Text
Selection  tool, which should be selected by default. If not, click it on the
Markup toolbar:

https://www.gonitro.com/pdf-pro/macos
https://www.adobe.com/acrobat/acrobat-pro.html


Text fields: When you mouse over a text field, a highlight appears over
the field; click it and a blinking text cursor appears. You’re ready to
type, but don’t worry about trying to format your text in any way, since
the formatting is set by the PDF’s creator. To move to the next field,
press Tab.

After you finish typing in a field, be aware that if you click in it again,
Preview selects all the text inside. Thus, if you click a field
unintentionally and start typing, you’ll overwrite your previous text. To
edit what you previously entered, click once in a field and then again
inside it. Preview deselects the text so you can make a change.

Checkboxes: To tick a checkbox, click it, and a checkmark appears.
Click it again to remove the checkmark.

Although a group of checkboxes may be set up logically so that it
makes sense to select only one, the creator of a particular PDF may not
have configured it properly to prevent you from selecting several
conflicting options. It’s up to you to keep the selection sensible.

Note: Interactive PDF forms can also include radio buttons, pop-up menus,
scrolling lists, and interactive signature fields. Some forms may even have a
button that submits the data via email or a URL. PDFs with such forms are
extremely uncommon. Preview appears to handle radio buttons and pop-up
menus, but can’t deal with scrolling lists, signature fields, or Submit buttons.
If you run across a sophisticated form like this, fill it out in Adobe Reader
instead of Preview.

If you fill in a form partway, you can save the PDF and finish it or edit your
previous entries in Preview later.

https://get.adobe.com/reader/


Warning! We’ve seen a few cases where people using other PDF viewers
couldn’t see forms filled in with Preview. If you send someone a filled-in form
and they can’t see your entries, try Printing to PDF and then sharing that
version.

Signing PDFs
Here’s a classic problem: someone sends you a form to sign via email. You
have to print it, sign it, and then scan it back into the computer so you can
email it back (or, horrors, fax it). Preview solves this problem neatly with its
Signature feature, (Tools > Annotate > Signature), but more easily
accessible with the Sign  icon on the Markup toolbar. Using this tool, you
can create one or more signatures, and then easily add them to PDFs.

Tip: Although we’re not suggesting forgery, if you find yourself in a situation
where you often need to sign things for your spouse, boss, or an
incapacitated relative, adding that person’s signature to Preview can make
signing electronic forms for them much easier.

Creating Signatures

Preview offers three ways to create a digital signature: by writing it on a
trackpad, by scanning a handwritten signature with the Mac’s built-in
camera, or by creating a signature with an iPhone or iPad.

Note: Each signature option also has the choice to add a description, such
as full name, given name, family name, etc.

Creating Signatures with a Trackpad

To create a signature using a trackpad:



1. Click the Sign  icon on the Markup toolbar and choose Create
Signature.

2. Click the Click Here to Begin button.

3. Write out your signature on the trackpad with your finger.There’s no
way to erase, so if you’re unhappy with the results, click Clear and try
again.

Tip: If you have a rubber-tipped iPad stylus (not an Apple Pencil), it works
better than your finger on your Mac’s trackpad.

4. When you’re satisfied, click Done to add the signature to Preview’s list
(Figure 85).



Figure 85: The simplest way to add a signature is to draw it on the
trackpad.

Note: During testing for this update, Josh and Joe found that the Trackpad
option was disabled on their M1 MacBook Airs, while Adam’s M1 MacBook Air
had it enabled. All were running the same version of macOS. We don’t know
why it works for some people but not others.

Import Signatures with a Webcam

If you dislike how shaky your signature appears when you try to draw it
with your finger on the trackpad—or if you don’t have a trackpad, write it
on a piece of paper and snap a picture with your Mac’s built-in camera
instead. Here’s how:



1. Sign your name on a blank, white piece of paper, preferably with a
black marker.

2. Choose Create Signature and click the Camera button. Inside the
popover, a window appears displaying what your camera sees.

3. Hold your paper signature up to the camera, making sure to get it close
and line it up with the blue line.

4. When Preview detects the signature, it displays the digital version in
the camera window. As long as you hold the paper up to the camera,
Preview keeps trying to detect it, so you can move it slightly to keep
improving the results. Once you like how it looks, click Done to save
the signature (Figure 86).

Figure 86: Preview’s camera-based signature detection.

Create a Signature with an iPhone or iPad



Preview displays a third tab after you click the Sign  icon: iPhone or iPad.
If you have multiple devices, you’ll see a Select Device button in the
trackpad area (Figure 87).

Figure 87: Preview lets you use an iPhone or iPad to create your digital
signature

Click Select Device, choose a device to write on, and a signature field
appears on that device. Sign with your finger or an Apple Pencil and tap
Done to transfer that signature to your Mac (Figure 88).



Figure 88: You can draw on an iPhone or iPad to add a signature.

Using Signatures

Once created, your signature is easy to insert into an image or PDF.

Choose Tools > Annotate > Signature or click the Sign  icon. This time,
you see your new signature in the list. Choose it to insert it in the document.

You can move it by clicking and dragging, or resize it using the blue handles
(Figure 89). Signatures are usually much larger than the space available,
which is good, since shrinking them to fit a signature line tends to make
them look better.

Figure 89: Once inserted, a signature behaves like any other shape, and
can be moved and resized accordingly.

Tip: You can also adjust the color of the signature by modifying the Border
Color settings, but you can’t use the Fill Color tool on a signature to adjust
its background color. See Customizing Shapes.

Once you save the PDF, the signature is embedded into the PDF’s visual
layer, so it can’t easily be copied out and reused. Of course, someone could



extract it by taking a screenshot of it in the PDF, but they could also scan or
photograph a paper document to get the signature, so there’s no real
difference in security either way.

Tip: If you use Apple Mail, these signatures are available when marking up
outgoing attachments. For details, see Joe Kissell’s Take Control of Apple
Mail. Plus, your signatures sync to other Macs if you have iCloud Keychain
turned on in System Settings > Your Name > iCloud > Passwords &
Keychain (Ventura or later) or System Preferences > iCloud > Keychain
(Monterey or earlier)—see Joe’s Take Control of iCloud for more.

https://www.takecontrolbooks.com/apple-mail/?pt=INTERNAL
https://www.takecontrolbooks.com/icloud/?pt=INTERNAL


Manipulate PDFs

We’ve covered how to add text, shapes, signatures, and more to a page in
PDF, but what if you want to work at an overview level to re-organize or
format the pages in a PDF? Whether it’s Rearranging, Deleting, and Adding
Pages; Rotating Pages; Cropping Pages; or even Changing PDF Color,
Preview makes it possible.

Rearranging, Deleting, and Adding
Pages
If you don’t like the order of pages in your PDF, you can change it. You can
also delete pages, copy them to another PDF, and even add a new blank
page or a page from a scanner.

TidBITS editor in chief Tonya Engst does this sort of thing all the time with
multi-page scanned documents, such as scans of the paperwork that she
receives for each payroll. She feeds the pile of papers into her Fujitsu
ScanSnap scanner and ends up with one big PDF. In that PDF, she
occasionally finds that a page was scanned out of order, and she usually
wants to delete a few pages that represent the blank backs of scanned sheets.
Plus, she copies the “payroll stub” page for one employee into a separate
document so that she can send it to that person electronically. Your needs
are probably different, but if you scan documents regularly, Preview can
help you manipulate your PDFs.

To start, choose a view where each page in the document appears as a
thumbnail:



Thumbnails: Choose View > Thumbnails (⌘-Option-2) to see the
thumbnails in the sidebar. This is a better choice for a short document
or a document where the changes that you want to make are all in the
same short stretch of pages.

Contact Sheet: Choose View > Contact Sheet (⌘-Option-6). Because
you can see many pages more quickly in this grid view, it’s a better
choice for longer documents or for situations where you need to work
with more pages as you fix up your document. If you work in this view,
note that you can press ⌘-= or ⌘– (we think of these commands as
⌘-Plus and ⌘-Minus) to make the thumbnails tiny (thus showing
more in the window at once) or to make them nearly large enough to
read (which makes differentiating between similar pages easier).

This is nearly identical to how you can rearrange images in a Contact
Sheet. See Viewing a Contact Sheet.

Once you’re looking at Thumbnails view or Contact Sheet view, it’s time to
make some changes:

Rearrange pages: Drag a page thumbnail to a different place in the
sidebar (or the contact sheet) to reorder the pages as you like. As you
drag, thumbnails of other pages shift out of the way to help you drop
the page in the desired spot.

Delete pages: Select one or more thumbnails (by Shift-clicking for a
contiguous selection or ⌘-clicking for a discontiguous selection) and
press Delete.

Copy a page to another PDF: With two or more Preview document
windows visible, drag one or more thumbnails from one PDF
document to another to add copies of their pages to the destination
document. The dragged pages are added in the location where you drop



them. This is particularly handy for combining scanned single-page
PDFs into a single file.

Merge PDFs: Drop a PDF from the Finder into the Thumbnails view
or Contact Sheet view of an open PDF to merge the two.

Tip: We find it easiest to manipulate our PDFs when we can see all the pages
at once. For that reason, we usually use Contact Sheet view for this task
unless we’re just swapping the position of two pages, which can be done
easily in Thumbnails view in the sidebar.

You can also add a page to a PDF from the Edit > Insert submenu.
Commands there let you add one or more pages from a file, or a blank page
to which you can then add text and graphics manually. When using Edit >
Insert > Page from File, you can add any graphic Preview can open as a
single page, and if you select a multi-page PDF, all of its pages are added.

Rotating Pages
Let’s say you have scanned some paper documents to PDF, but they came
out upside down. Although that could have been fixed by clicking the
appropriate orientation button when scanning (see Importing from a
Scanner), Preview can fix it after the fact too.

Your first step is to switch Preview into Thumbnails view or Contact Sheet
view, as we explained earlier in this chapter. You can select just one
thumbnail to rotate a single page or select more than one to rotate them all
in one step. In fact, you can even select all the thumbnails at once by
choosing Edit > Select All (or pressing ⌘-A).



To rotate counter-clockwise, click the Rotate  button on the toolbar, or
Option-click the button to rotate in the opposite direction. You may have to
click more than once to reach your desired rotation. Or, choose Tools >
Rotate Left or Tools > Rotate Right, that’s ⌘-L or ⌘-R.

In Figure 90, for purposes of illustration, we scanned four pages. We
rotated the second by 90º to the left (one click of the Rotate button), the
third by 180º (two clicks), and the fourth one by 270º to the left (three
clicks).

Figure 90: Preview can rotate pages in a PDF to correct for incorrect
scanning orientation.

In the real world, when we accidentally scan an entire document upside
down, we select all the pages with ⌘-A and then press ⌘-R—and do that
again—to flip them right side-up.

Cropping Pages
Just as with images, you can crop pages in a PDF. For example, you might
want to remove overly large margins to make a document easier for you to
read on screen.

Warning: Preview only hides cropped content instead of deleting it, and
there’s no guarantee that other PDF viewers will honor the crop. It’s probably
most useful if you’re trying to make a document easier to read in Preview
itself, by removing unnecessary margins. Don’t use this feature if you
collaborate with someone using a different PDF viewer.



To crop a single page, use the Rectangular Selection  tool on the Markup
toolbar (or choose Tools > Rectangular Selection) to select the area you
want to keep and then click Crop on the Markup toolbar (or choose Tools >
Crop, ⌘-K). Preview hides everything outside that area.

To crop multiple PDF pages, reveal the sidebar thumbnails by choosing
View > Thumbnails, and then use the Rectangular Selection tool on a page
to select the area you want to keep after cropping (in Figure 91, we’re
eliminating the extra white space at the top of each scanned page). Once
you’ve made your selection, click the current page in the sidebar and press
⌘-A to select all the pages. Click the Crop button on the Markup toolbar
(⌘-K) to crop every page in the document to the selected dimensions.

Figure 91: Here you see the original PDF with extra white space at the top
(left) as well as another version where we’ve cropped out the spurious
white space on each page, making for a tighter viewing area (right).

Changing PDF Color
The Mac’s graphic engine, Quartz, is based on PDF, so as a bonus, when
you export a PDF by choosing File > Export, you have the option of
applying a Quartz filter in order to adjust the look of the exported document
(Figure 92).



Figure 92: When exporting as PDF, you can choose between several
Quartz filters that change the look of the resulting file.

The Quartz filters that change your PDF’s color are Black & White, Blue
Tone, Gray Tone, and Sepia Tone. They do what you’d expect, making the
page black-and-white or turning all colors—images and text—into shades of
blue, gray, or sepia (Figure 93).

Figure 93: The Sepia Quartz filter applies an old-timey effect to the
exported PDF.

Lightness Increase and Lightness Decrease apply to all colors as well, so
their effects are relatively subtle in photos, but can make a large difference
to colored text (Figure 94).



Figure 94: The Lightness Increase and Lightness Decrease Quartz filters
can have a subtle, but far-reaching, impact on the entire document.



Create PDFs

While Preview can’t create a PDF entirely from scratch, like apps such as
Adobe InDesign and Apple’s Pages, it does offer some capabilities for
generating new PDFs from existing content. Preview, like most Mac apps,
can “print” to a PDF file. Additionally, you can create a PDF by converting
one or more images to a PDF (see Convert and Export), Importing from the
Clipboard, or Importing from a Scanner.

Printing to PDF
You can “print” any document from nearly any app to a PDF. This system-
wide feature on the Mac is just like printing, except that instead of a printing
marks on paper, the Mac creates a graphical image in PDF format of what
that paper would look like. Because it’s a graphic, any text is “understood”
in the file only as an image—the words aren’t stored as individual
characters that can be edited and searched. In this way, what you see on the
screen becomes an exact visual representation of what the printed document
would look like.

The Mac’s print-to-PDF feature has a few special options: you can add
metadata, such as keywords, to the PDF, and you can specify a password for
opening the file, as well as a permissions password to restrict whether the
PDF can be copied from or printed (or both). (Flip back to Restricting PDFs
for more about what activities the passwords restrict.)

One use of print-to-PDF that our editor has used frequently is assembling
meeting minutes for the PTA of her son’s school. As secretary, she would
type up the minutes in Apple’s Pages and ask speakers to give her computer
files or paper documents of any supplemental materials, like presenter slides



or handouts from the school nurse. She’d then print the Pages document to
PDF, scan any paper documents to PDF, and combine everything into one
final PDF document that she could email to parents, plus post on the PTA
website. Pretty much any computer can easily download and display a PDF,
so this system worked well for publishing the meeting minutes.

Also, if you are making a brochure or poster, printing to PDF is a great way
to make a version of the file that can be shared online.

When Printing to PDF Is Better than Exporting to PDF

Why print to a PDF in Preview, when the program has built-in PDF export
capabilities (described in Convert and Export)? Notably, the print-to-PDF
method offers more metadata and security options than Preview’s export
feature. More on those shortly.

Printing to PDF from within Preview can also solve a Preview problem we’ve
seen on occasion: you mark up a document in Preview, save it, send it to a
collaborator, and they don’t see your highlights. We don’t know why this
might happen—PDF is a standard file format, but that doesn’t mean every
app implements it correctly—but printing to PDF appears to cause the
highlights to show up properly.

Here’s how to print to PDF:

1. Open any document in Preview (or whatever app you normally open it
in; printing to PDF is a system-wide feature).

2. Choose File > Print.

3. In the Print dialog, click the PDF pop-up menu in the lower-left corner
(Figure 95) and choose Save as PDF.



Figure 95: To create a PDF from the Print dialog, use the pop-up menu in
the lower-left corner of the Print dialog. In this case, we want to add a
document open password.

4. In the Save dialog that appears, enter a filename and choose a
destination for your file, but don’t click Save yet.

5. Optionally, fill in title, author, subject, and keyword metadata (Figure
96). This standard PDF metadata becomes visible in Preview’s
Inspector window (see Examining PDF Metadata), in other PDF and
document cataloging apps, and even in the Finder’s Get Info dialog. It
can also provide better Spotlight search results.

Figure 96: When printing to PDF, you can add metadata, something that’s
not possible with Preview’s built-in PDF export feature.



6. Optionally, click the Security Options button to set both the document
open (top fields) and the permissions passwords (bottom fields) for the
PDF, and choose whether the permissions password restrict changes,
printing, or both (Figure 97). Click OK to close the PDF Security
Options dialog.

Figure 97: When you print to a PDF, you’re offered more control over the
resulting file’s security options. The top fields control the document open
password and the bottom fields are for the permissions password.

Note: If you’ve selected “Require password to copy text, images and other
content,” then if you try to copy a selection from it, print it, or export,
Preview prompts you to enter the password. If you attempt to annotate
the PDF, Preview doesn’t ask for a password but instead makes what
appears to be an editable duplicate. However, when you save the
annotated PDF, all of its original content disappears, leaving just your
additions.

7. Click Save to create your PDF.

Your Mac saves the PDF in the location you specified, with the metadata
and security options that you set during the save.



Other Items in the Print Dialog’s PDF Menu

The Print dialog’s PDF pop-up menu also has an Open PDF in Preview
command, which just creates an untitled PDF and opens it in Preview; you
can’t set any metadata or security options. It’s useful for previewing how a
document will print or making a PDF quickly. Once created, you can save it
like any other file, with Preview’s standard Quartz filters and encryption
options.

Farther down in the PDF pop-up menu, you may see a bunch of printing
workflows that various apps have installed for you. They make it easy, for
instance, to print a document to PDF and send it with Messages in one step.

Other Ways to Make PDFs
Besides printing to PDF, which lets you make a PDF from nearly any
document on your Mac—and which we covered earlier in this chapter,
here’s a roundup of other methods of making a new PDF with Preview:

Import PDF pages from the clipboard: Open a PDF in Preview,
select one or more thumbnails in the sidebar (see Navigating PDFs via
the Sidebar), and then press ⌘-C to put the selected page(s) on the
clipboard. Now, choose File > New from Clipboard to create a new
untitled PDF document with your selection.

Import part of a PDF page from the clipboard: Use the Rectangular
Selection  tool (see Copying Images from PDFs) to select a section of
a PDF, copy it, and then choose File > New from Clipboard to create a
PDF of that selection.

Note: For more about making PDFs from the clipboard, see Importing
from the Clipboard, earlier.

Scan documents: Preview can plug into the Continuity Camera
feature, using your iPhone or iPad to scan a document to PDF. It can



also interact with your scanner, enabling you to create a new PDF
based on a scan of a paper document. See Importing from an iPhone or
iPad and Importing from a Scanner, earlier, for directions.

Tip: Once you have a PDF with at least one page in it, remember that you
can copy pages between documents, dragging thumbnails from one PDF’s
sidebar into the sidebar of another. It’s handy way to combine multiple
scanned single-page PDFs into one document. See Rearranging, Deleting,
and Adding Pages.

Convert an image to PDF: Anything you can open in Preview, you
can convert to PDF using File > Export to PDF. See Convert and
Export.
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