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   Introduction
 
   
NX as a topic of learning is vast, and having a wide scope. It is one of the world’s most advanced and highly integrated CAD/CAM/CAE product. NX delivers a great value to enterprises of all sizes by covering the entire range of product development. It speeds up the design process by simplifying complex product designs.
 
   
This tutorial book provides a systematic approach for users to learn NX 10. It is aimed for those with no previous experience with NX. However, users of previous versions of NX may also find this book useful for them to learn the new enhancements. The user will be guided from starting a NX 10 session to constructing parts, assemblies, and drawings. Each chapter has components explained with the help of various dialogs and screen images.
 
   
              
 
   Scope of this Book
 
   
This book is written for students and engineers who are interested to learn NX 10 for designing mechanical components and assemblies, and then generate drawings. 
 
   
This book provides a systematic approach for learning NX 10. The topics include Getting Started with NX 10, Basic Part Modeling, Constructing Assemblies, Constructing Drawings, Additional Modeling Tools, and Sheet Metal Modeling. 
 
   
Chapter 1 introduces NX 10. The user interface, terminology, mouse functions, and shortcut keys are discussed in this chapter.
 
   
Chapter 2 takes you through the creation of your first NX model. You construct simple parts.
 
   
Chapter 3 teaches you to construct assemblies. It explains the Top-down and Bottom-up approaches for designing an assembly. You construct an assembly using the Bottom-up approach.
 
   
Chapter 4 teaches you to generate drawings of the models constructed in the earlier chapters. You will also learn to generate exploded views, and part list of an assembly.
 
    
 
   Chapter 5: In this chapter, you will learn the tools needed to create 2D sketches.
 
   
Chapter 6: In this chapter, you will learn additional modeling tools to construct complex models.
 
    
 
   Chapter 7: This chapter helps you to create, edit, and use expressions in your designs.
 
   
Chapter 8: introduces you to NX Sheet Metal design. You will construct a sheet metal part using the tools available in the NX Sheet Metal environment.
 
    
 
   Chapter 9: teaches you to create an assembly using Top-down design approach.
 
    
 
   Chapter 10: teaches you to add dimensions and annotations to your drawings.
 
    
 
   Chapter 11: introduces you to Finite Element Analysis.
 
    
 
    
 
   

 
  
 
  


 
 
   
   Chapter 1: Getting Started
 
   
In this chapter, you will learn some of the most commonly used features of NX. Also, you will learn about the user interface.
 
   
In NX, you construct 3D parts and use them to generate 2D drawings and 3D assemblies.
 
   
NX is Feature Based. Features are shapes that are combined to build a part. You can modify these shapes individually. 
 
                 [image: ]
 
   Most of the features are sketch-based. A sketch is a 2D profile and can be extruded, revolved, or swept along a path to construct features.
 
    [image: ] 
 
   NX is parametric in nature. You can specify standard parameters between the elements of a part. Changing these parameters changes the size and shape of the part. For example, see the design of the body of a flange before and after modifying the parameters of its features
 
    
 
    [image: ] 
 
   Starting NX
 
    
    	Click the Start button on the Windows taskbar.
 
    	Click the arrow pointing downward.
 
    	Click Siemens NX 10.0 > NX 10.0. 
 
    	Click the New button.
 
    	On the New dialog, click Templates > Model.
 
    	Click the OK button
 
   
 
    [image: ] 
 
                  
 
   Notice these important features of the NX window.
 
                  
 
   User Interface
 
   Various components of the user interface are discussed next.
 
    
 
   Quick Access Toolbar
 
   This is located at the top left corner of the window. It consists of the commonly used commands such as Save, Undo, Redo, Copy, and so on.
 
    
 
   File Menu
 
   The File Menu appears when you click on the File icon located at the top left corner of the window. The File Menu consists of a list of self-explanatory menus. You can see a list of recently opened documents under the Recently Opened Parts section. You can also switch to different applications of NX. 
 
   Ribbon
 
   A ribbon is a set of tools, which are used to perform various operations. It is divided into tabs and groups. Various tabs of the ribbon are discussed next.
 
    
 
   Home tab
 
   This ribbon tab contains the tools such as New, Open, and Help, and so on. 
 
    [image: ] 
 
   Home tab in the Model template
 
   This ribbon tab contains the tools to construct 3D features. 
 
    
 
    [image: ] 
 
   View tab
 
   This ribbon tab contains the tools to modify the display of the model and user interface.
 
    [image: ] 
 
   Analysis tab
 
   This ribbon tab has the tools to measure the objects. It also has tools to analyze the draft, curvature, and surface.
 
    [image: ] 
 
   Home tab in Sketch Task environment
 
   This ribbon tab contains all the sketch tools. It is available in a separate environment called Sketch Task environment. The Sketch Task environment is activated when you activate a Feature modeling tool and click on a planar face or Datum plane.
 
    [image: ] 
 
   Tools tab
 
   This ribbon tab contains the tools to create expressions, part families, movies, fasteners.
 
    
 
    [image: ] 
 
    
 
   Render tab
 
   This ribbon tab contains the tools to generate photorealistic images.
 
    
 
    [image: ] 
 
    
 
   Application tab
 
   This ribbon tab contains the tools to start different applications such as Assemblies, Sheet Metal, Drafting, and so on.
 
    
 
    [image: ] 
 
    
 
   Assemblies tab
 
   This tab contains the tools to construct an assembly. It is available in the Assembly template.
 
    [image: ] 
 
   Drafting environment ribbon
 
   In the Drafting Environment, you can generate orthographic views of the 3D model. The ribbon tabs in this environment contain tools to generate 2D drawings. 
 
    [image: ] 
 
    [image: ] 
 
   Sheet Metal ribbon 
 
   The tools in this ribbon are used to construct sheet metal components.
 
    [image: ] 
 
   Some tabs are not visible by default. To display a particular tab, right-click on the ribbon and select it from the list displayed.  
 
   
[image: ] 
 
   You can also add a ribbon tab by opening the Customize dialog. Click the down arrow located at the bottom right corner of the ribbon, and select Customize. On the Customize dialog, click on different tab and select/deselect the options.
 
    
 
    [image: ] 
 
    
 
   Ribbon Groups and More Galleries
 
   The tools on a ribbon are arranged in various groups depending upon their use. Each group has a More Gallery, which contain additional tools.
 
    
 
    [image: ] 
 
    
 
   You can add more tools to a ribbon group by clicking the arrow located at the bottom right corner of a group.
 
    [image: ] 
 
    
 
   Top Border Bar
 
   This is available below the ribbon. It consists of all the options to filter the objects that can be selected from the graphics window.
 
    
 
    [image: ] 
 
    
 
   Menu 
 
   Menu is located on the Top Border Bar. It consists of various options (menu titles). When you click on a menu title, a drop-down appears. You can select the required option from this drop-down.
 
    [image: ] 
 
   
Status bar
 
   This is available below the graphics window. It displays the prompts and the action taken while using the tools.
 
    
 
    [image: ]               
 
   
Resource Bar
 
   This is located at the left side of the window. It contains all the navigator windows such as Assembly Navigator, Constraint Navigator, Part Navigator, and so on. 
 
   
Part Navigator
 
   Contains the list of operations carried while constructing a part.
 
    
 
    [image: ]
               
 
   Roles Navigator
 
   The Roles Navigator (click the Roles tab on the Resource Bar) contains a list of system default and industry specific roles. A role is a set of tools and ribbon tabs customized for a specific application. For example, the CAM Express role can be used for performing manufacturing operations.  This textbook uses the Default role.
 
   
[image: ] 
 
    
 
   The Touch Panel and Touch Tablet roles help you to work with a Multi-touch screen.
 
    
 
   Touch Panel
 
    
 
    [image: ] 
 
    
 
   Touch Tablet
 
    
 
    [image: ] 
 
    
 
   Dialogs
 
   When you execute any command in NX, the dialog related to it appears. The dialog consists of various options. The following figure shows various components of the dialog.
 
    [image: ] 
 
   
This textbook uses the default options in the dialog. If you have made any changes on the dialog, click the Reset button to display the default options.
 
   
Mouse Functions
 
   Various functions of the mouse buttons are discussed next.
 
    
 
   Left Mouse button (MB1)
 
   When you double-click the left mouse button (MB1) on an object, the dialog related to the object appears. Using this dialog, you can edit the parameters of the objects.
 
   
Middle Mouse button (MB2)
 
   Click this button to execute the OK command.
 
   
Right Mouse button (MB3)
 
   Click this button to display the shortcut menu.    
 
                  
 
    [image: ]
The other functions with combination of the three mouse buttons are given next.
 
                  [image: ]
 
    
 
    [image: ] 
 
   
Color Settings
 
   To change the background color of the window, click View > Visualization > More > Edit Background; the Edit Background dialog appears. Click the Plain option to change the background to plain. Click on the color swatches; the Color dialog appears. Change the background color and click OK twice. 
 
    
 
    [image: ] 
 
    
 
   Shortcut Keys
 
    
 
    
    
      
      	 CTRL+Z                         
  
      	 (Undo)
  
     
 
      
      	 CTRL+Y                        
  
      	 (Repeat)
  
     
 
      
      	 CTRL+S                        
  
      	 (Save)
  
     
 
      
      	 F5     
  
      	 (Refresh)
  
     
 
      
      	 F1   
  
      	 (NX Help)
  
     
 
      
      	 F6 
  
      	 (Zoom)
  
     
 
      
      	 F7  
  
      	 (Rotate)
  
     
 
      
      	 CTRL+M                        
  
      	 (Starts the Modeling environment)
  
     
 
      
      	 CTRL+SHIFT+D            
  
      	 (Starts the Drafting environment)
  
     
 
      
      	 CTRL+SHIFT+M                
  
      	 (Starts the NX Sheet Metal environment)
  
     
 
      
      	 CTRL+ALT+M                
  
      	 (Starts the Manufacturing environment)
  
     
 
      
      	 X 
  
      	 (Extrude)
  
     
 
      
      	 CTRL+1                         
  
      	 (Customize)
  
     
 
      
      	 CTRL+D                        
  
      	 (Delete)
  
     
 
      
      	 CTRL+N                        
  
      	 (New File)
  
     
 
      
      	 CTRL+O                        
  
      	 (Open File)
  
     
 
      
      	 CTRL+P                        
  
      	 (Plot)
  
     
 
    
   
 
    
 
   
              
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
    
 
  
 
  


 
 
   
   Chapter 2: Modeling Basics
 
    
 
   This chapter takes you through the creation of your first NX model. You construct simple parts: 
 
                  
 
   In this chapter, you will: 
 
                  
 
    
    	Construct Sketches       
 
    	Construct a base feature       
 
    	Add another feature to it        
 
    	Construct revolved features         
 
    	Apply draft                
 
   
 
    
 
   
 
  
 
   
 
   
   TUTORIAL 1
 
   This tutorial takes you through the creation of your first NX model. You construct the Disc of an Old ham coupling: 
 
    [image: ] 
 
  
 
   
 
   
   Starting a New Part File
 
    
    	To start a new part, click the New [image: ] button on ribbon; the New dialog appears.
 
    	The Model template is the default selection, so click OK; a new model window appears.
 
   
 
                  
 
   Starting a Sketch
 
    
    	To start a new sketch, click the Sketch button on the Direct Sketch group; the Create Sketch dialog appears.
 
   
 
    
 
    [image: ] 
 
    
 
    
    	Select the XZ plane.
 
   
 
    [image: ] 
 
    
    	Click the OK button on the Create Sketch dialog; the sketch starts.
 
   
 
    
 
   The first feature is an extruded from a sketched circular profile. You will begin by sketching the circle.
 
    
 
    
    	Click Circle[image: ]on the Direct Sketch group.
 
    	Move the pointer to the sketch origin, and then click. 
 
    	Drag the pointer and click to draw a circle.
 
   
 
    [image: ] 
 
    
    	Press ESC to quit the tool.
 
   
 
   
Adding Dimensions
 
   In this section, you will specify the size of the sketched circle by adding dimensions.  
 
   
Note: You may notice that dimensions are applied automatically. However, they do not constraint the sketch.
 
   
As you add dimensions, the sketch can attain any one of the following three states:
 
   
Fully Constrained sketch: In a fully constrained sketch, the positions of all the entities are fully described by dimensions or constraints or both. In a fully constrained sketch, all the entities are dark green color.
 
   
Under Constrained sketch: Additional dimensions or constraints or both are needed to completely define the geometry. In this state, you can drag the sketch elements to modify the sketch. An under constrained sketch element is in maroon color.
 
   
Over Constrained sketch: In this state, an object has conflicting dimensions or relations or both. An over constrained sketch entity is grey. The over constraining dimensions are in red color.
 
    
 
    
    	Double-click on the dimension displayed on the sketch; the Dimension edit box appears.
 
    	To change the dimension to 100 mm, type a new value, and then press Enter.
 
    	Press Esc to quit the Dimension tool.
 
   
 
   
To display the entire circle at a full size and to center it in the graphics area, use one of the following methods:
 
    
 
    
    	Click Fit [image: ]on Top Border Bar.
 
    	On the ribbon, click View > Orientation > Fit.
 
   
 
    
 
    
    	On the ribbon, click Home > Direct Sketch > Finish Sketch[image: ].
 
    	To change the view to isometric, click Orient View Drop-down > Isometric on the Top Border Bar.
 
   
 
                       [image: ]
 
   You can use the buttons on the Orient View Drop-down on the Top Border Bar to set the view orientation of the sketch, part, or assembly.
 
   
Constructing the Base Feature
 
   The first feature in any part is called the base feature. You construct this feature by extruding the sketched circle.
 
    
 
    
    	On the ribbon, Home > Feature > Extrude[image: ]; the Extrude dialog appears.
 
    	Click on the sketch.
 
    	Type-in 10 in the End box attached to the preview.
 
    	To see how the model would look if you have extruded the sketch in the opposite direction, click Reverse Direction [image: ]button in the Direction section. Again, click on it to extrude the sketch in the front direction.
 
    	Ensure that Body Type in Settings group is set to Solid.
 
   
 
                  [image: ]
 
    
    	Click OK to construct the extrusion.
 
   
 
   
Notice the new feature, Extrude, in the Part Navigator.
 
    
 
    [image: ]                    
 
   To magnify a model or change its orientation in the graphics area, you can use the Orientation tools on the View tab.
 
    
 
    [image: ] 
 
   
Click Fit to display the part full size in the current window.
 
   
Click Zoom[image: ], and then drag the pointer to draw a rectangle; the area in the rectangle zooms to fill the window.
 
   
Click Zoom In/Out[image: ], and then drag the pointer. Dragging up zooms out; dragging down zooms in. Note that this command is available on the More gallery.
 
   
Click a vertex, an edge, or a feature, and then click Fit View to Selection[image: ]; the selected item zooms to fill the window.
 
   
To display the part in different modes, click the buttons in the Style group on the View tab. 
 
    [image: ]               
 
    
 
    [image: ] 
 
    [image: ] 
 
    [image: ] 
 
    [image: ] 
 
    [image: ] 
 
    
 
   The default display mode for parts and assemblies is Shaded with Edges. You may change the display mode whenever you want.
 
   
Adding an Extruded Feature
 
   To construct additional features on the part, you need to sketch on the model faces or planes, and then convert them into features.
 
    
 
    
    	Click Static Wireframe [image: ]on the View tab.
 
    	Click Sketch on the Direct Sketch group.
 
    	Click on the front face of the part to select it, and then click OK.
 
    	Click Direct sketch > More Curve > Project Curve [image: ]on the ribbon; the Project Curve dialog appears.
 
    	Click on the circular edge.
 
   
 
    [image: ] 
 
    
    	Click OK on the Project Curve dialog; the circular edge projects onto the sketch plane.
 
    	Click Line [image: ]on the Direct Sketch group.
 
    	Click on the circle to specify the first point of the line.
 
   
 
    [image: ] 
 
    
    	Move the pointer towards right.
 
    	Click on the circle; a line is drawn.
 
   
 
    [image: ] 
 
    
    	Draw another line above the previous line.
 
   
 
    [image: ]               
 
   Adding Constraints and Dimensions to the Sketch
 
   To establish the location and size of the sketch, you have to add the necessary constraints and dimensions.
 
    
 
    
    	Select the lower horizontal line.
 
    	On the Shortcuts toolbar, click Horizontal[image: ].
 
    	On the ribbon, click Direct Sketch > More gallery > Sketch Constrains > Make Symmetric[image: ].
 
    	Select the first and second lines.
 
    	Select the X-axis as the centerline; the two lines become symmetric about the X-axis.
 
   
 
    [image: ] 
 
    
    	Click Close on the Make Symmetric dialog.
 
   
 
    
 
   Adding Dimensions
 
    
    	Double-click on the dimension displayed in the sketch.
 
    	Type-in 12 in the box displayed.
 
    	Click Close on the dialog.
 
   
 
   
Trimming Sketch Entities
 
    
    	Click Trim Recipe Curve [image: ]on the Direct Sketch group.
 
    	Click on the projected element.
 
    	Click on the two horizontal lines.
 
    	On the Trim Recipe Curve dialog, click Discard under the Region section.
 
    	Click OK to trim the projected elements.
 
   
 
    [image: ] 
 
    
    	Click Finish Sketch on the Direct Sketch group.
 
    	To change the view to isometric, click View > Orientation > Isometric.
 
   
 
   
Extruding the Sketch
 
    
    	Click on the sketch, and then click Extrude on the Shortcuts toolbar; the Extrude dialog appears.
 
   
 
    [image: ] 
 
    
    	Type-in 10 in the End box attached to the preview.
 
   
 
    [image: ] 
 
    
    	Click OK to construct the extrusion.
 
    	To hide the sketch, click View> Show and Hide[image: ].
 
    	On the Show and Hide dialog, click Hide in the Sketches row; the sketches are hidden.
 
   
 
    
 
    [image: ] 
 
    
 
   Adding another Extruded Feature
 
    
    	Draw a sketch on the back face of the base feature (Use the Profile command to create the lines, and then project the outer circular edge. Use the Trim Recipe Curve command to trim the projected curve).
 
   
 
    [image: ]
You can use the Rotate [image: ]button from the View tab to rotate the model.
 
    
 
    
    	Extrude the sketch up to 10 mm thickness.
 
   
 
   
To move the part view, click View > Orientation > Pan, then drag the part to move it around in the graphics area.
 
    
 
    
    	Click View > Style > Shaded with Edges on the ribbon.
 
   
 
                  [image: ]
 
    
 
   Saving the Part
 
    
    	Click Save [image: ]on the Quick Access Toolbar; the Name Parts dialog appears.
 
    	Type-in Disc in the Name box and click the Folder button.
 
    	Browse to the NX 10/C2 folder and then click the OK button twice.
 
   
 
   
Note:
 
   *.prt is the file extension for all the files constructed in the Modeling, Assembly, and Drafting environments of NX.
 
   
TUTORIAL 2
 
   In this tutorial, you construct a flange by performing the following:
 
    
 
    
    	Constructing a revolved feature
 
    	Constructing a cut features
 
    	Adding fillets
 
   
 
                  
 
   Open a New Part File
 
    
    	To open a new part, click File > New on the ribbon; the New dialog appears.
 
    	The Model is the default selection, so click OK; a new model window appears.
 
   
 
   
Sketching a Revolve Profile
 
   You construct the base feature of the flange by revolving a profile around a centerline.
 
    
 
    
    	Click the Sketch button on the Direct Sketch group.
 
    	Select the YZ plane.
 
    	Click the OK button; the sketch starts.
 
    	Click Profile [image: ]on the Direct Sketch group.
 
    	Draw a sketch similar to that shown in figure. Press Esc.               [image: ]
 
    	On the ribbon, click Direct Sketch > More gallery > Sketch Constraints > Geometric Constraints[image: ]. 
 
    	Click OK on the message box.
 
    	On the Geometric Constraints dialog, click Collinear[image: ].
 
    	Under the Geometry to Constrain section, check Automatic Selection Progression.
 
    	Click on the line 1 and the Y-axis to make them collinear.
 
   
 
    [image: ] 
 
    
    	Click Rapid Dimension [image: ]on the Direct Sketch group.
 
    	Select the X-axis and Line 6; a dimension appears.
 
    	Place the dimension and type-in 15 in the dimension box.
 
    	Press Enter key.
 
    	Select the X-axis and Line 4; a dimension appears.
 
    	Set the dimension to 30.
 
    	Select the X-axis and Line 2; a dimension appears.
 
    	Set the dimension to 50 mm.
 
    	Create a dimension between the Y-axis and Line 3.
 
    	Set the dimension to 20 mm.
 
    	Create a dimension of 50 mm between Y-axis and Line 5.
 
    	Close the Rapid Dimension dialog.
 
   
 
    [image: ]               
 
    
    	Click Finish Sketch on the Direct Sketch group.
 
    	To change the view to isometric, click Isometric on the View tab.
 
   
 
   
Constructing the Revolved Feature
 
    
    	On the ribbon, click Home > Feature > Extrude > Revolve; the Revolve dialog appears.
 
   
 
    [image: ] 
 
    
    	Click on the sketch.
 
    	Click on Specify Vector in the Axis group; a vector triad appears.
 
    	Click on the Y-axis of the triad.
 
   
 
    [image: ] 
 
    
    	Click on the origin point; the preview of the revolved feature appears.
 
   
 
    [image: ] 
 
    
    	Type-in 360 in the End box attached to the preview.
 
    	Click OK to construct the revolved feature.
 
   
 
    [image: ] 
 
    
 
   Constructing the Cut feature
 
    
    	Click Extrude on the Feature group.
 
    	Rotate the model geometry and click the back face of the part; the sketch starts.
 
    	Construct a sketch, as shown in figure (Use the Profile command to create the lines, and then project the outer circular edge. Use the Trim Recipe Curve command to trim the projected curve).
 
   
 
    [image: ] 
 
    
    	Click Finish on the Sketch group.
 
    	Enter 10 in the End box attached to the preview. 
 
    	Click Reverse Direction [image: ]in the Direction section.
 
    	Select Subtract in the Boolean section.
 
   
 
    [image: ] 
 
    
    	Click OK to construct the cut feature.
 
   
 
    [image: ] 
 
   Adding another Cut-out 
 
    
    	Draw a sketch on the front face of the model geometry (Use the Profile command to create the lines, and then project the inner circular edge. Use the Trim Recipe Curve command to trim the projected curve. Also, add dimensions).
 
   
 
    [image: ] 
 
    
    	Finish the sketch.
 
    	Click Extrude on the Feature group.
 
    	Click on the sketch.
 
    	On the Extrude dialog, select End > Through All under the Limits section.
 
    	Click Reverse Direction in the Direction section.
 
    	Select Subtract in the Boolean group.
 
    	Click OK to construct the cut-out feature.
 
    	To change the view to isometric, click Isometric on the View tab.
 
   
 
    
 
    [image: ] 
 
   Adding Edge blend
 
    
    	Click Home > Feature > Edge Blend[image: ]; the Edge Blend dialog appears.
 
    	Click on the inner circular edge and set Radius 1 to 5.
 
    	Click OK to add the blend.
 
   
 
                 [image: ]
 
    
 
   Saving the Part
 
    
    	Click File > Save > Save; the Name Parts dialog appears.
 
    	Type Flange and click the Folder button.
 
    	Browse to NX 10/C2 folder and then click OK button twice.
 
    	Click File > Close > All Parts.
 
   
 
   
TUTORIAL 3
 
   In this tutorial, you construct a Shaft by performing the following:
 
    
 
    
    	Constructing a revolved feature
 
    	Constructing a cut feature
 
   
 
   
Opening a New Part File
 
    
    	To open a new part, click the New button on the Standard group.
 
   
 
    
 
    
    	Select the Model template and click OK; a new model window appears.
 
   
 
   
Constructing the Revolved Feature
 
    
    	Click Extrude > Revolve on the Feature group.
 
    	Click the Sketch Selection [image: ]icon under the Section section of the Revolve dialog.
 
    	Click on the YZ plane to select it, and then click OK; the sketch starts.
 
    	On the ribbon, click Home > Curve > Rectangle[image: ].
 
    	Select the origin point of the sketch.
 
    	Move the pointer toward top left corner and click.
 
    	Add dimensions to the sketch, as shown in figure. 
 
   
 
    [image: ] 
 
    
    	Click Finish on the Sketch group.
 
    	Click on the Y-axis of the triad.
 
    	Click on the origin point; the preview appears.
 
    	Click OK to construct the revolved feature.
 
   
 
                  
 
   Creating Cut feature
 
    
    	Construct a sketch on the front face of the model geometry (Use the Profile command to create the lines, and then project the circular edge. Use the Trim Recipe Curve command to trim the projected curve. Also, add dimensions).
 
   
 
    [image: ] 
 
    
    	Finish the sketch.
 
    	Click Extrude on the Feature group.
 
    	Click on the sketch.
 
    	Type-in 55 in the End box.
 
    	Click Reverse Direction in the Direction section.
 
    	Select Subtract in the Boolean group.
 
   
 
    [image: ] 
 
    
    	Click OK to construct the cut feature.
 
   
 
    [image: ] 
 
   
Saving the Part
 
    
    	Click File > Save > Save; the Name Parts dialog appears.
 
    	Type Shaft in the Name box and click Folder button.
 
    	Browse to NX 10/C2 folder and then click OK button twice.
 
    	Click File > Close > All Parts.
 
   
 
   
TUTORIAL 4
 
   In this tutorial, you construct a Key by performing the following:
 
    
 
    
    	Constructing a Block
 
    	Applying draft
 
   
 
    
 
   Constructing Extruded feature
 
    
    	Open a new part file.
 
    	On the ribbon, click Home > Feature > More > Design Feature > Block[image: ].
 
    	On the Block dialog, select Type > Origin and Edge Lengths.
 
    	Type-in 6, 50, and 6 in the Length (XC), Width (YC), and Height (ZC) boxes, respectively.
 
    	Click on the origin point of the datum coordinate system.
 
   
 
    [image: ] 
 
    
    	Click OK to construct the block.
 
   
 
    [image: ] 
 
    
 
   Applying Draft
 
    
    	Click Draft [image: ]on the Feature group.
 
    	On the Draft dialog, select Type > From Plane or Surface.
 
    	Click on Y-axis to specify vector.
 
   
 
    [image: ] 
 
    
    	Select front face as the stationary face.
 
   
 
    
 
    [image: ] 
 
    
    	Click Select Face in the Faces to Draft section.
 
    	Select the top face.
 
   
 
    [image: ] 
 
    
    	Type-in 1 in the Angle 1 box.
 
    	Click OK to add the draft.
 
   
 
    [image: ] 
 
   Saving the Part
 
    
    	Click File > Save > Save; the Name Parts dialog appears.
 
    	Type Key in the Name box and click Folder button.
 
    	Browse to NX 10/C2 folder and then click OK button twice.
 
    	Click File > Close > All Parts.
 
   
 
  
 
   
 
   
    
 
    
 
  
 
   
 
   
    
 
    
 
    
 
  
 
   
 
   
    
 
    
 
                  
 
  
 
   
 
   
    
 
    
 
  
 
   
 
   
    
 
  
 
   
 
   
    
 
  
 
   
 
   
    
 
    
 
  
 
  


 
 
   
    
 
  
 
   
 
   
   Chapter 3: Constructing Assembly
 
    
 
                  
 
                  
 
   In this chapter, you will: 
 
                  
 
    
    	Add Components to an assembly
 
    	Apply constraints between components        
 
    	Produce exploded view of the assembly               
 
   
 
                  
 
  
 
   
 
   
   
TUTORIAL 1
 
   This tutorial takes you through the creation of your first assembly. You construct the Oldham coupling assembly: 
 
                  [image: ] 
 
   Copying the Part files into a new folder
 
    
    	Create a folder named Oldham_Coupling at the location NX 10/C3.
 
    	Copy all the part files constructed in the previous chapter to this folder.
 
   
 
    
 
   Opening a New Assembly File
 
    
    	To open a new assembly, click File > New; the New dialog appears.
 
   
 
    
 
    
    	Click Assembly in the Template group.
 
    	Click OK; a new assembly window appears. In addition, the Add Component dialog appears.
 
   
 
                  
 
   Inserting the Base Component
 
    
    	To insert the base component, click Open [image: ]button in the Part section of the Add Component dialog.
 
    	Browse to the location NX 10/C3/Oldham_Coupling and double-click on Flange.prt.
 
    	On the Add Component dialog, select Positioning > Absolute Origin in the Placement section.
 
    	Under the Settings section, select Reference Set > Entire Part.
 
    	Click OK to place the Flange at the origin.
 
   
 
    
 
   There are two ways of constructing any assembly model. 
 
    
 
    
    	Top-Down Approach 
 
    	Bottom-Up Approach
 
   
 
   
Top-Down Approach
 
   You open the assembly file, and then construct components files in it. 
 
                  
 
   Bottom-Up Approach
 
   You construct the components first, and then add them to the assembly file. In this tutorial, you construct the assembly using this approach.
 
    
 
   Adding the second component
 
 
    
    	To insert the second component, click Assemblies > Component > Add [image: ]on the ribbon; the Add Component dialog appears.
 
    	On the Add Component dialog, click Open button in the Part section. 
 
    	Browse to the location NX 10/C3/Oldham_Coupling and double-click on Shaft.prt.
 
    	Under the Placement section, select Positioning > By Constraints.
 
    	Under the Settings section, select Reference Set > Entire Part.
 
    	Click OK on the Add Component dialog; the Assembly Constraints dialog appears.
 
   
 
    
 
   After adding the components to the assembly environment, you have to apply constraints between them. By applying constraints, you establish relationships between components. You can apply the following types of constraints between components.
 
   
 [image: ] Touch Align: Using this constraint, you can make two faces coplanar to each other. Note that if you set the Orientation to Align, the faces will point in the same direction. You can also align the centerlines of the cylindrical faces.
 
   
[image: ] Concentric: This constraint makes the centers of circular edges coincident. In addition, the circular edges will be on the same plane.
 
   
 [image: ] Distance: This constraint provides an offset distance between two objects.
 
   
[image: ] Fix: This constraint fixes a component at its current position. 
 
   
[image: ] Parallel: This constraint makes two objects parallel to each other.
 
   
[image: ]Perpendicular: This constraint makes two objects perpendicular to each other.
 
   
[image: ] Fit: This constraint brings two cylindrical faces together. Note that they should have the same radius.
 
   
[image: ] Bond: This constraint makes the selected components rigid so that they move together.
 
   
[image: ] Center: This constraint positions the selected component at a center plane between two components.
 
   
[image: ] Angle: Applies angle between two components.
 
   
[image: ] Align/Lock: Aligns the axes of two cylindrical faces and locks the rotation.               
 
    
 
    
    	On the Assembly Constraints dialog, select Type > Touch Align.
 
    	Under the Geometry to Constrain section, select Orientation > Infer Center/Axis.
 
    	On the Assembly Constraints dialog, uncheck the Preview Component in Main Window option.
 
    	Click on the cylindrical face of the Shaft.
 
   
 
    [image: ] 
 
    
 
    
    	Click on any cylindrical face of the Flange.
 
    	Under the Geometry to Constrain section, select Orientation > Align.
 
    	Click on the front face of the shaft.
 
   
 
    [image: ] 
 
    
    	Rotate the flange and click on the slot face as shown in figure. 
 
   
 
    [image: ] 
 
    
 
    
    	Click on the YZ plane of the Shaft.
 
   
 
    [image: ] 
 
    
    	Click on the XY plane of the Flange.
 
   
 
    [image: ] 
 
    
    	Click OK to assemble the components.
 
   
 
    [image: ] 
 
    
 
   Checking the Degrees of the Freedom
 
    
    	To check the degrees of freedom of a component, click Assemblies > Component Position > Show Degrees of Freedom[image: ].
 
    	Click on the Flange to display the degrees of freedom.
 
   
 
    [image: ]You will notice that the Flange has six degrees of freedom.
 
    
 
   Fixing the Flange 
 
    
    	To fix the flange, click Assemblies > Component Position > Assembly Constraints [image: ]on the ribbon.
 
    	On the Assembly Constraints dialog, click Type > Fix.
 
    	Click on the Flange, and then click OK.
 
    	On the ribbon, click View > Orientation > More > Refresh[image: ].
 
    	To view the degrees of freedom, click Show Degrees of Freedom on the Component Position group and select the Flange and Shaft.
 
   
 
    
 
   You will notice that there are fully constrained.
 
    
 
   Hiding the Flange
 
    
    	To hide the Flange, click on it and select Hide from the contextual toolbar.
 
   
 
    [image: ] 
 
    [image: ] 
 
   Adding the Third Component
 
    
    	Click Add [image: ]on the Component group.
 
    	On the Add Component dialog, click the Open button.
 
    	Double-click on the Key.prt.            
 
    	Click OK.
 
    	On the Assembly Constraints dialog, select Type > Touch Align.
 
    	Under the Geometry to Constraints section, select Orientation > Align.   
 
    	Click on the front face of the Key and front face of the Shaft.
 
   
 
    
 
    [image: ] 
 
    
 
    [image: ] 
 
    
    	Click on the XY plane of the Key.
 
   
 
    
 
    [image: ] 
 
    
    	Click on the face on the shaft as shown in figure.
 
   
 
    [image: ]
               
 
    
    	Under the Geometry to Constrain section, select Orientation > Touch.
 
    	Click on the side face of the Key and select the face on shaft as shown in figure.
 
   
 
    [image: ] 
 
    [image: ] 
 
    
    	Click OK.
 
   
 
    
 
   Showing the Hidden Flange
 
    
    	To show the hidden flange, click View > Visibility > Show All [image: ]on the ribbon.
 
   
 
    
 
    
 
    
 
    [image: ] 
 
   Hiding the Reference Planes, sketches, and Constraint symbols
 
    
    	To hide the reference planes, sketches, and constraint symbols, click View > Visibility > Show and Hide on the ribbon.
 
    	On the Show and Hide dialog, click the hide icons in the Sketches, Datums, and Assembly Constraints rows.
 
   
 
    
 
    [image: ] 
 
    
 
    
    	Click Close on the dialog.
 
   
 
    
 
    [image: ] 
 
   Saving the Assembly
 
    
    	Click File > Save > Save; the Name Parts dialog appears.
 
    	Type-in Flange_subassembly in the Name box and click the Folder button.
 
    	Browse to NX 10/C3/Oldham_Coupling folder and then click OK button twice.
 
    	Click File > Close > All Parts.
 
   
 
   
Starting the Main assembly
 
    
    	Click File > New on the ribbon.
 
    	On the New dialog, click the Assembly template.
 
    	Type-in Main_assembly in the Name box and click Folder button.
 
    	Browse to NX 10/C3/ Oldham_Coupling folder and then click OK button twice; the Add Component dialog appears.
 
   
 
                  
 
   Adding Disc to the Assembly
 
    
    	Click the Open button.
 
    	Double-click on Disc.prt.     
 
    	Under the Placement section, select Positioning > Absolute Origin.
 
    	Set Reference Set to Model.
 
    	Click OK to place the Disc at the origin.
 
   
 
    
 
   Fixing the Disc to the Origin
 
    
    	Click Assemblies > Component > Assembly Constraints on the ribbon; the Assembly Constraints dialog appears.
 
    	On the Assembly Constraints dialog, select Type > Fix.
 
    	Select the Disc and click OK.
 
   
 
    
 
    [image: ] 
 
   
Placing the Sub-assembly
 
    
    	Click the Add [image: ]button on the Component group.
 
    	Click the Open button.
 
    	Double-click on Flange_subassembly.prt.   
 
    	On the Add Component dialog, select Positioning > By Constraints.
 
    	Click OK; the Assembly Constraints dialog appears. 
 
    	Set Type to Touch Align 
 
    	Set Orientation to Touch.
 
    	Click on the face of the Flange as shown in figure.
 
   
 
    [image: ] 
 
    
    	Click on the face of the Disc as shown in figure.
 
   
 
    [image: ] 
 
    
    	Set Type to Concentric.
 
    	Click on the circular of the Flange. 
 
   
 
    [image: ] 
 
    
 
    
    	Click on the circular edge of the Disc.
 
   
 
    
 
    [image: ]
 
    
    	Click OK to assemble the subassembly.
 
   
 
    
 
   Placing second instance of the Sub-assembly
 
    
    	Insert another instance of the Flange subassembly.
 
    	Apply the Touch Align and Concentric constraints. Note that you have to click the Reverse Last Constraint button while applying the Concentric constraint.
 
   
 
    
 
    
 
    [image: ] 
 
    
 
   Saving the Assembly
 
    
    	Click Save on the Quick Access Toolbar, or click File > Save.
 
   
 
    [image: ] 
 
   TUTORIAL 2
 
   In this tutorial, you produce the exploded view of the assembly created in the previous tutorial. 
 
    [image: ] 
 
   Producing the Exploded view
 
    
    	To produce the exploded view, click Exploded Views > New Explosion[image: ]; the New Explosion dialog appears.
 
    	Type-in Oldham_Explosion in the Name box.
 
    	Click OK.
 
    	On the Assembly Navigator, click the right mouse button on Flange_subassembly x 2.
 
   
 
    [image: ] 
 
    
 
    
    	Select Unpack.
 
    	Deselect the Flange_subassembly instances.
 
    	Click Exploded Views > Edit Explosion [image: ]on the ribbon; the Edit Explosion dialog appears.
 
    	Select Flange_subassembly from the Assembly Navigator.
 
   
 
    [image: ] 
 
    
    	Click Move Objects on the dialog; the dynamic triad appears on the flange subassembly. 
 
   
 
    [image: ] 
 
    
    	Click the Snap Handles to WCS [image: ] button on the Edit Explosion dialog; the dynamic triad snaps to WCS.
 
   
 
    
 
    [image: ] 
 
                 
 
    
    	Click the Y-Handle on the dynamic triad.
 
    	Enter -100 in the Distance box.
 
    	Click OK to explode the flange subassembly.
 
   
 
    [image: ] 
 
    
    	Click Edit Explosion [image: ]button on the Exploded Views group.
 
    	Click Select Objects on the Edit Explosion dialog.
 
    	Rotate the model and select the Key from the assembly.       
 
    	Click Move Objects on the dialog.
 
    	Click Snap Handles to WCS [image: ]button.
 
   
 
    [image: ] 
 
    
 
    
    	Click the Y-Handle on the dynamic triad.
 
    	Enter 80 in the Distance box.
 
    	Click OK to explode the Key.
 
   
 
    [image: ] 
 
    
    	Activate the Edit Explosion dialog.
 
    	Explode the shaft in Y-direction up to the distance of -80 mm.
 
   
 
                  [image: ]
 
    
 
    
    	Likewise, explode the other flange subassembly and its parts in the opposite direction. The explosion distances are same. 
 
   
 
    [image: ] 
 
    
 
   Creating Tracelines
 
    
    	To create tracelines, click Exploded Views > Tracelines [image: ]on the ribbon; the Tracelines dialog appears.
 
    	Click on the center point of the Flange.
 
   
 
    
 
    [image: ] 
 
    
 
    
    	On the Tracelines dialog, select End Object > Point.
 
    	Click on the center point of the circular edge of the shaft.
 
   
 
    
 
    [image: ] 
 
    
 
    
    	Click OK to create the traceline.
 
   
 
    [image: ] 
 
    
    	Click the Tracelines [image: ]button on the Exploded Views group.
 
    	Under the Start section, select Inferred > End Point[image: ].
 
    	Select the edge on the key way of the shaft.
 
   
 
    [image: ]               
 
    
    	Double-click on the arrow displayed on the edge to reverse the direction.
 
    	Under the End section, select Inferred > End Point.
 
    	Click on the edge on the key.
 
   
 
    
 
    [image: ] 
 
    
 
    
    	Double-click on the arrow to reverse the direction.
 
   
 
    [image: ]
              
 
    
    	Click OK to create the traceline.
 
    	Create tracelines between the other parts.
 
    	Change the view to Wireframe with Hidden Edges.
 
   
 
    [image: ] 
 
    
    	Click Save on the Quick Access Toolbar, or click File > Save.
 
   
 
    
 
   


 
  
 
  
 
 
   
   Chapter 4: Generating Drawings
 
    
 
                  
 
   In this chapter, you generate drawings of the parts and assembly from previous chapters. 
 
                  
 
   In this chapter, you will: 
 
    
 
    
    	Open and edit a drawing template 
 
    	Insert standard views of a part model
 
    	Add model and reference annotations
 
    	Add another drawing sheet
 
    	Insert exploded view of the assembly
 
    	Insert a bill of materials of the assembly
 
    	Apply balloons to the assembly               
 
   
 
                  
 
    
 
   TUTORIAL 1
 
   In this tutorial, you will generate drawings of parts constructed in previous chapters.
 
    
 
                  [image: ]
 
    
 
  
 
   
 
   
   Opening a New Drawing File
 
    
    	Start NX 10.
 
    	To open a new drawing, click the New button on the Standard group, or click File > New.
 
    	On the New dialog, select the Drawing tab.
 
    	Click A3-Size in the Template section.
 
    	Click OK; a new drawing window appears. In addition, the Populate Title Block dialog appears.
 
    	Select the individual labels and type-in their values.
 
    	Click the Close button on this dialog.
 
   
 
    
 
   Editing the Drawing Sheet
 
    
    	To edit the drawing sheet, click Home > New Sheet > Edit Sheet [image: ]on the ribbon; the Sheet dialog appears.
 
    	Expand the Settings section and set Units to Millimeters.
 
    	Set the Projection type to 3rd Angle Projection[image: ].
 
    	Click OK on the Sheet dialog.
 
   
 
    
 
   Generating the Base View
 
    
    	To generate the base view, click Base View [image: ]on the View group; the Base View message box appears.
 
    	Click Yes on the message box; the Part Name dialog appears.
 
    	Browse to the location NX 10/C3/Oldham_Coupling and double-click on Flange.prt; the Base View dialog appears.
 
   
 
    
 
   In addition, the view appears along with the pointer.
 
    
 
    
    	Under the Model View section, select Model View to Use > Front.
 
    	Place the view as shown in figure; the Projected View dialog appears.
 
    	Click Close to close the dialog.
 
   
 
                 
 
    [image: ] 
 
   Generating the Section View
 
    
    	To generate a section view, click Home > View > Section View [image: ]on the ribbon; the Section View dialog appears.
 
    	Click on the base view; the section line appears.
 
    	Click on the center point of the base view.
 
   
 
    [image: ] 
 
    
    	Drag the pointer toward right and click to position the section view.
 
   
 
                  [image: ]
 
    [image: ] 
 
   Generating the Detailed View
 
   Now, you need to generate the detailed view of the keyway that appears on the front view.
 
    
 
    
    	To generate the detailed view, click Detail View [image: ]button on the View group.
 
    	On the Detail View dialog, select Type > Circular.
 
    	Specify the center point and boundary point of the detail view as shown.
 
   
 
    
 
    [image: ] 
 
    
    	Under the Scale section, select Scale > 2:1.
 
    	Position the detail view below the base view.
 
   
 
    [image: ] 
 
    
 
   Setting the Annotation Preferences
 
    
    	To set the annotation preferences, click File > Preferences > Drafting; the Drafting Preferences dialog appears.
 
   
 
    
 
    [image: ] 
 
    
 
    
    	On the dialog, type-in Orientation and Location in the Find box and press Enter.
 
    	Set the Orientation value to Horizontal text.
 
   
 
    [image: ] 
 
                  
 
    
    	On the dialog, select Dimension > Text > Unit from the tree.
 
    	Set the Decimal Delimiter value to. Period.
 
   
 
    
 
    [image: ] 
 
    
 
    
    	On the dialog, select Dimension > Text > Dimension Text from the tree.
 
    	Under the Format section, type-in 3.5 in the Height box.
 
    	Select Common > Line/Arrow > Arrowhead from the tree.
 
    	Under the Workflow section, check the Automatic Orientation option.
 
    	Under the Format section, type-in 3.5 and 30 in the Length and Angle boxes, respectively.
 
    	Click Common > Line/Arrow > Extension Line.
 
    	Type-in 1 in the Gap boxes.
 
    	Type in 2 in the Extension Line Overhang.
 
    	Click Common > Lettering.
 
    	Under the Text Parameters section, type-in 3.5 in Height box,
 
    	Click OK.
 
   
 
    
 
   Dimensioning the Drawing Views
 
    
    	To add dimensions, click Home > Dimension > Rapid Dimension [image: ]on the ribbon.
 
    	On the section view, click the horizontal line located at the top.
 
   
 
    [image: ] 
 
    
    	Drag the pointer up and click to position the dimension.
 
   
 
    [image: ] 
 
    
    	Click on the ends of the section view, as shown.
 
   
 
    [image: ] 
 
    
    	Drag the pointer up and click to position the dimension.
 
   
 
    [image: ] 
 
    
    	Add another linear dimension to the section view.
 
   
 
    [image: ] 
 
    
    	On the section view, click on the arc locate at the bottom.
 
   
 
    [image: ] 
 
    
    	Drag the pointer downward and click to position the radial dimension.
 
   
 
    
 
    [image: ] 
 
    
 
    
    	On the Rapid Dimension dialog, under the Measurement section, select Method > Cylindrical.
 
   
 
    
 
    [image: ] 
 
    
 
    
    	Click on the ends of the section view, as shown.
 
   
 
    [image: ] 
 
    
    	Drag the pointer rightwards and click to position the dimension.
 
   
 
    [image: ] 
 
    
    	Create the other dimensions on the section view, as shown.
 
   
 
    [image: ] 
 
    
    	Create the radial dimension on the front view, as shown.
 
   
 
    [image: ] 
 
    
    	Right click on the radial dimension and select Edit[image: ].
 
    	Create the dimensions on the detail view, as shown.
 
   
 
    [image: ] 
 
   Saving the Drawing
 
    
    	On the Quick Access Toolbar, click Save; the Name Parts dialog appears.
 
    	Type-in Flange Drawing in the Name box and click Folder button.
 
    	Browse to NX 10/C3 folder and then click OK button twice
 
    	Close the drawing.
 
   
 
   
 
  

TUTORIAL 2
 
   In this tutorial, you generate the drawing of the Disc constructed in Chapter 1.
 
   Creating a custom template
 
    
    	Close the NX 9 application window.
 
    	Click Start > Apps > Siemens NX 10.0.
 
    	Right click on the NX 10.0 icon and select Run as administrator.
 
    	Click OK on the message box.
 
    	On the ribbon, click the New button.
 
    	On the New dialog, double-click on the Model template.
 
    	On the ribbon, click Applications > Design > Drafting[image: ].
 
    	On the Sheet dialog, select Standard Size.
 
    	Set Size to A3 – 297 x 420.
 
    	Set Scale to 1:1.
 
    	Under the Settings section, set Units to Millimeters. 
 
    	Select 3rd Angle Projection and uncheck Always Start Drawing View Command.
 
    	Click OK to open a blank sheet.
 
   
 
    
 
   Adding Borders and Title Block
 
    
    	On the ribbon, click Drafting Tools > Drawing Format > Borders and Zones[image: ] on the ribbon.
 
    	On the Borders and Zones dialog, leave the default settings and click OK.
 
   
 
    
 
    [image: ] 
 
    
 
    
    	On the ribbon, click Home > Table > Tabular Note[image: ].
 
    	On the Tabular Note dialog, under the Origin section, expand the Alignment section and select Anchor > Bottom Right.
 
    	Under the Table Size section, set Number of Columns to 3 and Number of Rows to 2.
 
    	Type-in 50 in Column Width box.
 
    	Click on the bottom right corner of the sheet border.
 
   
 
    [image: ] 
 
    
    	Click Close on the Tabular Note dialog.
 
    	Click on the left vertical line of the tabular note.
 
   
 
    [image: ] 
 
    
    	Press the left mouse button and drag toward right.
 
    	Release the left mouse button when column width is changed to 35.
 
   
 
    [image: ] 
 
    
    	Likewise, change the width of the second and third columns.
 
   
 
    [image: ] 
 
    [image: ] 
 
    
    	Click inside the second cell of the top row.
 
    	Press the left mouse button and drag to the third cell.
 
   
 
    [image: ] 
 
    
    	Click the right mouse button and select Merge Cells.
 
   
 
    [image: ] 
 
    
 
    [image: ] 
 
    
 
    
    	Change the height of the top row.
 
   
 
    [image: ] 
 
    
 
    
    	Click Yes on the message box.
 
    	Click the right mouse button in the second cell of the top row. Select Settings.
 
    	On the Settings dialog, select Prefix/Suffix from the tree.
 
    	Type-in Title: in the Prefix box.
 
    	Click Close.
 
   
 
    [image: ] 
 
    
 
    
    	Likewise, add prefixes to other cells.
 
   
 
    [image: ] 
 
    
    	Click the right mouse button in the first cell of the top row.
 
    	Click Import > Image.
 
    	Select your company logo image and click OK.
 
    	On the ribbon, click Drafting Tools > Drawing Format > Define Title Block[image: ].
 
    	Click on the table, and then click OK.
 
    	On the ribbon, click Drafting Tools > Drawing Format > Mark as Template[image: ].
 
    	On the dialog, select Mark as Template and Update PAX File.
 
    	Under the PAX File Settings section, type-in Custom Template in the Presentation Name box.
 
    	Select Template Type > Reference Existing Part.
 
    	Click the Browse [image: ]icon.
 
    	Go to 
 
   
 
   C:\Program Files\Siemens\NX 10.0\LOCALIZATION\prc\english\startup
 
    
    	Click ugs_drawing_templates.
 
    	Click OK.
 
    	On the Input Validation box, click Yes.
 
    	Click OK twice.
 
    	On the ribbon, click Drafting Tools > Track Drawing Changes > Create Snapshot Data[image: ].
 
    	Click OK on the message box.
 
    	Save and close the file.
 
   
 
    
 
   Opening a new drawing file using the custom template
 
    
    	On the ribbon, click the New button.
 
    	On the New dialog, under the Drawing tab, select Relationship > Reference Existing Part.
 
    	Under the Templates section, select Custom Template.
 
    	Under the Part to create a drawing of section, click the Browse [image: ]button.
 
    	On the Select master part dialog, click Open[image: ].
 
    	Go to the location of Disc.prt and double-click on it.
 
    	Click OK twice.
 
    	On the Populate Title Block dialog, type-in values, as shown.
 
    	Click Close.
 
   
 
    
 
    [image: ] 
 
    
 
   Generating Drawing Views
 
    
    	On the View Creation Wizard dialog, select Loaded Parts > Disc.prt.
 
    	Click Next.
 
    	On the Options page, select View Boundary > Manual.
 
    	Uncheck the Auto-Scale to Fit option.
 
    	Select Scale > 1:1.
 
    	Select Hidden Lines > Dashed.
 
    	Click Next. 
 
    	On the Orientation page, select Model Views > Front. 
 
    	Click Next.
 
    	On the Layout page, select the view, as shown.
 
   
 
    [image: ] 
 
    
    	Select Option > Manual.
 
   
 
    
 
    
    	Click to define the center of the views, as shown.               
 
   
 
    [image: ] 
 
    
 
   Adding Dimensions
 
    
    	Add centerlines and dimensions to the drawing.
 
    	Save and close the drawing file.
 
   
 
    [image: ] 
 
   
 
  

TUTORIAL 3
 
   In this tutorial, you will generate the drawing of Oldham coupling assembly created in the previous chapter.
 
   Creating the assembly drawing
 
    
    	Open the Main_assembly.prt file.
 
    	Click Applications > Design > Drafting.
 
    	On the Sheet dialog, select Standard Size.
 
    	Set Size to A3 -297 x 420.
 
    	Set Scale to 1:2.
 
    	Under the Settings section, check Always Start View Creation.
 
    	Select Base View command.
 
    	Click OK.
 
    	On the Base View dialog, under the Model View section, select Model View to Use > Isometric. 
 
    	Under the Scale section, select Scale > 1:2.
 
    	Click on the left side of the drawing sheet.
 
    	Click Close on the Projected View dialog.
 
   
 
    [image: ] 
 
   Generating the Exploded View
 
    
    	On the ribbon, click Home > View > Base View. 
 
    	On the Base View dialog, select Model View to Use >Trimetric.
 
    	Click on the right side of the drawing sheet.
 
    	Click Close.
 
   
 
    [image: ] 
 
    
 
   Generating the Part list
 
    
    	To generate a part list, click Home > Table > Part List [image: ]on the ribbon.
 
    	Place the part list at the top-right corner.
 
   
 
    
 
   Generating Balloons
 
    
    	To generate balloons, click Home > Table > Auto Balloon [image: ]on ribbon.
 
    	Select the part list.
 
    	Click OK.
 
    	On the Part List Auto-Balloon dialog, select Trimetric@2.
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    	Click OK to generate balloons.
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    	Save and close the file. 
 
   
 
    
 
    
 
    
 
    
 
   


 
  
 
  

 
 
   
   Chapter 5: Sketching
 
   In this chapter, you will learn the sketching tools. You will learn to create:
 
    
 
    
    	Rectangles
 
    	Polygons
 
    	Resolving Sketch
 
    	Geometric Constraints
 
    	Studio Splines
 
    	Ellipses
 
    	Circles
 
    	Arcs
 
    	Trim 
 
    	Fillets and Chamfers
 
   
 
   TUTORIAL 1 (Creating Rectangles)
 
   A rectangle is a four-sided object. You can create a rectangle by just specifying its two diagonal corners. However, there are various methods to create a rectangle. These methods are explained next.
 
    
 
    
     
     	On the ribbon, click Direct Sketch > Sketch and select the Front plane.
 
     	On the ribbon, click Direct Sketch > Rectangle[image: ].
 
     	Select the origin point to define the first corner.
 
     	Move the pointer and click to define the second corner.
 
    
 
   
 
    [image: ] 
 
   You can also type the Width and Height values to create the rectangle.
 
    
     
     	On the Rectangle toolbar, click the 3 Points[image: ] icon under the Rectangle Method section. This option creates a slanted rectangle. 
 
     	Select two points to define the width and inclination angle of the rectangle.
 
    
 
   
 
    [image: ] 
 
    
     
     	Select the third point to define its height.
 
    
 
   
 
    [image: ] 
 
    
     
     	On the Rectangle toolbar, click the From Center [image: ]icon under the Rectangle Method section.
 
     	Click to define the center point of the rectangle.
 
     	Move the pointer and click to define the midpoint of one side. Also, the inclination angle is defined.
 
    
 
   
 
    [image: ] 
 
    
     
     	Move the pointer and click to define the corner point.
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     	Click Close [image: ] on the Rectangle toolbar.
 
    
 
   
 
    
 
   Multi-Selection Gesture Drop-down
 
   This drop-down is available on the Top Border Bar and has options to select multiple objects. The Rectangle option helps you to select multiple elements by dragging a rectangle covering them. 
 
   The Lasso option helps you to select multiple elements by dragging the pointer around them.
 
    
    	On the Top Border Bar, select Lasso[image: ] from the Multi-Selection Gesture Drop-down.
 
    	On the Top Border Bar, Selection Scope to Within Active Sketch Only.
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    	Press and hold the left mouse button and drag the pointer covering all the rectangles.
 
   
 
    [image: ] 
 
    
    	Press Delete to erase the rectangles.
 
    	Click OK.
 
   
 
   TUTORIAL 2 (Creating Polygons)
 
   A Polygon is a shape having many sides ranging from 3 to 513. In NX, you can create regular polygons having sides with equal length. Follow the steps given next to create a polygon.
 
    
 
    
    	Activate the Direct Sketch mode.
 
    	On the ribbon, click Direct Sketch > Polygon[image: ].
 
    	On the Polygon dialog, type 8 in the Number of Sides box under the Sides section. 
 
    	Under the Size section, select Size > Inscribed Radius. This option creates a polygon with its sides touching an imaginary circle. You can also select the Circumscribed Radius option to create a polygon with its vertices touching an imaginary circle.
 
    	Click to define the center of the polygon.
 
    	Type 0 in the Rotation box.
 
    	Move the pointer and notice that the rotation of the polygon is constrained.
 
    	Type 50 in the Radius box and press Enter.
 
   
 
    [image: ] 
 
    
    	Click Close on the dialog to deactivate the tool.
 
   
 
    
 
   Circle by 3 Points
 
    
    	On the ribbon, click Home > Direct Sketch > Circle[image: ]
 
    	On the Circle toolbar, click Circle by 3 Points [image: ]icon under the Circle Method section.
 
   
 
    
    	Click on the vertices of the polygon. A circle is created passing through the vertices. 
 
   
 
    [image: ] 
 
   TUTORIAL 3 (Studio Splines)
 
   Studio Splines are non-uniform curves, which are used to create irregular shapes. In NX, you can create studio splines by using two methods: Through Points, and By Pole.
 
    
 
    
    	Download the Studio-spline example.jpg file.
 
    	On the ribbon, click Home > Feature > Datum > Raster Image[image: ].
 
    	On the Raster Image dialog, click the Browse [image: ]icon.
 
    	Go to the location of the downloaded image file and double-click on it.
 
    	Select the XZ Plane from the Datum Coordinate System.
 
    	Under the Orientation section, select Basepoint > Bottom Center.
 
    	Set the Reference Direction to Vertical.
 
    	Click on the Angle handle (Spherical Dot) of the Dynamic Coordinate System, and enter 180 in the Angle box.
 
   
 
    [image: ] 
 
    
    	Expand the Image Settings section and set the Overall Translucency to 50.
 
    	Click OK.
 
    	Activate the Sketch mode on the XZ Plane.
 
   
 
    
    	On the Ribbon, click Direct Sketch > More Curve > Studio Spline[image: ].
 
    	On the Studio Spline dialog, select Type > Through Points.
 
    	Select the five points, as shown.
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    	Select the three points, as shown.
 
   
 
    [image: ] 
 
    
    	Likewise, select other points, as shown.
 
   
 
    [image: ] 
 
    
    	Under the Parameterization section, set the Degree value to 2, and check the Closed option.
 
    	Click OK.
 
    	Click Yes on the Continuous Auto Dimensioning message box. The auto dimensions are not created.
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    	Double-click on the spline.
 
    	On the Studio Spline dialog, select Type > By Poles.
 
    	Drag the pole, as shown.
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    	Likewise, modify the other pole locations, as shown.
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    	Select a point on the spline, as shown. A new pole is added.
 
   
 
    [image: ] 
 
    
    	Drag the new pole to modify the spline.
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    	Likewise, add poles wherever they are required, and modify their position.
 
    	Click OK.
 
    	Click on the image and select Hide.
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    	Click Finish Sketch.
 
   
 
    
 
   TUTORIAL 4 (Geometric Constraints)
 
    
 
    
    	Activate the Direct Sketch mode.
 
    	On the ribbon, click Home > Direct Sketch > Profile[image: ]. 
 
    	Select the sketch origin.
 
    	Move the pointer towards right horizontally and click.
 
    	Move the pointer up vertically and click.
 
    	Move the pointer toward left and click. Notice that the Horizontal and Vertical constraints are created, automatically.
 
   
 
    [image: ] 
 
    
    	Move the pointer up vertically and click.
 
    	On the Profile toolbar, click the Arc [image: ]icon.
 
    	Move the pointer to the end point of the previous line, and then move it toward left. An arc normal to the line appears.
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    	Move the pointer to the end point of the previous line, move toward up, and left. Notice that an arc tangent to the previous line.
 
   
 
    [image: ] 
 
    
    	Click to create a tangent arc.
 
    	Move the pointer downward and notice the Tangent constraint.
 
   
 
    [image: ] 
 
    
    	Click when a dotted line appears from the horizontal line.
 
    	Move the pointer toward left and click when a dotted line appears from the sketch origin.
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    	Move the pointer downward and click the sketch origin.
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    	On the ribbon, click Home > Direct Sketch > Circle. 
 
    	Select the center of the tangent arc, move the pointer outward, and click. A concentric constraint is created between the circle and the arc.
 
   
 
    [image: ] 
 
    
    	Place the pointer on the midpoint of the left vertical line, and move the pointer. 
 
    	Click when a horizontal dotted line appears.
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    	Move the pointer and click to create a circle.
 
    	Likewise, create another circle.
 
    	Press Esc.
 
   
 
    [image: ] 
 
   Adding Constraints
 
   Geometric Constraints are used to control the shape of a sketch by establishing relationships between the sketch elements. You can add relations using the Geometric Constraints tool.
 
    
 
    
    	Select the line connected to the tangent arc, and click Vertical from the Shortcuts toolbar. The vertical constraint is applied to the line.
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    	Select the lower vertical lines.
 
    	Click the Equal Length [image: ]icon on the Shortcuts toolbar to make the lines equal.
 
    	Press Esc.
 
    	Select the two horizontal lines, as shown.
 
    	Click the Equal Length [image: ]icon on the Shortcuts toolbar to make the lines equal.
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    	Press Esc.
 
    	Select the other two vertical lines and click the Equal Length [image: ]icon to make them equal.
 
    	Press Esc.
 
    	Select the two circles located at the bottom.
 
    	Click the Equal Radius [image: ]icon on the Shortcuts toolbar.
 
    	Select the center point of the circle and the left the vertical line. 
 
    	Click the Midpoint [image: ]icon on the dialog. The midpoint of the vertical line and the center point of the circle become collinear.
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    	Likewise, make the other circle collinear with the midpoint of the right vertical line.
 
   
 
    
 
   Adding Dimensions
 
    
    	Double-click on the dimension of the lower right vertical line, type 30 and press Enter.
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    	Likewise, change the dimension of the upper vertical line to 35.
 
    	On the ribbon, click Home > Direct Sketch > Rapid Dimension. 
 
    	Select the lower horizontal line, move the pointer, and click to position the dimension.
 
    	Type 40 and press Enter.
 
    	Likewise, add other dimensions to the sketch to constrain it fully.
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   TUTORIAL 5 (Resolving Over-Constrained Sketch)
 
    
    	Activate the Direct Sketch mode and create the sketch, as shown.
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    	On the ribbon, click Home > Direct Sketch > Rapid Dimension. 
 
    	Select the arc and position the dimension. The Update Sketch message box appears showing that the sketch is over constrained.
 
    	Click OK and press Esc. The over constrained sketch objects appear in grey color and the over-constraining dimensions and constraints appears in red.
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    	Select the linear dimension, as shown and click Delete.
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    	Click OK on the Delete Dimensions message box. Now, the sketch is fully constrained.
 
   
 
    
 
   TUTORIAL 6 (Ellipses)
 
   Ellipses are also non-uniform curves, but they have a regular shape. They are actually splines created in regular closed shapes.
 
    
 
    
    	Activate the Direct Sketch mode.
 
   
 
    
    	On the ribbon, click Home > Direct Sketch > More Curves > Ellipse[image: ].
 
    	Pick a point in the graphics window to define the location of the ellipse.
 
    	Type 40 and 20 in the Major Radius and Minor Radius boxes on the Ellipse dialog. You can also use the arrow handles to change the major and minor radius values.
 
   
 
    [image: ] 
 
    
    	Type 30 in the Angle box. You can also use the Angle handle to rotate the ellipse. Click OK.
 
   
 
    [image: ] 
 
   Note that the ellipse is not constrained fully. Follow the steps given next to fully-constrain the ellipse.
 
    
 
    
    	On the ribbon, click Home > Direct Sketch > Line[image: ].
 
    	Select center point of the ellipse.
 
    	Select a point on the ellipse.
 
    	Likewise, create another line.
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    	On the ribbon, click Home > Direct Sketch > More > Geometric Constraints[image: ].
 
    	Click OK on the message box.
 
    	On the Geometric Constraints dialog, click the Parallel [image: ]icon under the Constraints section.
 
    	Select the line and ellipse, as shown.
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    	On the Geometric Constraints dialog, click the Perpendicular [image: ] icon under the Constraints section.
 
    	Select the two lines to make them perpendicular to each other.
 
    	Close the Geometric Constraints dialog.
 
    	On the ribbon, click Home > Direct Sketch > Rapid Dimension[image: ].
 
    	Select the major axis line, move the pointer in the direction perpendicular to the line, and click to position the dimension.
 
    	Type 40 and press Enter.
 
    	Likewise, dimension the minor axis line.
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    	Select the Major axis line and the X-axis.
 
    	Move the pointer and click.
 
    	Type 30 and press Enter.
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    	Close the Rapid Dimension dialog.
 
    	Click on the major axis line and select Convert to Reference.
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    	Likewise, convert the other line to reference.
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    	Double-click on the ellipse and rotate it using the Angle handle.
 
    	Click OK and notice that the ellipse returns to it position. 
 
   
 
    
 
   TUTORIAL 7 (Conics)
 
    
    	Activate the Direct Sketch mode.
 
    	Create a triangle using the Polygon tool.
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    	On the ribbon, click Home > Direct Sketch > More Curve > Conic[image: ].
 
    	Select the start and end limits, and control point, as shown.
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    	Set the Rho Value to 0.25.
 
    	Expand the Preview section and click Show Result.
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    	Click Undo Result on the dialog.
 
    	Set the Rho Value to 0.75 and click Show Result.
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    	Click OK.
 
   
 
    
 
   TUTORIAL 8 (Quick Extend, Quick Trim, Make Corner, and Offset Curve)
 
   The Quick Extend tool is similar to the Quick Trim tool but its use is opposite of the Quick Trim tool. This tool is used to extend lines, arcs and other open entities to connect to other objects. 
 
    
 
    
    	Create a sketch as shown below.
 
   
 
    [image: ]
 
    
    	Click Home > Direct Sketch > Quick Extend[image: ]on the ribbon. 
 
    	Select the horizontal open line. This will extend the line up to arc.
 
   
 
    [image: ] 
 
    
    	Likewise, extend the other elements, as shown.
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    	Close the Quick Extend dialog.
 
   
 
    
 
   Make Corner
 
    
    	On the ribbon, click Home > Direct Sketch > Make Corner[image: ].
 
    	Click on the ending portion of the arc.
 
    	Click on the starting portion of the horizontal line.
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    	Close the Make Corner dialog.
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   Quick Trim
 
    
    	On the ribbon, click Home > Direct Sketch > Quick Trim[image: ].
 
    	Select the horizontal line.
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    	Close the Quick Trim dialog.
 
   
 
    
 
   Offset Curve
 
   The Offset Curve tool creates parallel copies of lines, circles, arcs and so on.
 
    
 
    
    	On the ribbon, click Home > Direct Sketch > More Curve > Offset Curve[image: ]. 
 
    	Select an entity and notice that all the connected entities are selected.
 
    	Type-in a value in the Distance box on the Offset Curve dialog (or) drag the arrow that appears on the offset curve.
 
    	Click Reverse Direction [image: ]icon to reverse the offset side.
 
    	Click OK.
 
   
 
    [image: ] 
 
   TUTORIAL 9 
 
   This tutorial teaches you to use Fillet, Chamfer, and Mirror Curve tools. 
 
    
 
   Fillet
 
   The Fillet tool converts the sharp corners into round corners.
 
    
 
    
    	Draw the lines as shown below.
 
   
 
    [image: ] 
 
    
    	Click Home > Direct Sketch > Fillet [image: ]on the ribbon.
 
    	Click on the corner, as shown.
 
    	Move the pointer and click to define the radius. You can also type the radius value.
 
   
 
    [image: ] 
 
    
    	On the Fillet toolbar, click the Delete Third Curve [image: ]icon.
 
    	Select the right and left vertical lines.
 
    	Move the pointer and select the horizontal connecting the two vertical lines.
 
   
 
    [image: ] 
 
    
 
   Chamfer
 
   The Chamfer tool replaces the sharp corners with an angled line. This tool is similar to the Fillet tool, except that an angled line is placed at the corners instead of a round.
 
    
 
    
    	Click Home > Direct Sketch > Chamfer[image: ]on the Ribbon.
 
    	On the Chamfer dialog, select Chamfer > Symmetric.
 
    	Click on the corner, as shown.
 
   
 
    [image: ] 
 
    
 
    
    	Type-in a value in the Distance box and press Enter.
 
    	Close the dialog.
 
   
 
    [image: ] 
 
   Mirror Curve
 
   The Mirror Curve tool creates a mirror image of objects. You can create symmetrical sketches using this tool. 
 
    
 
    
    	On the ribbon, click Home > Direct Sketch > Mirror Curve [image: ]
 
    	Drag a selection lasso covering all the sketch entities.
 
   
 
    [image: ] 
 
    
    	On the Mirror Curve dialog, click Select Centerline and select the X-axis.
 
    	Click OK to mirror the selected entities.
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    	On the Ribbon, click Home > Direct Sketch > Arc[image: ].
 
    	Select the start and end points of the arc, as shown.
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    	Move the pointer rightwards and click when the Tangent glyph appears.
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    	Close the Arc toolbar.
 
   
 
    
 
    
 
   Adding Dimensions
 
    
    	Double-click on the radial dimension, as shown.
 
    	Type 15 and press Enter.
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    	On the Ribbon, click Home > Direct Sketch > Rapid Dimension[image: ].
 
    	Select the left most vertical line and the center point of the arc, as shown.
 
    	Type 125 and press Enter.
 
   
 
    [image: ] 
 
    
    	Select the fillet, type 5 and press Enter.
 
    	Likewise, create other dimensions, as shown.
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    	Zoom to the top portion of the sketch, select the points, and press Delete.
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    	Click Finish Sketch.
 
   
 
    
 
    
 
    
 
    
 
   
 
 
    
 
  
 
   
 
   
    
 
  
 
   
 
   
    
 
    
 
    
 
    
 
    
 
                  
 
   
               
 
  
 
   
 
   
    
 
   


 
  
 
  
 
 
   
   Chapter 6: Additional Modeling Tools
 
    
 
                                 
 
   In this chapter, you will: 
 
    
 
    
    	Construct a Sweep feature
 
    	Construct a Swept feature along guide curves
 
    	Create Holes
 
    	Add Grooves and Slots
 
    	Make Pattern Features
 
    	Construct Tube features
 
    	Construct Instance Geometry
 
    	Apply Boolean operations
 
    	Add chamfers               
 
   
 
                  
 
   TUTORIAL 1
 
   In this tutorial, you will construct a helical spring using the Helix and Sweep along Guide tools.
 
                  [image: ]
 
  
 
   
 
   
    
 
   Constructing the Helix
 
    
    	Open a NX file using the Model template.
 
    	To construct a helix, click Curve > Curve > Helix [image: ]on the ribbon.
 
    	On the Helix dialog, select Type > Along Vector.
 
   
 
    
 
    
    	Specify the settings in the Size section, as given next.
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    	Specify the settings in the Pitch section, as given next.
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    	Specify the settings in the Length section, as given next.
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    	Expand the dialog and specify the settings in the Settings section, as given next.
 
   
 
                  [image: ]
 
    
    	Click OK to construct the helix.
 
   
 
                  [image: ]
 
   Adding the Datum Plane
 
    
    	To add a datum plane, click Home > Feature > Datum Plane[image: ] on the ribbon.
 
    	On the Datum Plane dialog, select Type > On Curve.
 
    	Select the helix from the graphics window.
 
    	Under the Location on Curve section, select Location > Through Point.
 
    	Select the end of the helix.
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    	Under the Orientation on Curve section, select Direction > Normal to Path.
 
    	Leave the default values and click OK.
 
   
 
                  
 
   Constructing the Sweep feature
 
    
    	On the ribbon, click Home > Direct Sketch > Sketch.
 
    	Select the plane created normal to the helix. 
 
    	Expand the Sketch Origin section and click Specify Point.
 
    	Select the end point of the helix to define the sketch origin.
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    	Click OK.
 
    	Draw circle of 4 mm diameter.
 
   
 
                 [image: ]
 
    
    	Right-click and select Finish Sketch[image: ].
 
    	On Top Border Bar, click the Orient View > Isometric. 
 
    	To construct a sweep feature, click Surface > More > Sweep along Guide [image: ]on the ribbon.
 
    	Select the circle to define the section curve.
 
    	Under the Guide section, click Select Curve.
 
    	Select the helix.
 
    	Leave the default settings and click OK to construct the sweep feature.
 
    	Click on the plane and select Hide.
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   Also, hide the sketch.
 
                 [image: ]
 
    
    	Save and close the file.
 
   
 
                  
 
   TUTORIAL 2
 
   In this tutorial, you construct a pulley wheel using the Revolve and Groove tools.
 
    [image: ]
 
    
 
    
    	Open a file in the Modeling Environment.
 
    	Construct the sketch on the YZ plane, as shown in figure.
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    	Finish the sketch.
 
    	Construct the revolved feature.
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   Constructing the Groove feature
 
    
    	To construct a groove feature, click Home > Feature > More > Design Feature > Groove [image: ]on the ribbon.
 
   
 
    
 
   Note
 
   Some tools do not appear on the ribbon. To display the required tools, select them from the menu, as shown in figure.
 
                 
 
    
    	On the Groove dialog, click the U Groove button.
 
    	Select the outer cylindrical face of the revolved feature.
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    	Specify the values on the U Groove dialog, as shown in figure.
 
   
 
    
 
    [image: ]
 
    
 
    
    	Click OK; the Position Groove dialog appears.
 
    	Click on the cylindrical edges of the model and groove preview, as shown.
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    	Enter 7.5 on the Create Expression dialog.
 
   
 
    
 
    [image: ] 
 
    
 
    
    	Click OK to add the groove.
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    	Click Cancel.
 
    	Save and close the model.
 
   
 
   
TUTORIAL 3
 
   In this tutorial, you construct a shampoo bottle using the Swept, Extrude, and Thread tools.
 
                  
 
   Creating Sections and Guide curves
 
   To construct a swept feature, you need to create sections and guide curves.
 
    
 
    
    	Open a file in the Modeling Environment.
 
    	On the ribbon, click Home > Direct Sketch > Sketch.
 
    	Select the XY plane.
 
    	On the Create Sketch dialog, click OK to start the sketch.
 
    	On the ribbon, click Home > Direct Sketch > Ellipse[image: ].
 
    	Select the origin point of the coordinate system.
 
    	Specify Major Radius as 50 mm.
 
    	Specify Minor Radius as 20 mm.
 
    	Specify Angle as 0.
 
    	Leave the default settings and click OK.
 
   
 
    [image: ] 
 
    
    	Click Finish Sketch.
 
    	Change the orientation to Isometric.
 
    	On the ribbon, click Home > Direct Sketch > Sketch.
 
    	Select the XZ plane.
 
    	Click OK.
 
    	On the ribbon, click Home > Direct sketch > Studio Spline[image: ].
 
    	On the Studio Spline dialog, select Type > Through Points.
 
    	Draw a spline similarly to the one shown in figure.
 
   
 
    [image: ] 
 
   Ensure that the first point of the spline coincides with the previous sketch.
 
    
 
    
    	Click OK.
 
    	Apply dimension to the spline, as shown in figure.
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    	On the ribbon, click Home > Direct Sketch > Mirror Curve[image: ].
 
    	Select the spline.
 
    	On the Mirror Curve dialog, click Select Centerline and then select the vertical axis of the sketch.
 
    	Click OK.
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    	Click Finish Sketch.
 
    	Change the view orientation to Isometric.
 
   
 
   
Creating another section
 
    
    	On the ribbon, click Home > Feature > Datum Plane.
 
    	On the Datum Plane dialog, select Type > At Distance.
 
    	Select the XY plane from the coordinate system.
 
    	Type-in 225 in the Distance box.
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    	Click OK.
 
    	Start a sketch on the new datum plane.
 
    	Draw a circle of 40 mm diameter.
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    	Click Finish Sketch.
 
    	Change the view to Isometric.
 
   
 
    
 
   Constructing the swept feature
 
    
    	On the ribbon, click Home > Surface > Swept[image: ].
 
    	Select the circle and click the middle mouse button.
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    	Select the ellipse.
 
   
 
   
Ensure that the arrows on the circle and the ellipse point towards same direction. Use the Reverse Direction button in the Sections section to reverse the direction of arrows.
 
    
 
    
    	Click Select Curve in the Guides (3 maximum) section.
 
    	Select the first guide curve and click the middle mouse button.
 
    	Select the second guide curve.
 
    	Click OK to construct the swept feature.
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   Constructing the Extruded feature
 
    
    	Click on the circle on the top of the sweep feature.
 
    	Click Extrude on the contextual toolbar.
 
   
 
    [image: ]
 
 
    
    	On the Extrude dialog, under the Boolean section, select Boolean > Unite.
 
    	Extrude the circle up to 25 mm.
 
   
 
    [image: ] 
 
   Adding the Emboss feature
 
    
    	On the Feature group, click the Datum Plane button.
 
    	On the Datum Plane dialog, select Type > At Distance.
 
    	Select the XZ plane from the coordinate system.
 
    	Enter 50 in the Distance box.
 
    	Click Reverse Direction to create the plane, as shown. Click OK.
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    	Create a sketch on the plane as shown in figure. The major and minor radiuses of the ellipse are 50 and 20, respectively.
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    	Click Finish Sketch.
 
    	On the ribbon, click Home > Feature > More > Design Feature > Emboss[image: ].
 
    	Select the sketch.
 
    	On the Emboss dialog, under Face to Emboss, click Select Face.
 
    	Select the swept feature.
 
   
 
    [image: ] 
 
    
    	Under the End Cap section, specify the settings, as given in figure.
 
   
 
    [image: ] 
 
    
    	Leave the default settings and click OK to add the embossed feature.
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   Adding Edge Blend
 
    
    	On the ribbon, click Home > Feature > Edge Blend.
 
    	Click on the bottom and top edges of the swept feature.
 
    	Set Radius 1 to 5 mm.
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    	Click Apply to add the blend.
 
    	Set Radius 1 to 1 mm.
 
    	Select the edges of the emboss feature and click OK.
 
   
 
                  [image: ]
 
    
 
   Shelling the Model
 
    
    	On the ribbon, click Home > Feature > Shell[image: ].
 
    	On the Shell dialog, select Type > Remove Faces, then Shell.
 
    	Set Thickness to 2 mm.
 
    	Select the top face of the cylindrical feature.
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    	Click OK to shell the geometry.
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   Adding Threads
 
    
    	On the ribbon, click Home > Feature > More > Thread[image: ].
 
    	On the Thread dialog, set Thread Type to Detailed.
 
    	Select the cylindrical face.
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    	Set Pitch to 8 mm.
 
    	Leave the other default settings and click OK to add the thread.
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    	Save the model and close it.
 
   
 
                  
 
   TUTORIAL 4
 
   In this tutorial, you construct a patterned cylindrical shell.               
 
    [image: ] 
 
   Constructing a cylindrical shell
 
    
    	Start a new file using the Model template.
 
    	On the ribbon, click Home > Feature > More > Design Feature > Cylinder[image: ].
 
    	On the Cylinder dialog, select Type > Axis, Diameter, and Height.
 
    	Select the Z-axis from the triad.
 
   
 
    [image: ] 
 
    
    	Specify Diameter and Height as 50 and 100, respectively.
 
    	Leave the default settings and click OK.
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    	On the ribbon, click Home > Feature > Shell.
 
    	Set Thickness to 3 mm.
 
   
 
    
 
    
    	Select the top and bottom faces of the cylindrical feature.
 
    	Click OK to shell the geometry.
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   Adding slots
 
    
    	On the ribbon, click Feature > More > Design Feature > Slot[image: ].
 
    	On the Slot dialog, select Rectangle then click OK.
 
    	Click on the YZ plane.
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    	Click Flip Default Side.
 
    	Select Z-axis from the Datum Coordinate System.
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    	On the Rectangular Slot dialog, type-in 8, 3, and 30 in the Length, Width and Depth boxes, respectively.
 
    	Click OK. 
 
   
 
    
 
   The Positioning dialog appears. In addition, the slot tool appears.
 
    
 
    
    	On the Positioning dialog, click the Horizontal [image: ]button.
 
    	Select the circular edge of the cylindrical feature.
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    	On the Set Arc Position dialog, click Arc Center on the dialog.
 
    	Select the circular edge on the slot tool.
 
   
 
                  [image: ]
 
    
    	On the Set Arc Position dialog, click Arc Center.
 
    	Enter -8 mm in the dialog.
 
    	Click OK twice to add the slot feature.
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    	Click Cancel.
 
   
 
   
Constructing the Linear pattern
 
    
    	On the ribbon, click Home > Feature > Pattern Feature[image: ].
 
    	On the Pattern Feature dialog, select Layout > Linear[image: ].
 
    	Select the slot feature.
 
    	Under the Pattern Definition section, select Direction 1 > Specify Vector.
 
    	Select the Z-axis vector.
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    	Select Spacing > Count and Pitch.
 
    	Type-in 6 in the Count box.
 
    	Enter 16 in the Pitch Distance box.
 
    	Click OK to make the linear pattern.
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   Constructing the Circular pattern
 
    
    	On the ribbon, click Feature > Pattern Feature[image: ]. 
 
    	On the Pattern Feature dialog, select Layout > Circular[image: ].
 
    	Press Ctrl key and then select the linear pattern and the slot feature from the Part Navigator.
 
    	Under the Pattern Definition section, select Rotation Axis > Specify Vector.
 
    	Select the Z-axis vector.
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   Now, you have to specify the point through which the rotation axis passes.
 
    
 
    
    	Click on the circular edge of the cylindrical feature (to select the center point of the cylinder).
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    	Select Spacing > Count and Span.
 
    	Type-in 12 in the Count box.
 
    	Type-in 360 in the Span Angle box.
 
    	Click OK to make the circular pattern.
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    	Save and close the model.
 
   
 
                  
 
   TUTORIAL 5
 
   In this tutorial, you will construct a chain.
 
    [image: ] 
 
   Constructing the Tube feature
 
    
    	Open a new file using the Model template.
 
    	On the ribbon, click Home > Direct Sketch > Sketch.
 
    	Select the XZ plane.
 
    	On the ribbon, click Home > Direct Sketch > Profile.
 
    	Click on the screen to define the first point.
 
    	Drag the pointer rightwards and click to define the second point.
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    	On the Profile dialog, click Arc.
 
    	Drag the mouse toward right, and then downwards.
 
    	Click to draw the arc.
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    	Drag the mouse toward left and click to define a horizontal line.
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    	On the Profile dialog, click Arc.
 
    	Drag the mouse toward left, and then upwards.
 
    	Click on the start point of the sketch to draw the arc 
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    	Close the Profile dialog.
 
    	On the ribbon, click Home > Direct Sketch > More > Make Symmetric.
 
    	Select the two arcs and click on the vertical axis.
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    	Click Reset [image: ] on the Make Symmetric dialog.
 
    	Select the horizontal lines, and then click on the horizontal axis.
 
    	Add dimensions to the sketch.
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    	Click Finish Sketch on the Direct Sketch group.
 
    	To construct a tube feature, click Home > Surface > More > Tube[image: ] on the ribbon.
 
    	Select the sketch.
 
    	On the Tube dialog, type-in 1.5 and 0 in the Outer Diameter and Inner Diameter boxes, respectively.
 
    	Click OK to construct the tube feature.
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   Patterning the Tube geometry
 
    
    	On the ribbon, click Home > Feature > Pattern Feature.
 
    	On the Pattern Feature dialog, select Layout > Linear and click on the tube feature.
 
    	Under the Pattern Definition section, select Direction 1 > Specify Vector.
 
    	Select the X-axis vector.
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    	Under Direction 1, select Spacing > Count and Pitch.
 
    	Type-in 6 and 12 in the Count and Pitch boxes, respectively.
 
    	Expand the Orientation section and select Orientation > CSYS to CSYS.
 
    	Under Orientation, select Specify From Vector CSYS > CSYS Dialog[image: ].
 
    	On the CSYS dialog, select Type > Dynamic.
 
    	Accept the default position of the Dynamic CSYS and click OK.
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    	On the Pattern Feature dialog, under Orientation, select Specify To CSYS > CSYS Dialog.
 
    	Rotate the Dynamic CSYS about the X-axis. The rotation angle is -90 degrees.
 
   
 
    [image: ] 
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    	Click OK.
 
    	On the Pattern Feature dialog, under Orientation, check the Repeat Transformation option. 
 
    	Click OK to make pattern of the tube.
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    	Save and close the file.
 
   
 
                  
 
   Boolean Operations
 
   Types of Boolean operations.
 
   
Unite
 
   Subtract
 
   Intersect
 
                  
 
   These tools combine, subtract, or intersect two bodies. Activate these tools from the Combine drop-down on the Feature group.
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   Unite: This tool combines the Tool Body and the Target Body into a single body.
 
   
Subtract: This tool subtracts the Tool body from the Target body.
 
   
Intersect: This tool keeps the intersecting portion of the tool and target bodies.
 
   
TUTORIAL 6
 
   In this tutorial, you will construct the model shown in figure.
 
                  [image: ]
 
    
 
   Constructing the first feature
 
    
    	Open a new part file.
 
    	Construct the first feature on the XY plane (extrude the sketch up to a distance of 10 mm).
 
   
 
                  [image: ]
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   Constructing the Second Feature
 
    
    	Draw the sketch on the top face of the first feature. 
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    	On the ribbon, click Home > Feature > Extrude.
 
    	Select the sketch.
 
    	Type-in 45 in the End box.
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    	Under the Boolean section, select Boolean > Unite.
 
    	Click OK.
 
   
 
    [image: ] 
 
    
 
   Constructing the third feature
 
    
    	On the ribbon, click Home > Feature > Datum Plane.
 
    	On the Datum Plane dialog, select Type > At Distance.
 
    	Click on the right-side face of the model geometry.
 
    	Type-in 50 in the Distance box and click the Reverse Direction icon on the Datum Plane dialog.
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    	Click OK.
 
    	Draw the sketch on the new datum plane.
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    	On the ribbon, click Home > Feature > More > Rib.
 
    	Select the sketch.
 
    	On the Rib dialog, select Walls > Parallel to Section Plane.
 
    	Under the Walls section, select Distance > Symmetric and type-in 10 in the Thickness box.
 
    	Check Combine Rib with Target.
 
    	Click OK.
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   Drilling Holes
 
    
    	To drill holes, click Home > Feature > Hole [image: ]on the ribbon.
 
    	On the Hole dialog, select Type > Drill Size Hole.
 
    	Under the Forms and Dimensions section, select Size > 16.
 
    	Select Depth Limit > Through Body.
 
    	Click on the top face of the model.
 
   
 
                  [image: ]
 
    
    	Click to place one more point.
 
    	Click Close on the Sketch Point dialog.
 
    	Add dimensions to define the hole location.
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    	Click Finish on the ribbon.
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    	Click Apply to create the hole.
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    	Drill another hole on the front face of the second feature.
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   Adding Chamfers
 
    
    	To add a chamfer, click Home > Feature > Chamfer [image: ]on the ribbon.
 
    	On the Chamfer dialog, select Cross-section > Asymmetric.
 
    	Under the Offsets section, type-in 25 and 45 in the Distance 1 and Distance 2 boxes.
 
    	Click on the corner edge of the first feature.
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    	Click Apply add the chamfer.
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    	On the Chamfer dialog, select Cross Section > Symmetric.
 
    	Type-in 45 in the Distance box.
 
    	Click on the corner edge of the second feature.
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    	Click OK.
 
   
 
    [image: ]                            
 
    
    	Save the model.
 
   
 
    
 
   Edit Parameters
 
    
    	Click on the Drilled hole and select Edit Parameters from the Shortcuts toolbar.
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    	On the Hole dialog, select Type > General Hole.
 
    	Under the Form and Dimensions section, select Form > Counterbored.
 
    	Set the Dimensions of the counterbored hole, as shown.
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   You can also change the location of the hole by double clicking on the location dimensions and changing their values.
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    	Click OK.
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   Show Dimensions
 
    
    	Click on the base feature and select Show Dimensions from the Shortcuts toolbar.
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    	Double click on the linear dimension of the extrude feature.
 
   
 
    [image: ] 
 
    
    	On the Feature Dimension dialog, type-in 20 in the value box and click OK.
 
    	Right click and select Refresh or press F5.
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   Editing Features by Double-clicking
 
    
    	Double-click on the chamfer.
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    	On the Chamfer dialog, type-in 30 in the Distance 1 box and click OK.
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   Supress Features
 
    
    	Click on the chamfer face and select Suppress on the Shortcuts toolbar.
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    	On the Part Navigator, check the Chamfer feature to unsuppress it.
 
    	On the Part Navigator, right click on the Sketch on the base feature and select Edit Parameters.
 
    	On the Edit Sketch Dimensions dialog, select the 125 dimension and change its name to Length.
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    	Click Apply and OK.
 
    	On the Top Border Bar, click Menu > Edit > Feature > Suppress by Expression.
 
    	Select the previously unsuppressed chamfer and click Apply.
 
    	Click Show Expressions on the dialog. The Information window appears showing the chamfer expression. The value 1 indicates that it is currently unsuppressed. 
 
    	Close the Information window.
 
    	On the ribbon, click Tools > Utilities > Expression.
 
    	On the Expressions dialog, select Listed Expressions > All.
 
    	Scroll down and select p361 (Chamfer (11) Suppression Status) from the listed expressions.
 
    	Enter Chamfer_Suppression in the Name box.
 
    	Enter if (Length=>125) (1) else (0) in the Formula box.
 
    	Click OK.
 
    	On the Part Navigator, right click on the Sketch on the base feature and select Edit Parameters.
 
    	On the Edit Sketch Dimensions dialog, select the 125 dimension and change its value to 124.
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    	Click OK. The chamfer is suppressed as the length value is less than 125.
 
   
 
    [image: ] 
 
    
    	Close the file.
 
   
 
    
 
   TUTORIAL 7
 
   In this tutorial, you create the model shown in figure.
 
    [image: ] 
 
   Constructing the first feature
 
    
    	Open a new part file.
 
    	On the ribbon, click Home > Features > Extrude.
 
    	Click on the XY plane.
 
    	Construct two circles and add dimensions to them.
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    	On the ribbon, click Home > Curve > Quick Trim [image: ]and trim the intersecting entities.
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    	On the ribbon, click Home > Curve > Fillet [image: ]and set the Radius value to 10.
 
    	Select the intersecting corners of the circles.
 
   
 
    [image: ] 
 
    
    	Click Finish Sketch.
 
    	Extrude the sketch up to 5 mm distance.
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   Constructing the Extruded cut
 
    
    	On the ribbon, click Home > Feature > Extrude.
 
    	Click on the top face of the model.
 
    	On the ribbon, click Home > Curve > Offset Curve[image: ].
 
    	Click on any edge of the top face.
 
    	On the Offset Curve dialog, set the Distance value to 20.
 
    	Click the Reverse Direction button.
 
    	Click OK.
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    	Click Finish.
 
    	On the Extrude dialog, click the Reverse Direction [image: ] button under the Direction section.
 
    	Click OK.
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   Constructing the Extruded cut
 
    
    	On the ribbon, click Home > Feature > Extrude.
 
    	Click on the top face of the model geometry.
 
    	On the ribbon, click Home > Curve > Polygon[image: ].
 
    	On the Polygon dialog, type-in 6 in the Number of Sides box.
 
    	Select Size > Circumscribed Radius.
 
    	Set the Radius to 4.
 
    	Set the Rotation to 0.
 
    	Click to define the center point of the polygon.
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    	Draw a horizontal line connecting the center point of the polygon and the origin.
 
    	Click on the horizontal line and select Convert to Reference.
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    	Add dimensions to the sketch.
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    	Click Finish.
 
    	Create the cut throughout the body.
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   Making the Along Pattern
 
    
    	On the ribbon, click Home > Feature > Pattern Feature [image: ].
 
    	Select the polygonal cut to define the feature to pattern.
 
    	Select Layout > Along.
 
    	Select Path Method > Offset.
 
    	On the Top Border Bar, select Curve rule > Tangent Curves.
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    	Click Select Path and select the outer edge of the top face.
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    	Select Spacing > Count and Span.
 
    	Type-in 10 in the Count box.
 
    	Type-in 100 in the % Span By box.
 
    	Under the Orientation section, set Orientation to Normal to Path.
 
    	Click OK.
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   Measuring the Mass Properties
 
    
    	On the ribbon, click Analysis > Measure > More > Measure Bodies[image: ]
 
    	Select the geometry. Notice the volume of the geometry. You can select a different property from the drop-down to see its value.
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   You can also check the Show Information Window option under the Results Display section to display the mass properties in the Information window.
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    	Click Cancel on the Measure Bodies dialog.
 
    	On the Top Border Bar, click Menu > Edit > Feature > Solid Density[image: ].
 
    	On the Assign Solid Density dialog, select Units > Lbs – Inches.
 
    	Type 0.45 in the Solid Density box.
 
    	Select the geometry and click OK.
 
    	On the ribbon, click Analysis > Measure > More > Measure Bodies[image: ].
 
    	Select the geometry and notice the updated mass properties.
 
    	Click Cancel.
 
    	On the ribbon, click Tools > Utilities > More > Assign Materials[image: ].
 
    	Select the geometry.
 
    	Select Iron_Malleable from the Materials section.
 
    	Click Inspect Material [image: ]from the Materials section. The Isotropic Material dialog appears showing various properties of the material. You can view the Mechanical, Strength, Durability, Formability and other properties by clicking on each of them.
 
    	Close the Isotropic Material dialog and click OK.
 
    	Use the Measure Bodies tool to see the Mass Properties of the geometry.
 
    	Save and close the file.
 
   
 
    
 
   TUTORIAL 8
 
   In this tutorial, you create a plastic casing.
 
                       [image: ] 
 
   Creating the First Feature
 
    
    	Open a new part file.
 
    	Create a sketch on the XY Plane, as shown in figure.
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    	Click Finish Sketch[image: ].
 
    	Click the Feature > Extrude on the ribbon.
 
    	Set the Distance to 30.
 
    	Expand the Draft section and select Draft > From Start Limit.
 
    	Set the Angle to 2 deg.
 
    	Click OK.
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   Creating the Extruded surface
 
    
     
      
      	Click Feature > Extrude on the ribbon and select the YZ Plane.
 
      	Create a sketch, as shown. Note that there should a Tangent constraint between the arc and the inclined edge of the geometry.
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      	Click Finish.
 
      	On the dialog, under the Limits section, select Start > Symmetric Value.
 
      	Type-in 50 in the Distance box and click OK.
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   Trim Body
 
    
    	On the ribbon, click Extrude > Trim Body[image: ].
 
   
 
    
 
   Now, you need to select the target body.
 
                  
 
    
    	Select the solid body.
 
   
 
    
 
   Next, you need to select the tool body.
 
                    
 
    
    	Select Tool Option > Face or Plane.
 
    	Click Select Face or Plane and select the extruded surface.
 
    	Make sure that the arrow points towards front. You can double-click on it to reverse its direction.
 
    	Click OK to trim the solid.
 
   
 
    [image: ] 
 
    
    	Hide the extruded surface by clicking on it and selecting Hide.
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   Variable Radius Blend
 
    
     
      
      	On the ribbon, click Home > Feature > Edge Blend[image: ].
 
      	Select the edge between the top and curved faces.
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      	Expand the Variable Radius Points section and click Specify New Location.
 
      	Select the three points on the edge, as shown.
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      	Under the Variable Radius Points section, expand the List section.
 
      	Select the radius points one-by-one and change the radius values, as shown.
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      	Click OK to create the variable radius blend.
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   Corner Setbacks
 
    
    	On the ribbon, click Home > Feature > Edge Blend[image: ].
 
    	Set the Radius 1 to 5
 
    	Select the edges of the geometry, as shown.
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    	Expand the Corner Setback section and click Specify End Point.
 
    	Select the vertex point, as shown.
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    	Under the Corner Setback section, expand the List section.
 
    	Select the setback points one-by-one and change the setback values, as shown. You can also change the setback values on the handle attached to the corner.
 
   
 
    
 
    [image: ] 
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    	Under the Edge Blend section, click Select Edge.
 
    	Select the edges, as shown.
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    	Under the Corner Setback section, click Specify End Point.
 
    	Select the vertex point, as shown.
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    	Change the setback values on the handle attached to the corner.
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    	Click OK.
 
   
 
    
 
   Creating a Boss
 
    
    	On the ribbon, click Home > Feature > More > Design Features >Boss[image: ].
 
    	On the Boss dialog, type-in 20 and 30 in the Diameter and Height boxes, respectively.
 
    	Click on the top face of the geometry and click OK.
 
    	On the Positioning dialog, click the Horizontal [image: ]icon.
 
    	Select the edge, as shown.
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    	Select the circular edge on the top face, as shown.
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    	Select the Arc Center button.
 
    	Type-in 30 in the value box and click Apply.
 
    	Click the Perpendicular [image: ]icon and select the YZ plane.
 
    	Type-in 20 in value box and click OK.
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   Split Body
 
    
    	Create a shell feature by removing the bottom face.
 
   
 
    [image: ] 
 
   Notice that the Boss feature is also shelled. To avoid this, you need to separate the boss feature from the other body.
 
    
 
    
    	On the Part Navigator, right click on the Shell feature and select Delete.
 
    	On the ribbon, click Feature > More > Trim > Split Body[image: ].
 
    	Select the model to define the target body.
 
    	Select Tool Option > New Plane.
 
    	Under the Tool section, click Specify Plane.
 
    	Select the top face of the geometry and click OK.
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   Shell with an Alternate Thickness
 
    
    	On the ribbon, click Home > Feature > Shell[image: ].
 
    	Select the bottom face of the geometry.
 
    	Under the Thickness section, type-in 2 in the Thickness box.
 
    	Expand the Alternate Thickness section and click Select Face.
 
    	Select the cylindrical face, as shown.
 
    	Under the Alternate Thickness section, type-in 4 in the Thickness box.
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    	Click OK. 
 
   
 
    [image: ] 
 
   Offset Face
 
    
    	On the ribbon, click Home > Feature > More > Offset/Scale > Offset Face[image: ].
 
    	Select the face of the geometry, as shown.
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    	Drag the arrow handle downward, and release when the offset value is set to 20.
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    	Click OK.
 
   
 
    
 
   Delete Body
 
    
    	On the ribbon, click Home > Feature > More > Trim > Delete Body[image: ].
 
    	Select the boss feature and click OK.
 
    	Save the file.
 
   
 
    
 
   Scale Body
 
    
    	On the ribbon, click Home > Feature > More > Offset/Scale > Scale Body[image: ].
 
    	On the Scale Body dialog, select Type > Uniform.
 
    	Select the geometry.
 
    	Under the Scale Point section, click Specify Point.
 
    	Select the center point of the circular edge, as shown.
 
   
 
    [image: ] 
 
    
    	Type-in 1.05 in the Uniform box.
 
     
      
      	Expand the Preview section and click Show Result.
 
     
 
    
 
    	Click the Undo Result.
 
    	Select Type > General.
 
    	Under the Scale Factor section, type-in 1.2, 1.5, and 0.8 in the X Direction, Y Direction, and Z Direction boxes, respectively.
 
    	Click Show Result.
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    	Click Undo Result.
 
    	Select Type > Axisymmetric.
 
    	Under the Scale Point section, click Specify Vector.
 
    	Select the Z axis from the triad.
 
    	Click Specify Axis Through-point and select the center point the circular edge, as shown.
 
    	Under the Scale Factor section, type-in 2 in the Along Axis box.
 
    	Click Show Result.
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    	Click Cancel.
 
   
 
    
 
   Extract Geometry
 
    
    	On the ribbon, click Home > Feature > More > Associate Copy > Extract Geometry[image: ].
 
    	On the Extract Geometry dialog, select Type > Composite Curve.
 
    	Select the edges of the geometry, as shown.
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    	Click OK.
 
    	On the Part Navigator, right click on the Composite Curve and select Hide Parents. The geometry is hidden.
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    	Right click on the Composite Curve and select Show Parents.
 
    	On the ribbon, click Home > Feature > More > Associate Copy > Extract Geometry[image: ].
 
    	On the Extract Geometry dialog, select Type > Face.
 
    	Select the top face of the geometry and click OK.
 
    	Right click on the extracted face and select Hide Parents.
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    	Right click on the extracted face and select Show Parents.
 
    	On the ribbon, click Home > Feature > More > Associate Copy > Extract Geometry[image: ].
 
    	Select Type > Region of Faces.
 
    	Select the inner horizontal face of the shell feature.
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    	Select the thin planar face to define the boundary.
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    	Under the Region Options section, check the Traverse Interior Edges option.
 
    	Expand the Preview section and click Preview Region.
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    	Click Finished Preview.
 
    	Uncheck the Traverse Interior Edges option.
 
    	Click Preview Region.
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    	Click OK.
 
    	Close the file.
 
   
 
    
 
   TUTORIAL 9
 
   In this tutorial, you will learn the Reorder 
 
   Feature, and Replace Feature tools.
 
    
 
    
    	Download and open the Tutorial 9 file.
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   Notice that the edge blend is applied only on the outside edges of the geometry.
 
    
 
    
    	In the Part Navigator, click the Edge Blend, drag it, and place above the Shell.
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   The edge blend is applied to the inner edges of the shell feature, automatically.
 
    [image: ] 
 
   Replace Features
 
    
    	In the Part Navigator, right click on the Extrude feature and select Make Current Feature. 
 
    	Download the Tutorial 9-Replacement.
 
    	Click File > Import > Part.
 
    	On the Import Part dialog, uncheck the Create Named Group option, leave the default settings, and click OK.
 
    	Browse to the location of the Tutorial 9-Replacement part and double-click on it.
 
    	On the Point dialog, leave the X, Y, and Z values to 0 and click OK.
 
   
 
    [image: ] 
 
    
    	Click Cancel.
 
    	In the Part Navigator, right click on the Shell feature and select Make Current Feature. 
 
    	In the Part Navigator, right click on the first Extrude feature and select Replace. 
 
    	On the Replace Feature dialog, click Select Feature under the Replacement Feature section.
 
    	Select the imported geometry.
 
    	Click the Next [image: ]button in the Mapping section. The back edge of the extrude feature is highlighted.
 
   
 
    [image: ] 
 
    
 
    
    	Select the corresponding edge on the replacement feature.
 
   
 
    [image: ] 
 
    
    	Likewise, select the corresponding references on the replacement feature, and then click OK.
 
   
 
    [image: ] 
 
    
    	Save and close the file.
 
   
 
    
 
   TUTORIAL 10
 
   In this tutorial, you will learn to divide faces, and apply draft using the To Parting Edges option.
 
    
 
    
    	Download and open the Tutorial 10 file and open it.
 
   
 
    [image: ] 
 
    
    	On the ribbon, click Home > Feature > More > Divide Face[image: ]. 
 
    	Select the outer cylindrical face of the geometry.
 
    	Click Select Object under the Dividing Objects section.
 
    	Select the datum plane.
 
    	Leave the Projection Direction to Normal to Face.
 
    	Click OK. The cylindrical face is divided into two parts.
 
   
 
    [image: ] 
 
   Applying Draft using the To Parting Edges option
 
    
    	On the ribbon, click Home > Feature > Draft[image: ]. 
 
    	On the Draft dialog, select Type > To Parting Edges.
 
    	Click Select Plane under the Stationary Plane section.
 
    	Select any point on the parting edge.
 
   
 
    [image: ] 
 
    
    	Select the parting edge and enter 10 in the Angle 1 box.
 
   
 
    [image: ] 
 
    
    	Click OK.
 
    	Save and close the file.
 
   
 
    
 
   TUTORIAL 11
 
   In this tutorial, you will learn to apply draft using the From Plane or Surface option.
 
    
 
    
    	Download and open the Tutorial 11 file and open it.
 
   
 
    [image: ] 
 
    
    	On the ribbon, click Home > Feature > Draft[image: ]. 
 
    	On the Draft dialog, select Type > From Plane or Surface.
 
    	Select the Z-axis from triad to define the drafting direction.
 
    	Under the Draft References section, select Draft Method > Parting Face.
 
    	Click Select Stationary Parting Face under the Draft References section.
 
    	Select the parting surface.
 
   
 
    [image: ] 
 
    
    	Click Select Face under the Faces to Draft section.
 
    	On the Top Border Bar, set the Face Rule to Tangent Faces.
 
    	Select anyone of the tangentially connected faces.
 
   
 
    [image: ] 
 
    
    	Type 10 in the Angle 1 box.
 
    	Check the Draft Both Sides option under the Draft References section.
 
    	Uncheck the Symmetric Angle option under the Faces to Draft section.
 
    	Type 15 in the Below Angle 1 box.
 
   
 
    [image: ] 
 
    
    	Click OK.
 
    	Click on the parting surface and select Hide.
 
   
 
    [image: ] 
 
    
    	Save and close the file.
 
   
 
    
 
   TUTORIAL 12
 
   In this tutorial, you will learn to apply draft using the Tangent to Faces option.
 
    
 
    
    	Download and open the Tutorial 12 file and open it.
 
   
 
    [image: ] 
 
    
    	 On the ribbon, click Home > Feature > Draft[image: ]. 
 
    	On the Draft dialog, select Type > Tangent to Faces.
 
    	Select the Z-axis from triad to define the drafting direction.
 
    	Select the cylindrical face. The faces connected tangentially to the cylindrical face are drafted
 
   
 
    [image: ] 
 
    
    	Type 10 in the Angle 1 box and click OK.
 
   
 
    [image: ] 
 
    
    	Save and close the file.
 
   
 
    
 
   TUTORIAL 13
 
   In this tutorial, you will learn to create Feature groups.
 
    
 
    
    	Download and open the Tutorial 13 file and open it.
 
   
 
    [image: ] 
 
    
 
    
    	On the Top Border Bar, click Menu > Format > Group > Feature Group[image: ].
 
    	Type Rib_with_blends in the Feature Group Name.
 
    	Press the Ctrl key and select Rib (3) and Edge Blend (4) from the Features in Part list.
 
    	Click the Add [image: ] icon to add them to the Features in Group list.
 
    	Click OK. The feature group appears in the Part Navigator.
 
    	Uncheck the Feature Group option in the Part Navigator. The Feature group is suppressed.
 
    	Check the Feature Group option to unsuppress it.
 
    	Save and close the file.
 
   
 
    
 
    
 
  
 
  


 
 
   
   Chapter 7: Expressions
 
    
 
                                 
 
   In this chapter, you will: 
 
    
 
    
    	Use Program Generated Expressions
 
    	Create your own Expressions
 
    	Create Family of Parts
 
    	Create expressions by measuring elements
 
    	Export and Import Expressions
 
   
 
    
 
   TUTORIAL 1
 
   In this tutorial, you will modify the basic expressions which are automatically created by NX.
 
    
 
    
    	Start a new file in the Modeling environment.
 
    	Activate the Direct Sketch mode on the XY plane.
 
    	Create the sketch, as shown.
 
   
 
    [image: ] 
 
    
 
   Notice the expressions that are applied to the dimensions.
 
    
 
    
    	Click Finish Sketch on the ribbon.
 
    	Click Orient View Drop-down > Isometric on the Top Border Bar (or) press the End key.
 
    	On the ribbon, click Home > Feature > Extrude. 
 
    	On the Extrude dialog, set the values in the Limits section, as given below:
 
   
 
    
 
   Start: Value
 
   Distance: 0
 
   End: Value
 
   Distance: 15
 
    
 
    
    	Expand the Offset section and set the values, as given below:
 
   
 
    
 
   Offset: Symmetric
 
   End: 5
 
    
 
    
    	Click OK.
 
   
 
    
 
    [image: ] 
 
    
 
    
    	On the ribbon, click Tools > Utilities > Expression[image: ]. 
 
    	On the Expressions dialog, select Listed Expressions > All. All the expressions in the file are displayed.
 
    	Select the Extrude feature from the graphics window to only display its expressions.
 
    	Select p6 (Extrude (2) Start Offset) from the expressions sheet.
 
   
 
    [image: ] 
 
    
    	Type 3 in the Formula box and click Accept Edit[image: ]. 
 
    	Click OK to update the model.
 
   
 
    [image: ] 
 
    
    	Select the Extrude feature from the Part Navigator.
 
    	Expand the Details section on the Part Navigator.
 
    	Double-click on the Start Limit value and type 10. The model is updated, as shown.
 
   
 
    [image: ] 
 
    
    	Save and close the part file.
 
   
 
    
 
   TUTORIAL 2
 
   In this tutorial, you will create expressions to drive the parameters of a bolt.
 
    
 
    
    	Start a new part file.
 
    	Activate the Extrude command and select the YZ plane.
 
    	Create a circle of 20 mm diameter.
 
   
 
    [image: ] 
 
    
    	Click Finish.
 
    	Extrude the sketch up to 80 mm distance.
 
   
 
    [image: ] 
 
    
    	Activate the Extrude command and select the right end face of the cylinder.
 
    	Create a hexagon, as shown.
 
   
 
    [image: ] 
 
    
    	Click Finish.
 
    	Extrude the sketch up to 10 mm distance.
 
   
 
    [image: ] 
 
    
    	On the ribbon, click Tools > Utilities > Expression[image: ]. 
 
    	On the Expressions dialog, select Listed Expressions > All.
 
    	Select p7 (Extrude (1) Diameter Dimension on Arc1).
 
    	Type Diameter in the Name box and click Accept Edit[image: ].
 
    	Select p18 (Extrude (2) Parallel Dimension between Line1 and Point2).
 
    	Type Diameter in the Formula box and click Accept Edit.
 
    	Select p9 (Extrude (2) End Limit).
 
    	Type 0.75*Diameter in the Formula box and click Accept Edit.
 
    	Click OK to update the model.
 
   
 
    [image: ] 
 
    
    	Select the Extrude (1) feature from the Part Navigator.
 
    	Expand the Details section on the Part Navigator.
 
    	Double-click on the Diameter value and type 10. The model is updated, as shown.
 
   
 
    [image: ] 
 
    
    	On the ribbon, click Home > Feature > More > Design Feature > Thread[image: ]. 
 
    	On the Thread dialog, set the Type to Detailed.
 
    	Select the cylindrical face of the geometry.
 
    	Click OK to create the thread.
 
   
 
    [image: ] 
 
    
    	Press Ctrl+E to open the Expressions dialog.
 
    	Select the Threads feature from the Part Navigator and notice all the expressions related to it.
 
    	Select p19 (Threads (3) Major Diameter).
 
    	Type D in the Name box.
 
    	Type Diameter in the Formula box to make the major diameter value equal to the diameter of the cylinder.
 
    	Click Accept Edit.
 
    	Select p22 (Threads (3) Pitch).
 
    	Type Pitch in the Name box and click Accept Edit[image: ].
 
    	Select p20 (Threads (3) Minor Diameter).
 
    	Type D2 and D-1.08*Pitch in the Name and Formula boxes, respectively.
 
    	Click Accept Edit.
 
    	Select p23 (Threads (3) Length).
 
    	Type Length and 2*D in the Name and Formula boxes, respectively.
 
    	Click Accept Edit and OK. The model is updated, as shown.
 
   
 
    [image: ] 
 
    
    	Select the Extrude (1) feature from the Part Navigator.
 
    	Expand the Details section on the Part Navigator.
 
    	Double-click on the Diameter value and type 20. The model is updated, as shown.
 
   
 
    [image: ] 
 
    
    	Select the Threads feature from the Part Navigator and change the Pitch value in the Details section to 2.5. The pitch and minor diameter of the threads are updated.
 
   
 
    [image: ] 
 
   Instead of updating the pitch and diameter values manually, you can use a spreadsheet to change all the values.
 
    
 
   Creating Family of Parts
 
    
    	On the ribbon, click Tools > Utilities > Spreadsheet[image: ].  The Worksheet in Modeling is opened.
 
    	In the Worksheet environment, click ADD-INS > Extract Expr on the ribbon. The expressions are added to the spreadsheet.
 
    	Copy the contents of column B into column C and D.
 
   
 
    
 
    [image: ] 
 
    
 
    
    	Type M20x2.5, M10x1.25, and M6x0.75 in the first rows of columns B, C, and D, respectively.
 
    	Click in the second row of the column B and change its expression to =EXPRVAL("Diameter")
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    	Likewise, change the expressions of D values in columns C and D to =Diameter.
 
    	Edit the values of the highlighted rows, as shown.
 
   
 
    [image: ] 
 
    
 
    
    	Drag the pointer across the A2 and D13 cells.
 
   
 
    
 
    [image: ] 
 
    
 
    
    	Click ADD-INS > Define Expr Rng on the ribbon.
 
    	Click ADD-INS > Options > NX Preferences.
 
    	Uncheck the Use Fixed Update Range option and click OK.
 
    	Select the contents of the column D.
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    	Click ADD-INS > Update NX Part.
 
    	Save and close the spreadsheet. The part is updated.
 
   
 
    [image: ] 
 
    
    	On the ribbon, click Tools > Utilities > Spreadsheet[image: ].  
 
    	Select the contents of the column C.
 
    	Click ADD-INS > Update NX Part.
 
    	Save and close the spreadsheet. The part is updated.
 
   
 
    [image: ] 
 
    
    	Likewise, select the contents of the column B and click Update NX Part.
 
    	In the spreadsheet, enter the location and part name (for example: C:\Users\Public\Documents\M20x2.5) at the bottom of the B, C, and D columns. The part names should be M20x2.5, M10x1.25, and M6x0.75.
 
    	Drag the pointer across the A2 and D14 cells.
 
   
 
    [image: ] 
 
    
    	Click ADD-INS > Define Fmly Rng on the ribbon. The selected data will be used to create the part family.
 
    	Click ADD-INS > Build Family on the ribbon.
 
    	Close the spreadsheet and click Discard. The part family is created in the specified folder.
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    	Close the part file.
 
   
 
    
 
   TUTORIAL 3
 
    
    	Download the Tutorial 3 file of the Expressions chapter and open it.
 
   
 
    [image: ] 
 
    
    	On the ribbon, click Tools > Utilities > Expressions.
 
    	On the Expressions dialog, select Listed Expressions > Named.
 
    	Type Thickness in the Name box.
 
    	Click the Measure Distance [image: ]icon on the dialog.
 
    	On the Measure Distance dialog, select Type > Length.
 
    	Select the edge of the geometry, as shown.
 
   
 
    [image: ] 
 
    
    	Click OK.
 
    	Click Accept Edit.
 
    	Click OK.
 
    	On the ribbon, click Home > Feature > Shell.
 
    	Select the horizontal face, as shown.
 
   
 
    [image: ] 
 
    
    	Click the down-arrow on Thickness handle and select Formula.
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    	On the Expressions dialog, type Thickness in the Formula box and click Accept Edit.
 
    	Click OK on the Expressions and Shell dialogs.
 
    	Click on the second extruded feature and select Show Dimensions.
 
    	Double-click on the linear dimension and change its value to 10.
 
   
 
    [image: ] 
 
    
    	Click OK on the Feature Dimension dialog.
 
    	Press F5 on your keyboard.
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   TUTORIAL 4
 
    
    	Download the Tutorial 4 file of the Expressions chapter and open it.
 
   
 
    [image: ] 
 
    
    	On the ribbon, click Tools > Utilities > Expressions.
 
    	On the Expressions dialog, select Listed Expressions > All.
 
    	On the Expression dialog, click the Export Expressions to File[image: ].
 
    	Browse to a location to save the file.
 
    	Set the Export Options to Work Part.
 
    	Type Tutorial_4 in the File name box and click OK. The expressions of the model are exported to a text file.
 
    	Open the Tutorial_4.exp file in Notepad or any text editor.
 
    	Modify the expressions in the text file and save it.
 
   
 
    [image: ] 
 
    
    	Switch to NX application window.
 
    	On the Expressions dialog, click the Import Expressions from File [image: ]icon.
 
    	Go to the location of Tutorial_4.exp file and double-click on it.
 
    	Click OK on the Expressions dialog.
 
   
 
    [image: ] 
 
    
    	Save and close the file.
 
   
 
    
 
                  
 
  
 
   
 
   
    
 
   


 
  
 
  
 
 
   
   Chapter 8: Sheet Metal Modeling
 
    
 
                  
 
   This Chapter will show you to: 
 
                  
 
    
    	Construct Tab feature
 
    	Construct Flange       
 
    	Contour Flange      
 
    	Closed corners       
 
    	Louvers        
 
    	Beads        
 
    	Drawn Cut-outs       
 
    	Gussets       
 
    	Flat Pattern              
 
   
 
    
 
   TUTORIAL 1
 
   In this tutorial, you construct the sheet metal model shown in figure.
 
                  [image: ]
 
  
 
   
 
   
    
 
   Opening a New Sheet metal File
 
    
    	To open a new sheet metal file, click Home > New on the ribbon.
 
    	On the New dialog, click NX Sheet Metal.
 
    	Click OK.
 
   
 
    
 
   The NX Sheet Metal ribbon appears, as shown below. 
 
                  
 
    [image: ]               
 
    
 
    
 
   Setting the Parameters of the Sheet Metal part
 
    
    	To set the parameters, click File > Preferences > Sheet Metal
 
   
 
    
 
   On the NX Sheet Metal Preferences dialog, , you can set the preferences of the sheet metal part such as thickness, bend radius, relief depth, width and so on. In this tutorial, you will construct the sheet metal part with the default preferences. Click OK on the dialog.
 
    
 
    [image: ]

 
  
 
   
 
   
   Constructing the Tab Feature
 
    
    	To construct the base feature, click Home > Basic > Tab [image: ]on the ribbon.
 
    	Select the XY plane.
 
    	Construct the sketch, as shown.
 
   
 
    [image: ] 
 
    
    	Click Finish.
 
    	Click OK to construct the tab feature.
 
   
 
    [image: ] 
 
   Adding a flange
 
    
    	To add the flange, click Home > Bend > Flange[image: ] on the ribbon.
 
    	Select the edge on the top face.
 
   
 
                  [image: ]
 
    
    	Set Length to 100.
 
    	Click OK to add the flange.
 
   
 
                  [image: ]
 
    
 
   Constructing the Contour Flange
 
    
    	To construct the contour flange, click Home > Bend > Contour Flange [image: ]on the ribbon. 
 
    	On the Contour Flange dialog, click the Sketch Section [image: ]icon.
 
    	On the Top Border Bar, select Curve Rule > Single Curve.
 
    	Click the edge on the left side of the top face.
 
   
 
    [image: ] 
 
    
 
    
    	On the Create Sketch dialog, under the Plane Location section, type-in 100 in the % Arc Length box. 
 
    	Under the Plane Orientation section, select Reverse Plane Normal.
 
   
 
    [image: ] 
 
    
    	Click OK.
 
    	Draw the sketch, as shown.
 
   
 
    
 
    [image: ]               
 
    
    	Click Finish.
 
    	On the Contour Flange dialog, under the Width section, select Width Option > To End.
 
    	Click on the arrow attached to the sketch.
 
   
 
    [image: ] 
 
    
    	Click OK to construct the contour flange.
 
   
 
    [image: ] 
 
    
 
   Adding the Closed Corner        
 
    
    	To add the closed corner, click Home > Corner > Closed Corner[image: ].
 
    	Select the two bends forming the corner.
 
   
 
    [image: ] 
 
    
    	On the Closed Corner dialog, under the Corner Properties section, select Treatment > Open.
 
    	Click OK to add the open corner.
 
   
 
   
You can also apply corner treatment using the options in the Treatments drop-down. The different types of the corner treatments are given next.
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   Adding the Louver
 
    
    	To add the louver, click Home > Punch > Louver [image: ]on the ribbon.
 
    	Select the front face of the flange.
 
   
 
    [image: ] 
 
    
    	Construct the sketch, as shown in figure.
 
   
 
    [image: ] 
 
    
    	Click Finish.
 
    	On the Louver dialog, select Louver Shape > Formed.
 
    	Type-in 5 in the Depth box and click the Reverse Direction icon below it. 
 
    	Type-in 10 in the Width box and click the Reverse Direction icon below it.
 
    	Click OK to add the louver.
 
   
 
    [image: ] 
 
   Making the Pattern Along curve
 
    
    	On the ribbon, click Home > Feature > Pattern Feature[image: ].
 
    	Select the louver feature.
 
    	On the Louver dialog, under Pattern Definition section, select Layout > Along.  
 
    	Under Direction 1 section, click Select Path.
 
    	On the Top Border Bar, select Curve Rule > Single Curve.
 
    	Select the vertical edge of the flange feature.
 
   
 
                  [image: ]
 
    
    	Under the Direction 1 section, select Spacing > Count and Span.
 
    	Set Count to 3.
 
    	Set % Span By as 60.
 
    	Make sure that the arrow points downwards. You can double-click on it to reverse its direction.
 
    	Click OK to construct the pattern along curve.
 
   
 
    [image: ] 
 
   Adding the Bead
 
    
    	To add the bead, click Home > Punch > Bead [image: ]on the ribbon.
 
    	Select the top face of the tab feature.
 
   
 
    [image: ] 
 
    
    	Draw a line and dimension it.
 
   
 
    [image: ] 
 
    
    	Click Finish on the ribbon.
 
    	Under the Bead Properties section, select Cross Section > Circular.
 
    	Set Depth to 4 and click the Reverse Direction icon below it
 
    	Set Radius to 4.
 
    	Select End Condition > Formed.
 
    	Click OK to add the bead.
 
   
 
    
 
    [image: ] 
 
   Adding the Drawn Cutout
 
    
    	To add the drawn cutout, click Home > Punch > Drawn Cutout [image: ]on the ribbon.
 
    	Select the face of the contour flange.
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    	Draw a circle and dimension it.
 
   
 
    [image: ] 
 
    
 
    
    	Click Finish on the ribbon.
 
    	Set Depth to 10.
 
    	Set Side Angle to 5.
 
    	Select Side Walls > Material Outside.
 
    	Expand the Drawn Cutout dialog and uncheck the Round Section Corners option under the Rounding section.
 
    	Set Die Radius to 3.
 
    	Click OK to add the drawn cutout.
 
   
 
    [image: ] 
 
    
 
   Adding Gussets
 
    
    	To add gussets, click Home > Punch > Gusset [image: ]on the ribbon.
 
    	Click on the bend face of the contour flange.
 
    	On the Gusset dialog, select Type > Automatic Profile.
 
    	Under the Location section, select YC[image: ] from the drop-down.
 
    	Under the Shape section, set Depth to 12.
 
    	Select Form > Round.
 
    	Set Width to 10.
 
    	Set Side Angle to 2.
 
    	Set Punch Radius and Die Radius to 2.
 
    	Click OK to add gussets.
 
   
 
                  [image: ]
 
    
 
   Constructing the Mirror Feature
 
    
    	To construct the mirror feature, click Home > Feature > More > Mirror Feature [image: ]on the ribbon.
 
    	Under the Part Navigator, press the Ctrl key, and then select the contour flange, closed corner, bead feature, and gusset.
 
   
 
    
 
    [image: ]
 
    
 
    
    	Under the Mirror Plane section, click Select Plane.
 
    	Select the YZ plane.
 
   
 
    [image: ]               
 
    
    	Click OK to construct the mirror feature.
 
   
 
    [image: ]               
Making the Flat Pattern
 
    
    	To make the flat pattern, click Home > Flat Pattern > Flat Pattern [image: ]on the ribbon.
 
    	Click on the top face of the tab feature.
 
   
 
                  [image: ]
 
    
    	Uncheck the Move to Absolute CSYS option.
 
    	Click OK to make the flat pattern.
 
    	On the Sheet Metal message, click OK.
 
    	To view the flat pattern, click View > Orientation > More > View Layout > New Layout [image: ]on the ribbon.
 
    	On the New Layout dialog, select FLAT-PATTERN#1 and click OK.
 
   
 
    
 
    [image: ] 
 
    
 
    
    	To view the 3D model, click View > Orientation > More > New Layout on the ribbon.
 
    	On the New Layout dialog, select Isometric and click OK.
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    	Save and close the file.
 
   
 
  
 
   
 
   
    
 
    
 
    
 
                  
 
    
 
  
 
   
 
   
    
 
  
 
   
 
   
    
 
  
 
   
 
   
                  
 
    
 
   
               
 
                  
 
                  
 
   

               
 
   
               
 
    


 
  
 
  
 
 
   
    Chapter 9: Top-Down Assembly 
 
                  
 
   In this chapter, you will learn to
 
    
 
    
    	Create a top-down assembly
 
    	Insert fasteners 
 
    	Create Sequences
 
    	Create Deformable Parts and assemble them
 
   
 
                  
 
   
 
  

TUTORIAL 1
 
   In this tutorial, you will create the model shown in figure. You use top-down assembly approach to create this model.
 
    [image: ]  
 
   Creating a New Assembly File
 
    
     
      
      	Click the New icon on the Quick Access Toolbar, select the Assembly template, and click the Browse icon located next to the Name box.
 
      	Create a new folder and open it.
 
      	Type Tutorial 1 in the File Name box.
 
      	Click OK twice.
 
      	Click Cancel on the Add Component dialog.
 
     
 
    
 
   
 
    
 
   Creating a component in the Assembly
 
   In a top-down assembly approach, you create components of an assembly directly in the assembly by using the Create New tool.
 
                  
 
    
    	On the ribbon, click Assemblies > Component > Create New[image: 1].
 
    	Select the Model template, type Base in the Name box, and click OK.
 
    	Click OK on the Create New Component dialog.
 
    	Click the Assembly Navigator tab on the Resource Bar.
 
    	Double-click on the Base component. The part mode is activated.
 
   
 
    
 
    [image: G:\Excel 2013 Tutors\ii\NX10 tutorial\Assemblies\2.jpg] 
 
    
 
    
    	Click Home > Sketch on the ribbon and select the XY plane from Datum Coordinate System and click OK.
 
    	Create the sketch as shown below.
 
   
 
    [image: G:\Excel 2013 Tutors\ii\NX10 tutorial\Assemblies\3.jpg] 
 
    
    	Click Finish Sketch.
 
    	Click Home > Feature > Extrude on the Ribbon and extrude the sketch up to 40 mm.
 
   
 
    [image: G:\Excel 2013 Tutors\ii\NX10 tutorial\Assemblies\4.jpg] 
 
    
    	Create a cylinder of 50 mm diameter and 95 mm length on the top face.
 
   
 
    [image: G:\Excel 2013 Tutors\ii\NX10 tutorial\Assemblies\5.jpg] 
 
    
 
    
    	On the ribbon, click Home > Features > Hole.
 
    	On the Hole dialog, select Type > General Hole.
 
    	In the Form and Dimensions section, set the parameters, as shown.
 
   
 
    
 
   Form: Counterbored
 
   C-Bore Diameter: 30
 
   C-Bore Depth: 12
 
   Diameter: 25
 
   Depth Limit: Through Body
 
    
 
    
    	Select the center point of the top circular edge.
 
    	Click OK.
 
   
 
    [image: G:\Excel 2013 Tutors\ii\NX10 tutorial\Assemblies\7.jpg] 
 
    
 
    
    	On the ribbon, click the Assemblies > Context Control > Work on Assembly.
 
   
 
    
 
   Creating the Second Component of the Assembly
 
   1.        On the ribbon, click Assemblies > Component > Create New[image: 1].
 
   2.       Select the Model template, type Flange in the Name box, and click OK.
 
   3.       Click OK on the Create New Component dialog.
 
   4.       In the Assembly Navigator, double-click on the Flange to activate the Work part mode.
 
   5.       Click Home > Direct Sketch > Sketch on the Ribbon.
 
   6.       On the Top Border Bar, set the Selection Scope to Entire Assembly.
 
   7.       Select top face of the Base.
 
    [image: ] 
 
   8.       Click OK.
 
   9.       On the ribbon, click Home > Direct Sketch > Project Curve[image: ].
 
   10.     On the Top Border Bar, click the Create Interpart Link [image: ]icon.
 
   11.      Select the circular edge of the Base.
 
    [image: ] 
 
   12.     Click OK twice.
 
   13.     Draw a circle of 120 mm diameter.
 
    [image: ] 
 
   14.     Click Finish Sketch. 
 
   15.     Activate the Extrude tool and extrude the sketch up to 40.
 
    [image: ] 
 
   16.     Click the Part Navigator tab on the Resource Bar and notice the Linked Component Curve(1).
 
   17.     In the Assembly Navigator, double-click on Tutorial 1 to switch to the assembly mode.
 
    
 
   Creating the third Component of the Assembly
 
    
    	On the ribbon, click Assemblies > Component > Create New[image: 1].
 
    	Select the Model template, type Head Screw in the Name box, and click OK twice.
 
    	In the Assembly Navigator, right click on Head Screw and select Make Work Part.
 
    	Start a sketch on the XZ Plane.
 
    	On the ribbon, click Home > Direct Sketch > More Curve > Intersection Curve[image: ].
 
    	On the Top Border Bar, click the Create Interpart Link [image: ]icon.
 
    	On the Top Border Bar, set the Selection Scope to Entire Assembly.
 
    	Rotate the view and select the faces, as shown.
 
   
 
    [image: ] 
 
    
 
    
    	Click OK.
 
    	Right click and select Orient View to Sketch.
 
    	Draw the other lines, as shown.
 
   
 
    [image: ] 
 
    
 
    
    	Click Finish Sketch.
 
    	Activate the Revolve tool and revolve the sketch.
 
   
 
    [image: ] 
 
    
    	Activate the Chamfer tool and chamfer the edges, as shown in figure.
 
   
 
    [image: ] 
 
    
 
    
    	Activate the Edge Blend tool and round the edges, as shown in figure.
 
   
 
    [image: ] 
 
    
    	On the ribbon, click Home > Assemblies > Work on Assembly.
 
   
 
    
 
   Editing the Linked Parts
 
   1.        Right click on the Base and select the Make Work Part.
 
   2.       Select the face of the Base, as shown.
 
   3.       Click Show Dimensions on the Shortcuts toolbar.
 
    [image: ] 
 
    
 
   4.       Change the Diameter dimension to 60 and Linear dimension to 80.
 
   5.       Activate the Assembly mode and notice that the linked parts are also modified.
 
    [image: ] 
 
    
    	On the ribbon, click Assemblies > General > Interpart Link Browser[image: ]. The Interpart Links Browser dialog has two sections: Parts and Interpart Links in Selected Parts.
 
   
 
    
 
   You can edit a link by selecting it and clicking the Edit [image: ]icon. You can also use the Break Link [image: ]icon to remove the link.
 
    
 
    
    	Close the Interpart Link Browser dialog.
 
   
 
    
 
   Creating Hole Series
 
   A hole series is created through different parts of the assembly.
 
    
 
   1.        On the ribbon, click Home > Feature > Hole.
 
   2.       Select the top face of the Flange.
 
   3.       Select Type > Hole Series.
 
   4.       Position the hole using the Reference line, as shown.
 
    [image: ] 
 
   5.       Click Finish.
 
    
 
   Under the Specification section, notice the three tabs: Start, Middle, and End. They are used to set the hole parameters for the three bodies through which the hole passes. For this example, you are required to only set the Start and End parameters.
 
    
 
   6.       Under the Specifications section, click the Start tab and set the parameters, as shown.
 
    
 
   Form: Simple
 
   Screw Type: General Screw Clearance
 
   Screw Size: M12
 
   Fit: Normal (H13)
 
    
 
   7.       Click the End tab and set the parameters, as shown.
 
    
 
   Form: Threaded
 
   Depth Type: Full
 
   Handedness: Right Handed
 
   Depth Limit: Through Body
 
    
 
   8.       Click OK.
 
   9.       Likewise, create three more series holes.
 
    [image: ] 
 
   Adding Fasteners to the assembly
 
    
    	On the ribbon, click Tools > Reuse Library > Fastener Assembly[image: ].
 
    	On the Fastener Assembly dialog, select Type >Hole.
 
    	Select anyone of the holes.
 
    	Click the Add Fastener Assembly [image: ]icon.
 
    	Set the Configuration Name to AM-Hex Bolt/Stacks.
 
    	Under the Fastener Configuration section, click the Remove icon next to Plain Washer, Regular, AM under Top Stacks.
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    	Click OK.
 
    	On the Configuration section, click the Properties [image: ]icon next to Hex Bolt, AM.
 
    	On the Edit Reusable Component dialog, set the (L) Length value to 100. Also, notice the parameters of the hex bolt in the Details section. They are read only.
 
    	Click OK.
 
    	Expand the Settings section and check the Create Constraints Automatically option.
 
    	In the Configuration section, right click on AM-Hex Bolt Stacks and select Save Configuration.
 
    	Type Fastener 1 in the Name box and click OK.
 
    	Click OK to add the fastener assembly.
 
   
 
    [image: ] 
 
    
    	Likewise, create add fasteners to other holes.
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    	Save the assembly and all its parts.
 
   
 
                  
 
   TUTORIAL 2
 
   In this tutorial, you create a sequence of the assembly. 
 
    
 
    
    	Download the Tutorial 2 files of Chapter 9.
 
    	Open the Tutorial_2 assembly file.
 
   
 
    [image: ] 
 
    
    	On the ribbon, click Assemblies > General > Sequence[image: ].
 
    	On the ribbon, click Home > Assembly Sequence > New[image: ].
 
    	On the Resource Bar, click the Sequence Navigator [image: ]tab and select Sequence_1.
 
    	Expand the Details section of the Sequence Navigator and change the Name to Hub Puller.
 
    	In the Details section, double-click in the Value column of the Display Split Screen row. The graphics window is split into two parts. 
 
    	Drag a selection box around the assembly displayed on the right side.
 
    	On the ribbon, click Home > Sequence Steps > Disassemble[image: ]. The disassemble events are displayed under the Preassembled folder of the Sequence Navigator.
 
   
 
    [image: ] 
 
    
    	On the ribbon, click Home > Playback > Play Backwards[image: ]. Notice that the parts are assembled back in a random sequence.
 
    	In the Sequence Navigator, press the Ctrl key and select all the events under the Preassembled folder. 
 
    	Right click and select Delete.
 
    	Select the two instances of Part_4 and click the Disassemble Together [image: ]icon on the ribbon.
 
    	Select the Sequence Group 1 from the Sequence Navigator and change its Name to Pins.
 
    	Select the Part_3 and click the Disassemble icon on the ribbon.
 
    	Likewise, disassemble the other instance of Part_3, Part_2, and Parte_1.
 
    	On the ribbon, click the Record Camera Position[image: ] icon.
 
    	In the Sequence Navigator, select the Pins event and change the Total Duration value in the Details section to 2.
 
    	Likewise, change the Total Duration values of other events to 2.
 
    	On the Playback group of ribbon, change the Playback Speed to 10.
 
    	On the Playback group, click the Export to Movie [image: ]icon.
 
    	Type Hu Puller assembly in the File name box and OK. The movie of the assembly sequence is recorded.
 
    	Click OK on the Export to Movie message.
 
    	Click Finish.
 
    	Open and play the video.
 
    	Close all the parts.
 
   
 
    
 
   TUTORIAL 3
 
   In this tutorial, you create a deformable part and add it to an assembly. 
 
    
 
   Creating the Deformable Part
 
    
    	Download the Tutorial 3 files of Chapter 9.
 
    	Open the Deformable_part.prt file.
 
   
 
    [image: ] 
 
    
    	On the Top Border Bar, click Menu > Tools > Define Deformable Part.
 
    	Leave the default Name value and click Next.
 
    	Select all features from the Features in Part list and click Add Feature[image: ].
 
    	Click Next.
 
    	Select Pitch = 15 from the Available Expressions list and click Add Expression[image: ].
 
    	Type Pitch in the box below the Deformable Input Expressions list.
 
    	Set the Expression Rules to By Number Range.
 
    	Type 8 and 15 in the Minimum and Maximum boxes.
 
    	Click Next and Finish.
 
    	Save and close the file.
 
   
 
    
 
   Adding the Deformable part to an Assembly
 
    
    	Open the Tutorial 3 assembly file.
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    	On the ribbon, click Assemblies > Component > Add.
 
    	Click the Open icon on the Add Component dialog.
 
    	Go to the location of the Deformable_part.prt file and double-click on it.
 
    	Set Positioning to By Constraints.
 
    	Select Reference set > Entire Part.
 
    	Click OK.
 
    	On the Add Constraints dialog, select Type > Touch Align.
 
    	Select Orientation > Touch.
 
    	Select the bottom flat face of the deformable part.
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    	Select the flat face of the plate, as shown.
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    	Select the top flat face of the deformable part.
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    	Select the flat face of the upper plate, as shown.
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    	Select Orientation > Infer Center/Axis.
 
    	Select the Z-axis of the deformable part.
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    	Select the select circular edge of the plate.
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    	Click OK.
 
    	Change the Pitch value on the Deformable_part dialog to 10 by dragging the slider.
 
    	Click OK.
 
   
 
    [image: ] 
 
    
    	On the Resource Bar, click the Part Navigator tab.
 
    	Right click on the Deformable_part feature and select Edit Parameters.
 
    	Drag the slider to change the pitch value to 15.
 
    	Click OK. The assembly is updated.
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    	Save and close the files.
 
   
 
    
 
    
 
    
 
    
 
                    
 
    
 
    
 
   
 
  


 
  
 
   
 
   
   Chapter 10: Dimensions and Annotations
 
                  
 
                  
 
   In this chapter, you will learn to
 
    
 
    
    	Create Centerlines and Center Marks
 
    	Edit Hatch Pattern
 
    	Apply Dimensions
 
    	Place Datum Feature
 
    	Place Feature control frame
 
    	Place Surface Finish symbol
 
   
 
    
 
                  
 
   TUTORIAL 1
 
   In this tutorial, you create the drawing shown below.
 
                  [image: ]
 
  
 
   
 
   
    
     
      
      	Download the Adapter Plate file of Chapter 10.
 
      	Start NX 10 and click the New icon on the ribbon.
 
      	Click the Drawing tab, select Relationship > Reference Existing Part.
 
      	Select the A4 template.
 
      	Click the Browse icon under the Part to create a drawing of.
 
      	Click Open on the Select master part.
 
      	Go to the location of the Adapter Plate file and double-click on it.
 
      	Click OK on the Select master part and New dialogs.
 
      	Type values on the Populate Title Block dialog and click Close.
 
     
 
    
 
   
 
    
 
   Creating a View with Center Marks
 
    
 
    
    	Click the Reset button on the View Creation Wizard.
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    	Click the Next button on the View Creation Wizard.
 
    	On the Options page, leave the Show Centerlines option selected.
 
    	Click Next.
 
    	Select Front view and click Finish.
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    	Select the view and press Delete.
 
    	On the ribbon, click Home > View > Base View.
 
    	On the Base View dialog, expand the Settings section and click the Settings [image: ] icon.
 
    	On the Settings dialog, click General from the tree.
 
    	On the General page, uncheck the Create with Centerlines option and click OK.
 
    	Select Model View to Use > Front.
 
    	Set the Scale value to 2:1.
 
    	Click on the drawing page, as shown.
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    	Close the Projected View dialog.
 
    	Click Home > View > Section View on the Ribbon.
 
    	Select the center point of the front view.
 
    	Place the section view on the right side.
 
    	Click Close.
 
   
 
                  [image: ]                 
 
   Creating Centerlines and Center Marks
 
    
    	Click Home > Annotation > Center Mark > Bolt Circle Centerline [image: ]on the Ribbon.
 
    	On the Bolt Circle Centerline dialog, select Type > Through 3 or More Points.
 
    	Leave the Full Circle option checked.
 
    	Select the counterbore hole pattern.
 
    	Drag the arrow that appears on the centerline to change its Extension length.
 
   
 
    [image: ] 
 
    
    	Click OK.
 
    	Click Home > Annotation > Centerline drop-down> Circular Centerline [image: ]on the Ribbon.
 
    	On the Circular Centerline dialog, uncheck the Full Circle option.
 
    	Select the center points of the arcs, as shown.
 
   
 
    [image: ] 
 
    
    	Click OK.
 
    	Click Home > Annotation > Centerline drop-down> 2D Centerline [image: ]on the Ribbon.
 
    	On the 2D Centerline dialog, select Type > By Points.
 
    	On the Top Border Bar, activate the Control Point and Intersection icons, and deactivate the Arc Center icon.
 
   
 
    [image: ] 
 
    
 
    
    	Select the points on the slot, as shown.
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    	Drag the arrow to reduce the length of the centerline.
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    	Click Apply.
 
    	Likewise, create centerlines on other slots, as shown.
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    	Click Home > Annotation > Centerline drop-down> Automatic Centerline [image: ]on the Ribbon.
 
    	Select the front view and click OK.
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   Editing the Hatch Pattern
 
    
    	Double-click on the hatch pattern of the section view. The Crosshatch dialog appears.
 
    	On the Crosshatch dialog, expand the Settings section and notice options to modify the hatch pattern.
 
   
 
                          
 
   You can select the required hatch pattern from the Pattern drop-down. You can adjust the distance, angle, color, width, boundary curve tolerance.
 
   You can also select a different set of hatch patterns from the Crosshatch Definition drop-down.
 
                          
 
    
    	Click OK.
 
   
 
                 
 
   Applying Dimensions
 
    
    	On the Top Border Bar, click Menu > Tools > Drafting Standard.
 
    	On the Load Drafting Standard dialog, select Standard > ASME.
 
    	Click OK.
 
    	Click Home > Dimension > Rapid Dimension on the Ribbon.
 
    	On the Rapid Dimension dialog, under the Measurement section, select Method > Vertical.
 
    	Select the horizontal edge and the outer arc of the front view.
 
    	Move the pointer toward left and click.
 
   
 
    
 
    [image: ] 
 
    
 
    
    	On the Rapid Dimension dialog, select Method > Radial.
 
    	Create radial dimensions by selecting the circular centerlines, outer arc, and slot arc.
 
   
 
    [image: ] 
 
    
    	On the Rapid Dimension dialog, select Method > Diametral.
 
    	Select the counterbore hole and position the diameter dimension, as shown.
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    	On the Rapid Dimension dialog, select Method > Angular.
 
    	Select the 2D centerlines of the slot and position the angular dimension, as shown.
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    	Likewise, create another angular dimension, as shown.
 
   
 
    
 
    [image: ] 
 
    
 
    
    	On the Rapid Dimension dialog, under the Measurement section, select Method > Cylindrical.
 
    	Zoom to the section view and select the end points, as shown.
 
    	Move the pointer right and position the dimension.
 
   
 
    [image: ] 
 
    
    	Select the horizontal edges of the hole and position the dimension, as shown.
 
   
 
    [image: ] 
 
    
    	Create another cylindrical dimension for the counterbore hole.
 
    	Click Home > Dimension > Linear Dimension [image: ]on the Ribbon.
 
    	Select the vertices of the section view, as shown.
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    	Move the pointer up and place the pointer.
 
    	On the Linear Dimension dialog, expand the Dimension Set section and select Method > Chain.
 
    	Select the vertex of the section view, as shown.
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    	Click Close on the dialog.
 
    	Drag the dimension 6 toward left. 
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   Attach Text to Dimensions
 
    
    	Zoom to the front view and double-click on diameter 3.
 
    	Click the Arrow Out Diameter [image: ]on the palette.
 
    	Click the Edit Appended Text [image: ]icon.
 
    	On the Appended Text dialog, select Text Location > Above.
 
    	Type the text in the box available on the dialog. Also, use the diameter symbol available in the Symbol section.
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    	Select Text Location > Before.
 
    	Click the Insert Counterbore [image: ]icon in the Symbols section.
 
    	Select Text Location > After.
 
    	Click the Insert Depth icon in the Symbols section and type 1.
 
    	Click Close on the dialog.
 
    	Drag the dimension, as shown.
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    	Likewise, attach text to the radius dimension of the slot.
 
   
 
    [image: ] 
 
    
    	Double-click on the radius dimension.
 
    	Click on the square dot attached to the arrow.
 
    	Select the Out option from the handle.
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    	Likewise, change the arrow direction of the other radial dimensions.
 
   
 
    [image: ] 
 
    
    	Double the counterbore dimension.
 
    	On the palette, select Bilateral Tolerance from the Tolerance drop-down. 
 
    	Type +0.1 and -0.1 in the tolerances boxes.
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    	Click Close.
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   Placing the Datum Feature Symbol
 
    
    	Click Home > Annotation > Datum Feature Symbol[image: ]on the Ribbon.
 
    	On the Datum Feature Symbol dialog, expand the Leader section and click Select Terminating Object.
 
    	Select the extension line of the dimension, as shown below.
 
   
 
    
 
    [image: ] 
 
         
 
    
 
    
    	Move the cursor downward and click.
 
    	On the Datum Feature Symbol dialog, type B in the Letter box under the Datum Identifier section.
 
    	Click Select Terminating Object and select the vertical edge of the section view, as shown.
 
    	Move the pointer towards right and click.
 
    	Click Close.
 
   
 
    
 
    [image: ] 
 
    
 
   Placing the Feature Control Frame
 
    
    	Click Home > Annotation > Feature Control Frame on the Ribbon.
 
    	On the dialog, select Circular Runout from the Characteristic drop-down.
 
    	Type-in 0.02 in the Tolerance box.
 
    	Select A from the Primary Datum Reference drop-down.
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    	Place the pointer on the counterbore diameter dimension.
 
    	Click when a dashed rectangle appears.
 
   
 
    [image: ] 
 
    
    	On the dialog, select Parallelism from the Characteristic drop-down.
 
    	Type-in 0.02 in the Tolerance box.
 
    	Select B from the Primary Datum Reference drop-down.
 
   
 
    
    	Expand the Leader section, and click Select Terminating Object.
 
    	Select an edge parallel to the Datum B.
 
    	Click Select Terminating Object and select another edge which is parallel to the Datum B.
 
   
 
    [image: ] 
 
    
    	Click Close.
 
   
 
    
 
   Placing the Surface Texture Symbols
 
    
    	Click Home > Annotation > Surface Finish Symbol[image: ]on the Ribbon.
 
    	Set the Roughness (a) value to 63 on the dialog.   
 
    	Click on the inner cylindrical face of the hole, as shown below.
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    	Click Close. 
 
    	Save and close the file.
 
   
 
    
 
                  
 
  
 
  


 
 
   
   Chapter 11: Simulation Hands on Tutorial 
 
    
 
   TUTORIAL 1
 
   In this tutorial, you perform Finite Element Analysis on a part.
 
    
 
    
    	Download the Tutorial 1 part file of Chapter 11, and open it.
 
   
 
    [image: ] 
 
    
    	On the ribbon, click Application > Simulation Advanced[image: ].
 
    	On the Simulation Navigator, select Tutorial 1.prt.
 
    	On the ribbon, click Home > Context > New FEM and Simulation[image: ].
 
    	Leave the Create Idealized Part option checked. Notice the three file types (FEM, Simulation, and Idealized): Tutorial 1_fem1.fem, Tutorial 1_sim1.sim, Tutorial 1_fem1_i.prt displayed on the dialog. Note that three files are created in addition to the main part file.
 
    	Under the Solver Environment section select Solver > NX NASTRAN.
 
    	Select Analysis Type > Structural.
 
    	Click OK.
 
    	Leave the default options on the Solution dialog and click OK.
 
   
 
    
 
   On the Simulation Navigator, notice the Status of the Simulation and FEM files. 
 
    [image: ] 
 
    
 
    
    	Expand the Simulation File View section, right click on Tutorial 1_sim1, and click Save. The simulation tools are displayed on the ribbon.
 
   
 
    
 
    [image: ] 
 
    
 
   Preparing the Idealized Part
 
    
    	Hide the Simulation File View section.
 
    	On the Simulation Navigator, expand the Tutorial 1_fem1.fem node, right click on Tutorial 1_fem1_i.prt, and click Make Displayed Part (or) click View > Window > Tutorial 1_fem1_i.prt on the ribbon.
 
    	Click OK on the Idealized Part Warning message box. Notice the Status of the idealized part.
 
   
 
    
 
    [image: ] 
 
    
 
    
    	On the ribbon, click Home > Start > Promote[image: ].
 
    	Select the geometry from the graphics window and click OK. The program establishes an associative link between the idealized part and the main part file.
 
   
 
    
 
   Now, you need to prepare the idealized part by removing some features such as holes and blends.
 
    
 
    
    	On the ribbon, click Home > Synchronous Modeling > Delete Face[image: ].
 
    	On the Delete Face dialog, select Type > Hole, and uncheck the Select Holes by Size option.
 
    	Select the cylindrical face of the counterbore, as shown.
 
   
 
    [image: ] 
 
    
 
    
    	Select the other counterbore holes, as shown.
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    	Click Apply to delete the counterbore holes.
 
    	On the Delete Face dialog, select Type > Blend.
 
    	Select the edge blends of the geometry and click OK.
 
   
 
    [image: ] 
 
    
    	Click Save on the Quick Access Toolbar. Now, you need to switch to FEM file.
 
   
 
    
 
   Meshing the FEM file
 
    
    	On the ribbon, click Home > Context > Change Displayed Part[image: ].
 
    	Select Tutorial 1 _fem1.fem and click OK.  The Information window appears showing the CAE Polygon Update Log.
 
    	Close the Information window. Also, notice the Status of the Tutorial 1 _ fem1.fem file on the Simulation Navigator.
 
    	On the ribbon, click Home > Properties > Mesh Collector[image: ].
 
    	On the Mesh Collector dialog, select Element Family > 3D.
 
    	Click the Create Physical Properties [image: ]icon.
 
    	On the PSOLID dialog, type Cantilever in the Name box.
 
    	Click the Choose Material [image: ]icon.
 
    	On the Material List dialog, select Steel from the Material section and click OK.
 
    	Click OK on the PSOLID and Mesh Collector dialogs.
 
    	On the ribbon, click Home > Mesh > 3D Tetrahedral[image: ].
 
    	Select the geometry from the graphics window.
 
    	On the 3D Tetrahedral Mesh dialog, select Type > CETRA (10). You can also set the element type to CETRA (4).
 
    	Set the Element Size to 3.
 
    	Expand the Destination Collector section, uncheck the Automatic Creation option, and make sure that the Mesh Collector is set to Solid (1).
 
    	Click OK to generate the mesh.
 
   
 
    [image: ] 
 
    
 
   You can edit or remove the mesh from the Simulation Navigator. 
 
    
 
    
    	Expand the 3D Collector node in the Simulation Navigator and notice the mesh properties.
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    	Click Save on the Quick Access Toolbar.
 
   
 
    
 
   Applying Loads and Constraints to the Simulation file
 
    
    	On the ribbon, click Home > Context > Change Displayed Part[image: ].
 
    	Select Tutorial 1 _sim1.sim and click OK.  
 
    	On the Simulation Navigator, expand the Tutorial 1_fem1 node and uncheck the 3D Collectors node. The mesh is turned OFF.
 
    	On the ribbon, click Home > Loads and Constraints > Load Type > Force[image: ].
 
    	Select the holes, as shown.
 
   
 
    
 
    [image: ] 
 
    
    	Under the Magnitude section, type 2000 in the Force box.
 
    	Under the Direction section, click Specify Vector and select the Z-axis from the triad.
 
    	Click the Reverse Direction [image: ]button.
 
    	Click OK to apply the Force load.
 
    	On the Simulation Navigator, expand the Load Container node, right click on Force 1, and select Edit Display.
 
    	On the Boundary Condition Display dialog, drag the Scale slider to reduce the size of the load arrows.
 
    	Click OK.
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    	On the ribbon, click Home > Loads and Constraints > Constraint Type > Fixed[image: ].
 
    	Select the back face of the geometry and click OK.
 
   
 
    [image: ] 
 
   Simulating the Model
 
   Now, you need to check whether the simulation model is setup properly.
 
    
 
    
    	On the ribbon, click Home > Checks and Information > More > Model Setup[image: ].
 
    	Leave all the options checks on the Model Setup dialog and click OK. 
 
   
 
    
 
   The program checks for any errors during the model setup and displays them in the Information window. Also, the Solution-Based Errors Summary displays the following information.
 
    
 
   Solution-Based Errors Summary
 
   -----------------------------
 
    
 
   Iterative Solver Option
 
   More than 80 percent of the elements in this model are 3D elements.
 
   It is therefore recommended that you turn ON the Element Iterative Solver in the "Edit 
 
   Solution" dialog.
 
    
 
    
    	Close the Information window.
 
    	On the Simulation Navigator, right click on Solution1 node and select Edit.
 
    	On the Solution dialog, check the Element Iterative Solver option, and click OK.
 
    	Click Save on the Quick Access Toolbar.
 
    	On the ribbon, click Home > Solution > Solve[image: ].
 
    	Click OK on the Solve dialog.
 
    	Close the Information window, Solution Monitor, and click Cancel on the Analysis Job Monitor dialog.
 
    	On the ribbon, click Home > Context > Change Display Part > Open Results[image: ].
 
    	On the Post Processing Navigator, go to Solution 1 > Structural > Stress - Element-Nodal.
 
    	Double-click on Von-Mises. The result will appear.
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    	On the ribbon, click Results > Animation > Play[image: ]. The model is simulated in the graphics window.
 
    	Click Stop [image: ]on the Animation group.
 
    	On the Post Processing Navigator, expand Solution 1 > Structural > Displacement – Nodal.
 
    	Double-click on Z. The result will appear.
 
   
 
    [image: ] 
 
    
 
    
    	On the ribbon, click Results > Context > Return to Home[image: ].
 
    	Click File > Close > All Parts.
 
    	Click Yes Save and Close.
 
    	Click Yes.
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   Add Fastener Assembly, 108
 
   Align, 26
 
   Align/Lock, 26
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   Arc, 47
 
   Arrow Out Diameter, 117
 
   Assembly, 25
 
   Assembly Constraints, 27
 
   Assign Materials, 77
 
   Auto Balloon, 42
 
   Automatic Centerline, 114
 
   Base View, 36, 42
 
   Bead, 100
 
   Block, 22
 
   Bolt Circle Centerline, 113
 
   Bond, 26
 
   Boolean, 20, 62
 
   Borders and Zones, 40
 
   Boss, 80
 
   Bottom-Up Approach, 25
 
   Break Link, 107
 
   Build Family, 92
 
   Center, 26
 
   Chain, 116
 
   Chamfer, 54, 72
 
   Circle, 13, 48
 
   Circle by 3 Points, 45
 
   Circular, 66
 
   Circular Centerline, 114
 
   Closed Corner, 98
 
   Component Position, 27
 
   Concentric, 26, 30
 
   Conic, 52
 
   Contour Flange, 97
 
   Convert to Reference, 51
 
   Create Interpart Link, 105
 
   Create New, 104
 
   Create Physical Properties, 121
 
   Create Snapshot Data, 41
 
   Customize dialog, 5
 
   Cylinder, 64
 
   Cylindrical, 38
 
   Datum Feature Symbol, 118
 
   Datum Plane, 58
 
   Define Deformable Part, 109
 
   Define Expr Rng, 91
 
   Define Fmly Rng, 92
 
   Define Title Block, 41
 
   Delete Body, 82
 
   Delete Face, 120
 
   Delete Third Curve, 54
 
   Details section, 88
 
   Disassemble Together, 109
 
   Displayed Part, 121, 122
 
   Distance, 26
 
   Divide Face, 85
 
   Draft, 22
 
   Drafting, 39
 
   Drafting Preferences, 37
 
   Drafting Standard, 115
 
   Drawn Cutout, 100
 
   Edge Blend, 20, 63, 78
 
   Edit Appended Text, 117
 
   Edit Background, 11
 
   Edit Explosion, 31
 
   Edit Parameters, 72
 
   Edit Sheet, 35
 
   Ellipse, 50, 60
 
   Emboss, 63
 
   Equal Length, 49
 
   Equal Radius, 49
 
   Export Expressions to File, 93
 
   Expression, 88
 
   Extract Expr, 90
 
   Extract Geometry, 82
 
   Extrude, 14
 
   Fastener Assembly, 108
 
   Feature Based, 1
 
   Feature Control Frame, 118
 
   Feature Group, 87
 
   FEM and Simulation, 120
 
   File Menu, 3
 
   Fillet, 54
 
   Fit, 14, 26
 
   Fit View to Selection, 15
 
   Fix, 26, 27
 
   Flange, 96
 
   Flat Pattern, 102
 
   Force, 122
 
   From Plane or Surface, 86
 
   Fully Constrained, 14
 
   Geometric Constraints, 18, 51
 
   Groove, 59
 
   Gusset, 101
 
   Helix, 57
 
   Hole, 70
 
   Hole Series, 107
 
   Import, 84
 
   Import Expressions from File, 93
 
   Infer Center/Axis, 26
 
   Insert Counterbore, 117
 
   Interpart Link Browser, 107
 
   Intersect, 69
 
   Intersection Curve, 106
 
   Line, 16, 51
 
   Linear, 66
 
   Linear Dimension, 116
 
   Louver, 99
 
   Make Corner, 53
 
   Make Current Feature, 84
 
   Make Symmetric, 16
 
   Mark as Template, 41
 
   Measure Bodies, 76
 
   Measure Distance, 92
 
   Menu, 7
 
   Mesh Collector, 121
 
   Midpoint, 49
 
   Mirror Curve, 55, 61
 
   Mirror Feature, 101
 
   Model Setup, 122
 
   More Gallery, 6
 
   New, 18
 
   New Explosion, 31
 
   New Layout, 102
 
   Offset Curve, 53, 75
 
   Offset Face, 81
 
   Open Results, 123
 
   Orient View Drop-down, 14
 
   Orient View to Sketch, 106
 
   Over Constrained, 14
 
   Pan, 18
 
   Parallel, 26, 51
 
   parametric, 1
 
   Part List, 42
 
   Part Navigator, 7
 
   Pattern Along curve, 99
 
   Pattern Feature, 66
 
   Perpendicular, 26, 51
 
   Polygon, 45, 52, 75
 
   Profile, 18, 47
 
   Project Curve, 16, 105
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